3 years of this: Cannot connect to network shares over 10GbE, but WiFi & 1GbE work fine

Currently reading
3 years of this: Cannot connect to network shares over 10GbE, but WiFi & 1GbE work fine

Operating system
  1. macOS
Mobile operating system
  1. iOS
Last edited:
ℹ️ Latest development, May 22, 2022:
As suggested by a friend, I tried connecting the Mac directly to the NAS. This solved the problem below.

When putting the cabling back together, I didn’t connect the built-in 1Gbps port on the NAS, so now only the 10GbE interface is connected to the switch. Aaaand… the Mac can now see the NAS and connect to it, and the transfer speeds are what they are supposed to be. Now, I’m not convinced this is 100% the cause of the problem, because I had only connected that port recently so I could wake up the DiskStation with a WOL message. For most of the past 3 years with this issue, only the 10GbE adapter on the DiskStation has been connected.

Hi, everyone. I’ve been struggling with this for over 3 years and two Macs now. Let me explain:

Back in 2019, I had a Mid-2017 iMac. I purchased a Synology DS1819+ with a 10GbE network card, a 10GbE Netgear switch, and a 10GbE Thunderbolt 3 adapter for the iMac. Things were working fine for a while, and I would get great transfer speeds, upwards of 600 MB/s, between the iMac and the Synology.

Fast forward a few weeks, and then I couldn’t connect to my Synology with the 10GbE adapter. Here’s what I get:

  • Pinging the Synology works, no matter if I address it by its hostname or its two IPs (one on its 10GbE interface and another on the built-in 1GbE). The connection is solid, with no dropped packets.
  • Finder shows the Synology hostname in the left sidebar and in the Network section. I can open it and it shows me the list of network shares.
  • If I try to connect to any of those, the Finder just shows a “Loading” overlay but never actually connects.
  • The same thing happens if I use cmd+K and directly connect to smb://synology_name.local. I get a login prompt, which acknowledges my username and password, and then a small window appears while the connection is being established. But it never manages to connect.
  • Even though I can ping my Synology successfully by its hostname, I can NOT open the Synology admin webpage at synology_name.local. What I can do is open it with the remote access that Synology provides, at synology_name.synology.me —that works just fine.
  • The Finder becomes unresponsive and even locks up if I try this too much. Folder contents, such as ongoing downloads, are not properly updated, saved files do not appear even when they‘re actually there… Finder just loses grip with reality. It won’t even allow the computer to be properly shut down and requires me to restart Finder or forcibly power off the Mac.
  • When I switched to the 1GbE port on the iMac, everything worked just fine.

I thought the cause might be the 10GbE network adapter, so over the years, I tried TWO additional adapters, with the same result. They worked for a while, maybe weeks, even months, but the same problems reappeared. I switched back to the integrated 1GbE port, then tried the 10GbE adapter again, and it would sometimes work, but it would inevitably fail again. A clean macOS install would fix things back then, and I could use my Synology over the 10GbE adapter for months, but it was just a matter of time until I had the same issues.

Fast forward to 2022. I get a Mac Studio, with its awesome 10GbE port. I thought it would finally put an end all these problems I’ve been having.
I migrated my iMac install: The problem persisted.
I erased everything and installed macOS Monterey from scratch: The problem was there from day one.

Yesterday, a friend of mine who’s more versed in the technical side of macOS asked me to generate a system log so he could have a look at it. He found an interesting section with some mDNSResponder errors. Here it is:


I also have a second, older Synology DiskStation I use to back up the contents of the main one. It only has a 1GbE port, and I also have the same issues when I try to connect with the 10GbE interface on the Mac Studio. This one is more erratic, as I can sometimes connect and open the admin webpage. But it still fails most of the time.

Any help will be appreciated. I don’t really know what to think at this point, after 3 years dealing with this.
Thanks everyone and regards from Spain.
Interesting :)
Just to get a bit more background: do you use SMB or AFP?
Did you check the protocol settings on both ends like same MTU etc?
Upvote 0
Last edited:
Just to get a bit more background: do you use SMB or AFP?
Did you check the protocol settings on both ends like same MTU etc?
Hi there. Mostly SMB, but I tried AFP on one of the shares to test the transfer speed. About the protocol settings, yes, I matched those for each 10GbE network adapter I’ve had and the DiskStation, but the problem persisted. I will recheck them, though.

(I’ve just updated the post with a new development)
Upvote 0
Today, it wasn’t working anymore. I couldn’t connect to my network shares, and couldn’t open the admin URL. I tried lowering the MTU value on my Mac network interface to 1500, and suddenly everything started working again.
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

More like /volume1/name_of_folder/ Make sure to name the volume correctly
Thank you for your reply. Netatmo supports only simple FTP...
I'm using smb only on my windows pc. I have android devices with kodi but there i'm using NFS without any...

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads