Solved Active Backup and NTFS disk with Bad block(s)

Currently reading
Solved Active Backup and NTFS disk with Bad block(s)

jeyare

Subscriber
1,800
592
As some of you know I like it Synology Active Backup for Business package (ABB). I have 3 sites, with 20+ WIN10 based computers in total (also Linux, but this not the case). ABB is in everyday operation, tested Restore scenarios. Great tool.

What I found yesterday:
In my 3rd (remote) site, what is 1400km from my home I prepared new DS718+ mainly for ABB and Drive service operation.
I can't regularly finish ABB in one computer, what contains 9 disks in operation. Doesn't matter when bare metal or other methods.

Problem behavior:
physical disk 0 - (3 logical volumes - system, recovery, efi)
disk type -SSD
Disk vendor: Intel
Disk family: SSD 510 Series (MLC)
Disk ID: Intel SSDSC2MH120A2
Capacity: 120GB
Disk Power ON time till today: 605days + 4hours = 14,524 hours (from 1,200,000 Hours to MTBF)
Current disk Media Wearout Indicator: 233 … (what is pretty good, when 1 indicated action for the disk replacement)
Logical volumes geometry:
1579432194448.png

For the System (NTFS) partition remains 33.8GB available space, then 77,43GB is used now.

Screenshot from ABB: ... error code 1117 ... 5 times repeated w/o success
1579432266403.png

When yo can find an answer for such Error code - especially - during backup (no recovery) process you find just a mess.

Analyze:
Because the computer is far away from me - then there is not possibility to put it to my Linux lab, then I tried to check the disk with my WIN favorite tool - Hard Disk Sentinel Pro (now in v5.50). It's little bit old fashioned UI, but the tool is for disk check powerful.

Result of the disk check:
1. SMART extend test
1579432684879.png

don't be full, when SMART will tell you, that disk is OK, you need more advanced attitude

2. Extended Surface test
Error Code 1117 – disk I/O read error at:
Sector 68300133
Affected file: C:\Program Files\Microsoft Office\root\Office16\PUBWIZ\STORYBB.DPV
Written in sectors: 66 067 944 – 66 068 703
MY NOTE: isn’t readable

Sector 67 193 370
Affected file: C:\Program Files\NVIDIA Corporation\Installer2\Display.Driver.{FF4E8B6D-2C19-4F7C-ABDD-B1A135C4551A}\nvdispco64.dll
Written in sectors: 67 190 576 – 67 193 951
MY NOTE: is readable

Sector 67 193 370
Affected file: Unused sector on logical drive C:\
Written in sectors: no
MY NOTE: is free

Sector 67 193 370
Affected file: C:\xxxxxx\ManualSave_733a0_7e212000_5e325c2.sav ..... (yes someone has play Witcher game) :cool:
Written in sectors: 68 435 856 – 68 437 935
NOTE: isn’t readable

Disk geometry: single Block = 23 445 sectors = 11.45MB

Another point:
Similar situation found in another HDD in this computer - single Bad block discovered.

Final result:
When your disk has BAD block, what is still not DAMAGE status. You can't make BACKUP by ABB from such disk.
You cant mark this BAD block (specially in system disk) when you have NTFS, even with chdsk system command you can't change it. Then you can't use ABB, because snapshot every time fails, when it found BAD block in the disk.

Thankfully, I have paid version Acronis True Image 2019 (used from 2008). And problem is now solved:
- backup of the sick disks
- for the system disk, there is just one recommended way - buy new one (done) - then clone the disk by such tool as Acronis
Then you can use the ABB regularly - till first BAD block discovery.

What about you?
 

jeyare

Subscriber
1,800
592
Now I'm waiting for a response from Syno Support (ticket issued) for an explanation - how to create backup from disk with single or more BAD block (sectors), when the amount of the such corruption is under 0,0004% of entire disk space.
Because they have unconsidered idea in ABB, how to backup disk with bad sectors (based on my observation). Acronis (an others) knows it - how to do it - there is an implementation (a checkbox in UI) include/exclude bad sectors.
Finally when you need save a data, there is no question with or without bad sectors - specially when the corrupted block (data contained) aren't fragmented and not used by system for a boot or something important.

To be sure, this case is not about e.g. 600 damaged block in disk. This is about few blocks (1-10). OFC up to your disk geometry (how much sectors (also MB) for single block. In my case it is about:
single Block = 23 445 sectors = 11.45MB from 120GB
 

Telos

Subscriber
1,318
440
NAS
DS418play, DS213j, DS3621+, DSM 7.0.4-11091
Sorry to hear this. Veeam and Macrium Reflect have options to skip bad blocks/ignore bad sectors.

Can you run
Code:
chkdsk c: /r
on remote unit to remap bad sectors?
 

jeyare

Subscriber
1,800
592
Sorry to hear this. Veeam and Macrium Reflect have options to skip bad blocks/ignore bad sectors.

Can you run
Code:
chkdsk c: /r
on remote unit to remap bad sectors?

Thx,
as I wrote, Acronis is trustworthy for me from 2008. Second disk (no system, HDD) from two affected is now recovered:
- chkdsk is too slow and it can't help you to wipe out entire disk. Acronis has such "combo" with several methods (from standard zero or FF for each sector to DoD ...).
- then new partition create and hard format to NTFS

System disk is covered by backups from Acronis with these different methods:
- include bad sectors (to be sure)
- exclude bad sectors ... this is missing in ABB, and this is real bottleneck of ABB for NTFS
- bare metal (sector by sector include empty space).

Win chkdsk (it was my first attempt) was not able replace data from the bad sectors, finished with error.

What is important -this case is just for users with NTFS (WIN). Because EXT FS is out of such drama (there is easy steps, how to repair it).
 

jeyare

Subscriber
1,800
592
and I have to take a beer for TeamViewer, because all the support to remote site was done by this great service
 

jeyare

Subscriber
1,800
592
to be sure, when you need check disk, then you need use chkdsk command with these parameters:
Code:
chkdsk /f /r /x

when "f" - Fixes errors on the disk. The disk must be locked. If chkdsk cannot lock the drive, a message appears that asks you if you want to check the drive the next time you restart the computer.

when "r" - Locates bad sectors and recovers readable information. The disk must be locked. /r includes the functionality of /f, with the additional analysis of physical disk errors.

when "x" - Forces the volume to dismount first, if necessary. All open handles to the drive are invalidated. /x also includes the functionality of /f.

... but as I wrote, this isn't guarantee of magic repairs
 

jeyare

Subscriber
1,800
592
Task is already done now. Result:
1. New disk installed
2. Disk cloning by Acronis True Image (from the old SSD to new M2 NVMe) successfully done (ignore bad block notification during the cloning process).
3. Then new system disk booted
4. AB4B is now OK with such disk (w/o bad blocks)

Lessons learned (NTFS in Win based PC):
When your AB4B will identify first bad block in your disk (doesn't matter hdd/ssd, ...), then you can't backup such disk, because error code 1117 (Read error mentioned above).
It doesn't mater, when the bad block is based on:
- hard error (disk memory cell is broken)
- soft error (damaged record during write operation - power outage, ...).

How to repair it:

1. When you have previous backup of such disk (AB4B).

Use AB4B for restore data to new disk. Easy and simple task.

2. When you don't have previous backup of such disk.
There is little bit more complex process.
You can't make backup with MS Backup (official system tool). Because same Read error. Don't waste a time.
Then you can use 3rd party utilities such Acronis True Image (successfully, many times for me) and make Backup of such disk (Read error ignored, when selected such method).
Finally you can make:
- Clone of old disk to new (also with Acronis)
- or Restore backup from Acronis to new disk
Then you have "new" disk with your old data.

PS:
- you can use Disk clean tool (Acronis also) for Wipe out of the old disk. It will erase all data on the disk (mainly by 00 or FF, or by used features). Then use final feature for wipe out Partitions on the disk.
- you can use the disk to future operation. Because if the disk records was damaged by soft error, the disk is still useful. Then, when you need save a money, you can use for cloning some old disk (same or larger GB size). After clone process and wipe out process you can re-clone the "repaired" original disk without any new cost to your budget (except tools as Acronis).
 

jeyare

Subscriber
1,800
592
This issue (can't backup NTFS disk with bad block) is confirmed also by Synology support officially:

... 1117 (0x45D) returned by Windows means the request could not be performed because of an I/O device error. Thus it leads to reading snapshot failure.

Gents from Syno need to find a way out. Solutions how to is anywhere.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Similar threads

Similar threads

Top