Question Anyone run FreshRSS in Docker?

Currently reading
Question Anyone run FreshRSS in Docker?

fredbert

Moderator
NAS Support
Subscriber
1,590
666
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Last edited:
I still use RSS feeds to get the news I want, rather than let FaceAche and Twiddle decide what I might like to see (or not).

I use Reeder app on iOS and macOS as well as FeedBin's own web interface. However I have occasionally looked at self-hosted RSS aggregation but nothing has jumped out as a reasonably easy solution. The last few days Reeder was updated to support FreshRSS, which I hadn't come across before. It needs a fair few additional packages to build up but then I thought about Docker and found some containers in the registry. Of the top two I selected linuxserver/freshrss (Docker Hub).

Just to test it: I launched the image with the Docker default settings, except I deleted the HTTP port and set the HTTPS port to a fixed number. After that I added a DSM reverse proxy to access it using my domain on HTTPS/443; a local DNS CNAME for the subdomain; updated the LE certificate with an SubjAltName for this subdomain. I haven't changed anything that would write databases etc to the NAS file shares, it's all contained in the container and that's probably not a wise way to proceed in the long term.

The first browser connection requires select of the database type (SQLite [selected this], MySQL, Postgres) and a user to be created as the admin user. Then go and enable the API interface so that Reeder can connect. That's pretty much it to get it going.

Next, added a user and imported my OPML file (exported from FeedBin or macOS Reeder). The user needs to set an API password as this is less secure that the web login (they say) and now Reeder can access using either FreshRSS account type (greader.php api) or the Fever account type (fever.php api) ... just need to edit the URL because Reeder adds an unwanted '/p' in the heirarchy.

Here's the question...

Has any one looked at running FreshRSS in Docker and how secure is it? Also how to configure NAS storage, or at least backup, the user data?

For my low priority RSS needs (reading today's news) of 20-ish feeds this might be a good, free solution and also others can have an account if they need it. FeedBin is still better but costs.

Meant to add, the container is running between 0 to 2% CPU (DS218+) and 30-40MB RAM.
 
349
91
NAS
DS418play
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
  2. Windows
Mobile operating system
  1. iOS
I don't use FreshRSS, but TinyTinyRSS in Docker for some feeds: Docker Hub

You'll also need to install and configure Fever to work with Reeder. Maybe it will suit your needs.

But for some other feeds I need only privately to read some local news I switched from Reeder app to News Explorer for Mac and iOS. Easy to set up, syncs with iCloud and that's enough for my needs.
 

fredbert

Moderator
NAS Support
Subscriber
1,590
666
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
I hadn't thought about TTRSS but ... didn't you write up about it? I must've missed the Fever api bit as I have looked and TTRSS isn't directly supported in Reeder.

Having gone through a lot of different RSS reader apps I'm happy at the moment with Reeder. Mostly reading on the phone and bookmarking the odd article for later.

With FeedBin I now have NAS and CCC backup alerts emailed to a special address that turns up in the feeds and saves lots Inbox clutter. Also it is better at handling my single article weather xml (from Wweex) that gets updated every 15 mins, and this shows where an aggregator works better than a client only setup.

The FreshRSS image-proxy extension causes the nginx server to fail serving page requests. That would be good to fix as it would provide a buffer between the client and image sources.


How do you manage the database and other configuration files? Have you mapped them to a shared folder?
 
112
23
jonohunt.design
NAS
DS1019+, DS218+, DS416play, unRAID
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. Linux
  2. macOS
  3. other
Mobile operating system
  1. iOS
I don't use FreshRSS, but TinyTinyRSS in Docker for some feeds: Docker Hub

You'll also need to install and configure Fever to work with Reeder. Maybe it will suit your needs.

But for some other feeds I need only privately to read some local news I switched from Reeder app to News Explorer for Mac and iOS. Easy to set up, syncs with iCloud and that's enough for my needs.
I'm also running Tiny Tiny RSS. I set it up from the instructions and docker compose file here A ttrss setup guide - Start your own RSS aggregator today - Henry's blog
 

Rusty

Moderator
NAS Support
2,350
698
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Been running ttrss with fever plugin for years. Runs great with reeder on ios and mac. love it
 

fredbert

Moderator
NAS Support
Subscriber
1,590
666
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
SO all you TTRSS users ... in Docker? How do you protect from a container corruption?
 

Rusty

Moderator
NAS Support
2,350
698
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
SO all you TTRSS users ... in Docker? How do you protect from a container corruption?
PostgreSQL is the db. Container is just the front end. Never had a corruption. If it happens, snapshot replica restore of the db.
 

fredbert

Moderator
NAS Support
Subscriber
1,590
666
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
So you mean the the DB files are on a NAS shared folder not in the container itself?
 

Rusty

Moderator
NAS Support
2,350
698
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
So you mean the the DB files are on a NAS shared folder not in the container itself?
It all depends how your PostgreSQL is setup, but if its setup that its volume is exposed to the NAS then yes, the DB file are on the nas shared folder.

Any valuable data must not be left in the container. On each shutdown/boot it will reset itself.
 

fredbert

Moderator
NAS Support
Subscriber
1,590
666
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Last edited:
That's the thing, my test setup is using SQLite where the data is held within the container itself. I've never investigated using PostgreSQL except where it's already running, e.g. for manipulating Video Station age classification records.

I know DSM has PostgreSQL built-in but don't know if I can use it for this. I've looked at the other Docker guides and they end with 'fill in these PSQL parameters' which is great if you know the info but leaves a bit of detective work if you don't. Is there an expectation that there's an accessible PSQL deployment somewhere? If yes, how to achieve this. My background has been in security not applications :)

For a temporary, dirty fix I ...
  1. Shutdown the container.
  2. Created a folder in my Docker shared folder in DSM and mounted this within the container (somewhere safe /data/nas)
  3. Started the container
  4. Using a bash shell in the container's Terminal: did a 'cp -a' of the /config/www/freshrss/data/* directory contents to the /data/nas
  5. Shutdown the container and remapped the DSM folder to mount on /config/www/freshrss/data/
  6. Started the container and added items to the DSM folder to test they turned up in the container .. they did

This DSM folder is already in scope of HB backups.
 

Rusty

Moderator
NAS Support
2,350
698
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Well why not run a PSQL as a separate docker container and use it for all similar apps that use psql as backend?
 

fredbert

Moderator
NAS Support
Subscriber
1,590
666
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
That'll have to be the next thing to look at doing. So the answer is 'DSM PSQL isn't available for general use, you need to run a Docker PSQL instance' that's sort of the missing step in I guessed :)

Then a mount point to the NAS for the PSQL database(s)?
 

fredbert

Moderator
NAS Support
Subscriber
1,590
666
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Well that seems to work. Having done a few repeats with different tweaks I think I've got the hang of it.

Might be worth writing this up, if nothing else it'll help me to remember what I did :)
 

Rusty

Moderator
NAS Support
2,350
698
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Well there are several resources use this principal
 
8
0
NAS
DS1019+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
  2. iOS
Been running ttrss with fever plugin for years. Runs great with reeder on ios and mac. love it
Re: Fever. I downloaded it and was all ready to go, but it seems to be discontinued, and only support past customers. Any ideas there? I got ttrss working, but cannot use a read due to lack of api.
 

Rusty

Moderator
NAS Support
2,350
698
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
@ProfessorHuyang just use this one


extract it and copy it to your plugins folder (or plugins.local)
 
8
0
NAS
DS1019+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
  2. iOS
So this will not require “activation”? I’m fairly new to the all of this, but reading a lot. I have to be mindful of dated items.
 

Rusty

Moderator
NAS Support
2,350
698
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
So this will not require “activation”? I’m fairly new to the all of this, but reading a lot. I have to be mindful of dated items.
There is no activation, no. This is simply a plugin. I use it day to day on both macos and ios side.

If you need a hand, let me (us) know.
 
8
0
NAS
DS1019+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
  2. iOS
Thanks. I may need that. I'll keep tinkering with it. Copying to the plugin folder is a bit challenging for me (lack of knowledge).

I have Putty and can gain root access or use sudo under my login. Might be the directory path I'm using. (note I dowloaded, but switch and tried the command prompt option since I'm not able to see the actual folder to copy to. Sorry, a newbie.

I attached the path where my ttrss files are located. I assume the plugin folder is a hidden one from the Folder view (gui).
 

Attachments

  • Screen Shot 2020-01-08 at 7.21.52 AM.png
    Screen Shot 2020-01-08 at 7.21.52 AM.png
    3.5 KB · Views: 4

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Similar threads

Similar threads

Trending threads

Top