apache install went where, adds what, and works how when it appears to have done neither?

Currently reading
apache install went where, adds what, and works how when it appears to have done neither?

crow216p2, dove216
Operating system
  1. Linux
  2. macOS
  3. Windows
  4. other
Last edited:
This is puzzling. Web Station installs, runs, and does not see any HTML/CSS, so I'm stuck with a File Station set of foldered lists. No text. Just titles. Not much of a presentation.
So I moved to what was easy on Ubuntu, FreeBSD, Debian, and Fedora: Apache, accessing the DS216+II structure with my administrative SSH connection.
The problem is that there is no documentation on what gets installed, where it gets installed, and with what defaults.
That's what is called a "BOM" (Bill Of Materials); it's a basic of any qualified installations. It's needed if you ever want to run, modify, upgrade, or uninstall. It's an integral focus of ISO 9001.
So, I cannot find install or runtime logs, which will help me to backfill (reverse engineer) the missing details.
The path was not appended to (path=$path:newcmd) so that command line call (e.g., start, reload, and synoserrvicectl) existences/locations are unknown.

Time wasting becomes a substitute for life time when this shortcut passes on what amounts to 'software incompleteness' to end users.

The saddest guess is that the Apache 2.4 install didn't add anything except the "Running" indication.
Alas, I'm still hoping for more, and only coming from users, as Support tends to refer all levels of a configuration back to the same 'living proof' example-free documentation, which may not even reflect the current DSM or install's release version, so that menus, options, files/folders may not even correspond or exist.
When versions change, so must doc. However, as we all have no doubt experienced, that can easily get out of synch when modules change between major and minor releases. Very easily! And, the more contributing parties that are baking something the more the end result may never "look like" or taste like" the reciped item. If all module permutations are not tested, then expect some sort of glitch, incorrectness, and/or failure. Branched code can also break working features if no regression test suites are run. [A bad example: Apple probably killed their test/QA department years ago, while boosting their management and marketing budgets; the proof is in their unpublicized bug counts, if they even track bugs; users cannot file them, so who does?! Insiders.
And, doc needs to have been tested and verified... which means that example sites with code should already exist and be available to be put on a site showing proof of the conceptual ability to run, robustly, without high severity/priority bugs, and correctly. Nowhere that I can find.

I've found this w/r/t FreeBSD and coding-by-committee projects, as well as in most every "rapid development" project. They may skip testing and thus, use "quality" as if the word comes for free, like "natural" on food wrappers. So ambiguous is its conception, that the "science" in "computer science" disappears as steps, phases, testing, definitions, qualification standards, and process get abbreviated or skipped.

Sure, it's easy to say all this? Nope. I did this for decades. It's all that stands between garbage and efficient, modular, high-performing, and maintainable software. It also helps to make software actually do what marketing and sales say they want it to do. Meeting quotas is not the same as meeting standards of quality! That said, they're both needed. But maybe we need to take on the software quality assurance (verifying/fixing) technical documentation ourselves?!

So, rather than give up to garbage and frustration, I think we can construct a method where documentation is synchronized with a web example and with regularly being tested and updated. In short, we would be creating a Project Plan to propose to Synology so that their benefit from said [user-inspired] processes is a higher ranking in the 'needs no support because it self-documents, and works' department, which, in turn, then benefits us when they release software requiring robustness as-and-before it's released.

If anyone else is interested in bypassing 'what is', which doesn't appear to be much at all, then we can salvage "science" from the 'billboarded' version that prevails, and in the process, save each other vast headaches, heartaches, and rapid hair-loss ( or at leat the greying aspect). It could be rather fun. We could set up a repository and segment it by our own critical-path topics (maybe just along a tool-by-tool basis) so that the most pertinent and needed solutions can be tackled and publicized for all of us. There's also what we have already succeeded at as well. Anything that builds our community as our community. Waiting for Synology to solve these issues is slow since it involves assignments and time, and they are already locked into budgeting both I'm sure. I'm immediately interested in Apache. I have temporarily quit working on Web Station and Web Radio. Too little doc, no working examples, no successes, and no high-level experts. Interested? Please contat me and we can allocate some collaborative time and design a living document as a roadmap. Thanks.

best wishes,
The apache packages add these as options to Web Station. You can set apache as the default engine for WS on TCP 80/443 and/or for virtual hosts you create.
Web Station access to Apache does not include starting, reloading or any access to .conf files, which via SSH never even get a default existence. All Apache should be accessible by SSH. If it doesn't exist then how can Web Station access it, let alone affect it? There is no documentation on where Web Station interacts with Apache or even nginx. How did this get released w/o describing how to run the basic Apache commands via Web Station. I don't see the doc or the menus at all. Maybe I'm blind. Sometimes, like in the film, "The Andromeda Strain", the answer is right in front of you. Maybe if I turn away and then look again? Nope. I've tried that for three days. And, the very first thing I did was change "nginx" to "Apache 2.4" everywhere. I am using DSM6.2 because DSM7.x seems to lose more than it adds in features; there are no release notes that suggest Apache or Web Station had any fixes. Thanks. Any not-kb documentation available?
Last edited:
Thanks Fred. I used a stepwise trial-and-error method to "solve" the situation. My use of Panix.com's Transmit tool (WebDAV HTTPS and SFTP) has made it so I can go deploy "vim" on specified /etc/, /usr/, and/or any other configuration (or default) files. Plus, getting my .bash_profile and .bashrc files set up has made life much easier. I dug up some old 'dot' files I had emailed to myself before leaving Tektronix in 1996, which are moderately useful as a 'what goes in which?' and 'when is each sourced?' sort of way. There's probably some more useful tools in my future, availed via the Docker tool, that will surprise me with what they can do (the names and brief descriptions often do not do them justice). So, it's starting to become fun again as next I will be setting up SVN, Python, PyQt, and SQLite. I'm documenting failures and successes as I go, so it'll be easier next time and maybe for anyone who queries. Or, maybe they'll just want to strangle me for diverting them. Anyway... I greatly appreciate your reply!

best wishes,
From the SSH command line you'll find a good starting point for where packages items are installed is /var/packages.

For more normal commands look in /bin, /sbin, /usr/bin, and /usr/sbin. These are the usual places for most Unix-y systems. And if you know the command but not where it is you can, e.g., which sqlite3 to find /bin/sqlite3.

You'll also find that vi links to vim which can be found at /bin/vim.

If you are going to want to stretch the NAS with what it does then I would recommend not modifying DSM and the packages themselves, unless you know what you're doing. Instead use Docker containers to run new services and if/when you make a catastrophic mistake then it's only that container that is affected.

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

  • Question
Hello, Since some times, the Apache 2.4 is broken and when I try to repair it, it fails. I already tried...
Neither. Simply format them using a PC prior to installing in the new unit.
  • Locked
@esbenvb Please do not make duplicate posts on the same issue. Also, while you obfuscated the word it's...
  • Question
Got it sorted :) After update to 7.2 the tun.ko is back again. Everything is working fine again :)

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!