App permissions and indexing

Currently reading
App permissions and indexing

13
3
NAS
DS414s, DS1621+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
Last edited:
Hello all,
I am facing problems having my Moments app working properly for a non-admin account. I searched and various places and none of the solutions offered helped me so I hope some expert that might come upon my post, might help me. Finger crossed.

My DS1621+ integrates a domain and we use domain accounts in our Synology. Permissions are correctly set via DSM's control panel and all users can access the Moments app.
Myself as an admin, Moments works as it should, I back-up photos from the phone to Moments or transfer them via filesystem and DSM always triggers and indexing task followed by conversion. For my wife's non-admin account, it does not. I tried on her account to load a photo to Moments via the web interface and this is the result:

1.png


And when I click it:

2.png


Of course, there was no indexing or conversion tasks triggered.
My first thought were permissions on the system and then I saw on the website that Synology recommends that the Moments folder's permissions should be set to 'admin' and I should tick to 'apply to this folder, sub-folders and files'. I should do this both in the General tab and the Permissions tab from properties.

Voilá, when I did it, an indexing task was triggered and I thought that the problem was solved. So on the file system I deleted the 'Web' folder that contained my web uploaded picture and transferred all the backed up photos I had from another system that I wanted to bring to Moments. But now, on the Moments web app, I still have that 'ghost' picture that doesn't even exist anymore and the ones I moved in via the file system don't appear.

Next step was to 're-index all' from the options of the Moments webapp. It triggers a re-indexing task but the results are the same.

Uninstalled and installed Moments again. A pain-in-the-*** that took my NAS the whole evening to convert all my thumbnails again and resulted in nothing. The user is still having problems.

Via the filesystem I saw something funny - The group owner of the Moments folder is a group called: "SynologyMoments". A system group that is and it was properly set on the account that worked properly and wrongly set on the account that was having issues:

3.png


I thought I had hit gold with this one, but after changing it on the problematic user's file system, the issue is still there.

At the moment, I am completely out of ideas and I don't know what to do. Last 2 times I have contacted the Synology assistance the service was lower than 0 in technical quality, the people involved were more focused in hearing "yes you can close the ticket" than to actually giving me a solution, so I came to the community for help today.

Thank you all for your time!
 
I had a similar problem with Moments just now. I did this:

Screenshot 2020-12-28 at 11.42.43.png


and leave it overnight. All my images were converted and are visible again. Except for all the albums I've created are empty. Will need to assign photos to them again.

This happened to me maybe because I have moved the photos from the Moments folder. I've moved them back and started the reindex.
 
Hello SynoMan,

Thanks for the reply.
I tried that as I wrote before. Moved out and in again. Re-installed Moments. Nothing helps ...
 
Hey guys, I'll keep posting the troubleshoots and the status with the ticket with Synology just to help someone who might face the same issue.
Further investigation leads me to believe it is not a problem of permissions.
By using the synology tool to check ACL via CLI, I see that the permissions are similar when compared to a user where Moments works fine.

Top listing is for non-working user and bottom listing is for working user.

ACL.JPG
 
Hello everyone.
After a long support ticket, the issue is solved.

Dear Customer, Thank you for contacting Synology support. Thank you for the information provides. We've confirmed with our developer, and this is noted as a known issue now and our developers are working hard to address in a future release. Please kindly stay tuned for the update, and in the meantime, we apologize for any inconvenience caused. We've setup Moments permission for user [x] and Moments can index now. If other domain users also face the same issue, please grant user application permission as a workaround. Thank you.

For everyone who has a synology connected to an active directory domain, some apps don't accept group policy and you must set application policy directly to each user. I hope this helps users in the future.

Cheers!
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Old thread notice: There have been no replies in this thread for quite some time. The last reply was on .
The content in this thread may no longer be relevant. It might be better to open a new thread instead.

Similar threads

  • Question
No. No Mac desktop application either. You can assign direct URLs to open some packages by defining them...
Replies
1
Views
9,684
Yes iDrive and Emby...sorry about the confusion. The issue is that the folder structure created by the...
Replies
4
Views
3,895

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top