Bitwarden "Browswer Requires HTTPS" Round 2...

Currently reading
Bitwarden "Browswer Requires HTTPS" Round 2...

484
98
NAS
DS220+, DS918+, RS1219+
Operating system
  1. Windows
Mobile operating system
  1. Android
I'm trying to get my dad set up with bitwarden at his place. I have successfully installed bitwarden before on my machine, and I have tried installing a clean version of BW on my dad's machine using Rusty's tutorial to make sure I didn't miss anything, but I still have a couple of weird issues.

1. I can access and log into the BW container at 192.168.147.2:30503 from my dad's macbook pro. The weird part here is that I can access the BW container login page from my windows laptop, but once I try to log in I get the message saying "This browser requires HTTPS..." Why can I login on the apple but not my PC? I've tried firefox and microsoft edge browsers and it hasn't changed anything.

2. I set up a reverse proxy for dad's BW instance just like I did for my instance. The RP of bitwarden.dadnas.i234.me directs me to the NAS DSM page, not bitwarden like my personal BW RP does. I've checked my settings a couple times to make sure that dad's RP matches my RP settings, but can't figure out what's wrong.

I have also gone to SSL Certificate Checker - Diagnostic Tool | DigiCert.com and checked my RP; it says that all of the SSL certificates and the RP address is resolving correctly back to my public IP. I'm stumped at this point. any help would be welcome.

I just tried creating an RP to redirect from the first NAS to a 2nd NAS on the network, but the RP still resolves on ly to the first NAS. Something appears to be broken with the RP's, but I can't quite figure it out.

1622232608753.png


1622232624903.png
 
1.
Same for me on a Mac. I can login to BW using http. Don't know why this is happening. Probably some Apple magic or a bug? I would expect to always get the "only works on https" message if you try to login using http...

2.
Are you sure your port forward on the router is configured correctly? The reverse proxy config looks fine to me.

BTW
If you are running the container on the same host you can use "localhost" for the destination hostname. But that is of no importance here...
 
Upvote 0
I'm running the same i234.me. The RP looks identical to me except I changed it from newbienas.i234.me to dadnas.i234.me and obviously updated the destination port.
It could be a problem with docker vs host routing. Could you do a simple reboot of the NAS if you haven't already?
 
Upvote 0
Sorry for the delayed response. Have a baby on the way and nesting is in full swing for mom. I rebooted dad's NAS and tried again. all of my RP's direct to the NAS DSM instead of the targeted port.

I still don't understand why I can access BW via direct IP on LAN with Apple products but not windows or android.
 
Upvote 0
Last edited:
So that means that reboot didn’t help?
Sorry, yes. I rebooted and didn't see any change.
-- post merged: --

Also, to clarify, I rebooted the NAS remotely via RP from my house. So, the RP to get into his DSM to do the reboot works just fine, but I can't get the other RP's to work. It shouldn't be a router port forwarding rule issue, correct? I'm forwarding 443 to the NAS, and then the RP rules should take over from there to redirect the traffic to the appropriate NAS port, correct?
 
Upvote 0
I have tried setting up a 2nd RP where the first NAS acts as a dispatcher to redirect traffic to the 2nd NAS on the LAN. This worked just fine on my home network with a different set of NAS's, but it does not work on dad's network. I get directed to DSM for the first NAS ("dadsnas") every time.

1622649150468.png
 
Upvote 0
Last edited:
What happens if you explicitly specify the port like bw.yourdomain.com:443.

Are all the DSM http to https redirect settings the same on both NASes?
https://bitwarden.dadsnas.i234.me:443 still directs to DSM login screen.

I did not have "automatically redirect http connection to https for DSM desktop" checked. everything else was the same. checking that box didn't make any difference in the RP working.
-- post merged: --

I just stumbled across something else. I was going to test creating an RP for File Station. I have one that works on my NAS, I wanted to see if I could get it to work on dad's NAS.

When going into the Application settings, I noticed that once I created a customized port, it wanted me to login at https://bitwarden.dadnsnas.i234.me:7001. Why is it using the bitwarden RP url instead of the main dadsnas.i234.me url? As shown in the screenshots, dad's NAS is referencing the BW URL, while my NAS is correctly referencing the DSM RP URL I had created.

Either way, I went through with creating the file station RP. It also does not work. Still redirects to DSM, not to the file station login screen like it does on my nas.

1622691492935.png


1622691500506.png
 
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top