BitWarden - self hosted password manager using vaultwarden/server image

Docker BitWarden - self hosted password manager using vaultwarden/server image

Currently reading
Docker BitWarden - self hosted password manager using vaultwarden/server image

Last edited:
I can't say that SMTP notifications still work in this version of BW. Think this is still in development, looking at Git
Well this point is not really clear.
The Wiki has a section dedicated to the SMTP configuration (dani-garcia/bitwarden_rs) and there's nothing in this page stating that it may not work or is till under development.
Also checked open issues and can't find anything regarding notification mails not working.

Edit: closest issue related to mine is failed to lookup address information: Name or service not known · Issue #688 · dani-garcia/bitwarden_rs. I may try to change my resolve.conf in my container to my router address to see if it helps but I'm not quite sure why using openDNS in resolve.conf would fail ...

Edit 2: Since I'm new to docker, any recommandation to modify the resolve.conf inside my container ?
I am in exactly the same situation as Shoop. Haven’t found a solution either.
I thought I was the only one with this issue since I found no one facing this issue...
Maybe I'm not doing it wrong all the way :D
@Rusty , thanks. I might try also to check the resolve.conf thing in case it does anything.
Well, I did not find how to change the resolv.conf in my container (turns out there is no vi :rolleyes: ) so I changed it directly on my NAS (set cloudflare DNS instead of freeDNS) and restarted my container, checked the resolv.conf and it was changed (y) But ... Still no luck with sending the mails.
My container logs are still showing this error :
thread '<unnamed>' panicked at 'called `Result::unwrap()` on an `Err` value: Io(Custom { kind: Other, error: "failed to lookup address information: Temporary failure in name resolution" })', src/libcore/
For info, I have followed the wiki for the installation of BWRS (almost all in command lines). I can provide all the steps if needed.
For what it's worth, I have both Bitwarden and Tautulli running under Docker on the same machine, and Tautulli is able to send emails. So I don't think the problem (at least my version of the problem) is tied to Docker related-it seems specifically confined to Bitwarden.
Last edited:
Next stage Account Form is OK (include validations), except "submit" button - doesn't work, seems to be a bug or need an additional setup in the container for browsers (Win OS):

Same here, creation of account didn't work in Chrome nor Brave. But worked in Edge. Hope this can be fixed.

I even can't use Chrome to login with a created account. I get this error:
An error has occurred.
Cannot read property 'importKey' of null

In Edge all works fine.
I had a new issue today.
I was not able to login to my vault. It dropped an "unknown error" on login submition.
I restarted the container which did not solve the issue. I then unchecked SMTP in the admin console and I was able to login again.

Anyone here had a chance to have SMTP and email notifications working on BitWardenRS without causing other issues ?
Never mind, appears we need to run it over https in chrome/chromium based browsers. I just tested over the internal LAN over http, directly calling the container "public" IP, before deciding to migrate from the multi container bitwarden solution to this one. Guess I first have to setup a reverse proxy with a certificate as well so get the full experience :)
I have confirmed that SMTP with BW RS version works as intended.

I have log confirmation that it works, email verification works (using the button in the picture below), and inviting users along with registration works just fine. 0 problems so far. I will update the resource with the parameters and variables that are needed.


This test was done with gmail smtp btw.

NOTE: email verification was delayed a few minutes in several cases but got deliverd non the same. Logs are registering same email time stamp with the recieved time stamp regardless of being delivered few minutes later.
Rusty updated BitWarden - self hosted password manager using bitwardenrs/server image with a new update entry:

BW SMTP for invitations and general user adminstration usage

If you want to use SMTP with this version of BW image make sure to make these changes to your setup.

Add these variables:

-e SMTP_HOST=<smtp.domain.tld> \
-e SMTP_FROM=<[email protected]> \
-e SMTP_PORT=587 \
-e SMTP_SSL=true \
-e SMTP_USERNAME=<username> \
-e SMTP_PASSWORD=<password> \

Note that if SMTP and invitations are enabled, invitations will be sent to new users via email. You must set the DOMAIN configuration option with the base URL of your bitwarden_rs instance...

Read the rest of this update entry...
Last edited:
@Rusty , thanks for testing.
There must be something wrong in my installation then.
Did you create the container in command lines (SSH on the NAS and docker commands) or in the GUI ?
Mine was installed in command lines and I had set all these variables directly in the docker run command.
Did you add the variables in the admin console or in the docker GUI on DSM ?
Are you using the gmail SMTP with application password ?
I can give my detailed installation (and image upgrade) procedure if it can help troubleshoot my issue.
Mine was installed in command lines and I had set all these variables directly in the docker run command.

Did you add the variables in the admin console or in the docker GUI on DSM ?
I have edit these variables using DSM UI or you can do it via Portainer or simply recreating with docker cmd as well (all should be the same)

What SMTP are you using ? I tried gmail with application password.
I have used gmail smtp ( via 587 port, not using a custom app password
Ok, I'm gonna try to reconfigure all this later today or tomorrow and keep you posted.
One more question, is MFA activated on the gmail account used to connect to the SMTP ?
Last night, I messed around with my installation of BW_RS and redid it from scratch with the DSM UI following @Rusty 's tutorial and everything went well except it's still not able to send mails with
I used the BW_RS installation tutorial, the RP config tutorial and then SMTP config but still no luck.
Still throws the same error :
thread '<unnamed>' panicked at 'called `Result::unwrap()` on an `Err` value: Io(Custom { kind: Other, error: "failed to lookup address information: Temporary failure in name resolution" })', src/libcore/
@Rusty , are there firewall rules other than the http & websocket ports to be added to allow BW_RS to send mails ?

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

So this means that I can copy to its directory from another DiskStation directory and share (using File...
I'll delete everything I can containers/images/etc, and start fresh over the weekend. While I really like...
I use it with the Reeder app and wanted to have filtered feeds there. I'll play around with it a bit more.
I ran across a very complete how-to-install-nextcloud on Docker using the Synology UI (just the UI, not...
Hello, i just tried to follow these steps above, but all I get is a psql: could not connect to server...
I discovered if you use fireflyiii/core:latest everything works just fine

Welcome to! is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!