Blank DSM Login Screen when using DSM Reverse Proxy

Currently reading
Blank DSM Login Screen when using DSM Reverse Proxy

15
3
NAS
DS1520+
Operating system
  1. Windows
Mobile operating system
  1. Android
Greetings.

As a new user, I have set up everything I wanted to with some excellent tutorials from mostly members here and I am 99% done. I am just being haunted by one thing:

I used @Rusty tutorials for Let's Encrypt + Docker = wildcard certs & Synology Reverse Proxy.

Sonarr, Radarr etc works fine using the reverse proxy. However, if I set up a reverse proxy to go to DSM is works fine for 1 or 2 times where I am able to get to the login screen. Thereafter if I try, it shows the DSM logo on the tab but the page is just white/blank?

I have seen other people posting on similar problems with Apache Proxy Server etc. but can't figure out how to fix it.

If you can shed some light, I will really appreciate it.
 
Greetings.

As a new user, I have set up everything I wanted to with some excellent tutorials from mostly members here and I am 99% done. I am just being haunted by one thing:

I used @Rusty tutorials for Let's Encrypt + Docker = wildcard certs & Synology Reverse Proxy.

Sonarr, Radarr etc works fine using the reverse proxy. However, if I set up a reverse proxy to go to DSM is works fine for 1 or 2 times where I am able to get to the login screen. Thereafter if I try, it shows the DSM logo on the tab but the page is just white/blank?

I have seen other people posting on similar problems with Apache Proxy Server etc. but can't figure out how to fix it.

If you can shed some light, I will really appreciate it.
Probably not an RP issue.
 
Upvote 0
log into your nas via ssh and go to /var/log/nginx/error and see if there are any errors that might point to a problem with this.

Also, if it works 1-2 times then it probably is not the RP that's the problem here. How is your DSM login configured via RP in the 1st place?
 
Upvote 0
log into your nas via ssh and go to /var/log/nginx/error and see if there are any errors that might point to a problem with this.

Also, if it works 1-2 times then it probably is not the RP that's the problem here. How is your DSM login configured via RP in the 1st place?
I logged in with ssh and could get to /var/log/nginx but not further?

At Cloudflare DNS I made an Aname entry to my ddns address. My DSM login is configured with the inbuilt RP of Synology:

Screenshot 2021-07-09 133433.png


I also found this thread on the same issue: Accessing synology DSM behind nginx reverse proxy
 
Upvote 0
Last edited:
@Rusty I have sent you a PM with some reports from browsers. Thanks
-- post merged: --

@Rusty I have turned off Auto Minify in Cloudflare and it now seems to work. Thank you very much for all your patience with me. 😊

EDIT: Still not 100% but I suspect that it is some or other setting on Cloudflare. Please still have a look at the logs I sent and let me know your thoughts.
 
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Apache 2.4 in dsm 7.2 does not run after restarting DSM Leading to errors in WordPress, Joomla,... Out of...
Replies
0
Views
692
Hi, hope someone can help here. I have a Synology ds2411+ and I can't get mergerfs to run properly and DSM...
Replies
0
Views
968
Ok this eliminates the HDD spinning down theory on the WIn11 client. Are your NAS HDDs set to spin down...
Replies
3
Views
1,351
Deleted member 5784
D
  • Solved
Creating a group is super easy, as is assigning them to that group. Once and done, transparent on the user...
Replies
5
Views
651

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Back
Top