Question Bought domain and need to link to NAS

Currently reading
Question Bought domain and need to link to NAS

5
1
NAS
DS220J
Operating system
  1. macOS
Mobile operating system
  1. iOS
Hello,

Massive newbie question.

I have bought a domain name (from Fasthosts).

I need to point this towards my NAS.

Is there a good step-by-step guide to this, anywhere?

many thanks
 

jeyare

Subscriber
1,609
544
Welcome here

Do you have fixed public IP (WAN) from your Internet Service Provider (ISP)?
 
5
1
NAS
DS220J
Operating system
  1. macOS
Mobile operating system
  1. iOS
No - not fixed - thank you
 

fredbert

Moderator
NAS Support
Subscriber
1,700
692
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Fasthosts doesn't have dynamic DNS support in its DNS admin portal so you have to make a choice:
  • Transfer the domain to a DNS service that supports personal domains and DDNS (that is supported by whichever DDNS update agent you use).
    • In the new DNS service you'll have to create an account and transfer in the domain. You should be given the list of nameservers to add into Fasthosts (look for the Nameservers and glue records section)
    • Setup the domain in the new DNS service and enable DDNS.
    • Configure you DDNS update agent to maintain the IP.
    • You can still keep paying for the domain registration through Fasthosts.
  • Use a DDNS service to maintain the dynamic IP association with a subdomain (e.g. Synology DDNS's <your_nas>.synology.me) and create a wildcard entry in the Fasthosts DNS configuration.
    • e.g. setup Synology DDNS
    • in Fasthosts create a CNAME record for * that points to, e.g., <your_nas>.synology.me. Now anything that doesn't have an explicit records (e.g. A, MX, or CNAME) will resolve to the Synology DDNS name.
I do the first option from two Fasthosts purchased domains. I found Namecheap to be reliable and free but it isn't supported directly by DSM or SRM's DDNS update agent: nor can I get a custom setting to work. I already used OpenDNS and they have DNS-o-matic, so I update D-o-M from DSM or SRM and then this account maintains my Namecheap and OpenDNS accounts. .... Other ways are possible but this is working for me and I'm not changing it unless forced :)

I haven't tried the second way but I've just tested it with another Fasthosts domain which hasn't been transferred. I added the * CNAME record to point to one of my A records and now any unregistered subdomains resolved to this A record ... so seems to work as a wildcard. I also have some explicit CNAME records from this domain that resolve to subdomains on my NAS, via the Namecheap doamins.
 
5
1
NAS
DS220J
Operating system
  1. macOS
Mobile operating system
  1. iOS
thank you for an outstanding reply!
best wishes
 
1,510
647
NAS
DS220+ : DS1019+ : DS216+II : DS118 : DS120j : APC Back UPS ES 700 — Mac/iOS user
I second @fredbert first suggestion. Moving the domain will make your life much easier.

Check Control Panel > External Access > DDNS tab
Add service provider
You’ll see a list starting with Synology
If you want your Synology NAS to update the DNS records then you can choose from this “Supported” list.

I’ve moved from a cheap, unreliable DDNS service provider (1st one on the list after Synology) to no-ip.com and so far (about 3 months) they’ve been good. They’re not the cheapest but once bitten twice shy.
 
  • Transfer the domain to a DNS service that supports personal domains and DDNS (that is supported by whichever DDNS update agent you use).
    • ...
Please bare in mind that this approach will not allow to issue letsencrypt wilcard certificates for your own domain, as it will require authority from the dns server that hosts the A record your CNAME record is pointing to. It is stongly advised to use a dns service that is supported by the dyndns update agent of your choice that does the updates on the dns records for you (=option #1).

My dns service provides an api to update records and I run my own dyndns service in a docker container. I point my routers dydns client to my own dyndns container which updates the A record for my * entry to point to my WAN ip. My router vendor provides a dyndns address which is use when I access my own dyndns container. Though, I am afraid this is a more advanced use case.

You should go with option #1 and transfer the domain to a supported dns service.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Similar threads

Similar threads

Trending threads

Top