CalDAV stopped working

Currently reading
CalDAV stopped working

Hi All,

I just wanted to ask if anyone else has had any recent issues (post updating) with Calendar and CalDAV?

Running DSM 6.2.4-25556 Update 2 and apparently Calendar 2.4.3-0925

Everything has always worked just fine and I have made no changes. Now, neither the Cal app on OSX Catalina, nor T'Bird on same host, nor iOS 14.8, nor DAVx5 on Android can now connect to the CalDAV server.

It appears the CalDAV service is no longer available on the 38443 port. I can no longer telnet into that port whether from internally or externally (telnet on other exposed ports still works). Only error response is:

Code:
Trying 192.168.1.1...
telnet: connect to address 192.168.1.1: Connection refused
telnet: Unable to connect to remote host

with the same error offered up if attempting external telnet as well (from Android).

No FW rules were changed by me. I have checked in the UI and all appropriate rules appear to be in place. Would be grateful if someone could advise which FW module Synology is using underneath so I can check at a terminal level.

Or is there some issue people are already aware of please? Your thoughts and experience greatly appreciated.



P.S. Is it time to move to 7.x?
 
Last edited:
CalDAV is on the HTTPS port.
Code:
https://my.domain.com:5001/caldav/username

That would suggest @Telos that I have changed it somewhere. Which is completely feasible, and possible even.

However, I have been through every goddamned page, tab, and screen I can find in DSM to determine where I may have done so, and I can't find it. And it doesn't appear to be in the Calendar appl. itself either.

There is, of course the "Application Portal" where I could set up a custom port (along with custom URL, etc) for the Calendar, but that has no customisations in it. And 38443 is what appears in the firewall rules config dialogs. So, it has to be getting it from somewhere.
-- post merged: --

How can I query the firewall by CLI pls?

If I attempt to set a custom port through the Application Portal to my expected port, it tells me that port is already in use, so something is using it.
 
Last edited:
It would appear that port 38443 has become bound to the loopback only.

Code:
root@Synonas:~# netstat -lanp | grep 38443
tcp        0      0 127.0.0.1:38443         0.0.0.0:*               LISTEN      16385/nginx: master
tcp6       0      0 ::1:38443               :::*                    LISTEN      16385/nginx: master

Not sure how I should proceed here.

@Telos, this link: What network ports are used by DSM services? (last upd: Nov 11, 2021) under section 7. Packages says the Calendar uses 38443 for CalDAV.
 
DAVx5 is explained here. The link is in the format I provided.
@Telos,
Just to circle back to this and close it out; I realised later your link was for all instances, not just DAVx5. Cheers.

The answer to resolve my issue (where Synology have indeed changed the CalDAV ports in the O.S. operation layer, just not in the U.I. layer - nor some of the documentation, and I did not want CalDAV exposing to the world, the same port DSM was operating on), was to use the Application Portal as mentioned above.

I was thrown by the new Syno Calendar UI URL being <host>:<port> (when customised in the Appl. Portal) and no longer being <host>:<port>/calendar - which for whatever mental logic was f#cking with my ability to translate to the CalDAV URL aspect of it.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

  • Question
If I enter an event on my Android phone, when it synchronizes over caldav to Synology Calendar the time...
Replies
0
Views
850

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top