Can see NAS, just cannot access it!

Currently reading
Can see NAS, just cannot access it!

14
3
NAS
DS224+
Router
  1. RT2600ac
Operating system
  1. Windows
Mobile operating system
  1. Android
  2. iOS
I asked Synology this and they didn't know either. I have 2 desktops and 1 laptop in our home office. They all talk happily to each other. The 2 desktops talk happily to the NAS. The laptop refuses to connect. It throws up the "Enter Network Credentials" popup, just like the desktops, but, unlike the desktops, rejects the credentials (yep, I'm entering the right ones!! :) ). I can even go into Windows (v10 home) credentials manager and manually enter them there, but I get the popup every time, and the credentials are not accepted.

However, I can see the NAS in the Network in Windows Explorer. I can successfully ping both LAN ports (I have set the NAS up with 2 LAN cables), and I can log into the NAS admin and see the drive and interact with it via File Station. VERY strange. My (very amateur) conclusion is there's a setting in my laptop's "Windows Security" (what a misnamed thing THAT is!) that is stopping that direct connection to the NAS (yet it is fine connecting to my old Zyxel NAS). What, I have not been able to isolate.

The only major difference I have come up with, and I don't know if it matters, is that I have no login on either desktop, but the laptop has a UN and PW as is more likely to get into the wrong hands than our desktops. I could potentially see this could be the issue, but I just don't have enough knowledge to move forward. I'm hoping this triggers a "Eureka" moment with one of you. I'm still convinced it's something small, simple, and )($*(&%( annoying!!
 
I would start with a reset of network settings and clearing the credentials file.
Then check the NTLMv2 setting.
The internet and search on this forum will help you.
Success
 
> Then check the NTLMv2 setting.

If that still fails, set it to NTLMv1. Synology will squawk about security, but you'll get in.

My DSM is not exposed to the outside world, so I could care less about V1. I do care about my access.
 
SMB1 is a real risk, but this was not the topic here as I understand.
NTLMv1 risk is much lower. Understand that the W10 PC is possibly on internet. Main risk an issue with brute force attacks and man in the middle attacks, so fixing the W10 is for sure much better than the easy change in the NAS.
I think as a general statement I try to give the most secure advice, not the easy ones :)
 
Just for clarification, how do you enter the credentials?
On Windows 11 I need to enter the credentials by defining the host first for using the local account of the NAS. For example: SynoNas\UserOnNas and the corresponding password. Otherwise I can’t access my network shares via SMB.
 
I'm VERY reluctant to open up either of those old, insecure protocols, especially when the 2 desktops don't have them open, yet they work. And, secondly, because the laptop is with me on the road on all manner of dubiously insecure WiFi networks. It has to be some other setting that is blocking it other than that.

As far as credentials go, on W10 (Home), I get a little popup that asks ONLY for UN and PW - no host. Likewise, going to Windows Credentials and manually adding only asks for US and PW.
 
That's why I suggest specifying the hostname by your own via the syntax mentioned above, like:

Username: SynoNasName\UserOnNas
Password: UserOnNasPwd
 
That's why I suggest specifying the hostname by your own via the syntax mentioned above, like:

Username: SynoNasName\UserOnNas
Password: UserOnNasPwd
Except that's not the NAS's UN. I can try it when I get back home, but I don't see that working. Right now I jammed by Synology's tech. Their DS Finder 2FA is garbage. Never get their message, instead it just freezes my phone till the code expires. So, far my experience with Synology and NASs has not been good. Like their router enough, but the NAS....
 
Last edited:
SynoNasName should be replaced with the SMB name of your NAS and UserOnNas with ther username you are using for accessing your NAS.
 
Last edited:
Just for clarification, how do you enter the credentials?
On Windows 11 I need to enter the credentials by defining the host first for using the local account of the NAS. For example: SynoNas\UserOnNas and the corresponding password. Otherwise I can’t access my network shares via SMB.
That doesn't work for me. Same issue as previously.
-- post merged: --

Did you already reset W10 network settings and check NTLMv2 setting?
Reset. NTLMv2 was set to "Send LM & NTLM - use NTLMv2 session security if negotiated'. I changed it to "Send NTLMv2 response only. Refuse LM & NTLM". Hopefully doing that doesn't screw up anything else on the system as I can now get to my NAS and browse. Thank you!

However, I was not asked for Credentials with this setting. Is this going to be a security risk?
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

  • Question
Yes, Omada is TP-Link's management system. Have set a reserved IP range and have put the NAS into that -...
Replies
2
Views
581
Those metrics are over the internet without VPN. I wanted to get some baseline numbers before adding VPN...
Replies
2
Views
568
  • Question
Just thought about another location to change IP if you have a specific app NAS control panel - Login...
Replies
1
Views
729
That sounds weird. Is there any port isolation feature on the LAN ports? If you have a network switch...
Replies
5
Views
1,093
  • Question
For the time being I 'm concentrating on getting things back to working condition with the the BT line -...
Replies
13
Views
3,699
  • Question
Mmm..., looks like the problem was that we were connected to a dead network port. When livened up, all...
Replies
4
Views
1,306

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Back
Top