Cannot connect to Bitwarden in Docker via reverse proxy on ubiquiti network... help?

Currently reading
Cannot connect to Bitwarden in Docker via reverse proxy on ubiquiti network... help?

484
98
NAS
DS220+, DS918+, RS1219+
Operating system
  1. Windows
Mobile operating system
  1. Android
So I'm back and trying to get docker/bitwarden up and running. I believe I have the docker/bitwarden image set up correctly, but I cannot reverse proxy into it using bitwarden.myname.synology.me. I have been able to access the image using http://192.168.x.x.1051, but it won't let me sign in because it requires https. I've included links of all of my settings below. Can someone please take a peek and see if I'm missing something. I still struggle a bit getting ports pointed in the right direction.

I have a feeling using port 443 in the reverse proxy rules for the port is incorrect, but it won't let me use 1051. I checked and ports 1050 & 1051 are both open.

Bitwarden Image settings:
1605563072542.png


Synology Reverse Proxy Rule:
1605563127695.png


Synology Certificate:
1605563158434.png


Unifi Controller Port Forwarding:
1605563202246.png
 
Solution
Destination in reverse proxy setting is wrong.

http instead of https towards port 1051. Docker port 80 that you have locally mapped to 1051 is an http binding not https.

Also regarding web access using your https, you need to port forward 443 from the outside if you want access. No need to port forward any local port (1051, 1051 etc)
Destination in reverse proxy setting is wrong.

http instead of https towards port 1051. Docker port 80 that you have locally mapped to 1051 is an http binding not https.

Also regarding web access using your https, you need to port forward 443 from the outside if you want access. No need to port forward any local port (1051, 1051 etc)
 
Upvote 0
Solution
Destination in reverse proxy setting is wrong.

http instead of https towards port 1051. Docker port 80 that you have locally mapped to 1051 is an http binding not https.

Also regarding web access using your https, you need to port forward 443 from the outside if you want access. No need to port forward any local port (1051, 1051 etc)
soo like this?

1605567133491.png


1605567142231.png
 
Upvote 0
so.... I got it working. was banging my head for quite a while, then noticed I had bitwarden/synology.me insteand of bitwarden.synology.me. 🤦‍♂️ Thanks for the help.
So was it the name that was the problem or the protocol? Or both? Please mark it "solved"
 
Upvote 0
I believe it was both; I played around with different protocol settings after I got the name straightened out and it wouldn't work with the original settings I had posted. Took me a bit to find the name error so I was frustrated at the protocols again, but once I got the name straightened out its working great.
-- post merged: --

Also, I'm not seeing a spot to mark it as solved. It looks like I posted it as a thread and not a question to be answered?
So was it the name that was the problem or the protocol? Or both? Please mark it "solved"
 
Upvote 0
Also, I'm not seeing a spot to mark it as solved. It looks like I posted it as a thread and not a question to be answered?
I've changed the thread type. Now you can Mark as solution by clicking on this:

Screenshot 2020-11-17 at 16.34.08.png


Thank you.
 
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Back
Top