Cannot Remove Volume or Storage Pool

Currently reading
Cannot Remove Volume or Storage Pool

I cannot, for the life of me, remove a specific Volume or Storage Pool from my system.

I am running DSM 7+ on my DS918+ which has has the Dx517 Expansion Unit. I have 2 drives in the expansion unit that are currently part of Storage Pool 3, which has Volume 3 assigned to it. I want to remove both of these drives to repurpose into another system. I have no further need for Volume 3 and no need for Storage Pool 3. When I try to remove the volume or pool, it fails.

My Initial clean-up:
Volume 3 was in use by two shared folders. I moved those folders to volume 2 and no longer have any shared folders on Volume 3.
Volume 3 was being used as my Docker location. I no longer want to use Docker, so I uninstalled the application and let the deletion of the folders happen.
Volume 3 was being used by SynologyPhotos. I followed a guide to use ssh to "move" the application from Volume 3 to Volume 1.
After this clean-up, Volume 3 shows 20.5MB of data being used via Storage Manager.

If I ssh and check the contents of /volume3, I see two directories that I cannot get rid of as sudo via CLI:
@iSCSI and @sharesnap
I am not running a LUN on Volume3, and have no idea what sharesnap is for.

Advice? Is it as simple as shutdown and physically remove the drives and hope the system can forget the volume/pool, or allow removal after reboot? I am willing to try, but I am currently waiting for a drive scan to complete on a new drive that has been running for 12+hours.
 
Well, either people did not know after 200 views, or they just assumed I would try after a shutdown. Either way, I had my vacuum trigger a shutdown from the UPS unexpectedly and so I just removed the drives. After the reboot I was able to remove the pool. On the plus side, this shows I need a new UPS as the battery must have lasted all of 2 seconds. The UPS is pretty old so I will opt for a new one over a battery replacement.
 
Thank you. I just went through the same thing... Setting up a new RS2423+ (DSM7.2) with 2x 8TB drives (SHR) temporarily while I waited for my 6x 20TB drives to arrive. Haven't put any data on the volume yet, so figured it would be quick to expand and convert to SHR2. I was wrong.. after ~2 hours in, I bailed and decided to blow up the whole volume and storage pool, cut my losses, and just start over. I had to physically pull the drives to force the SHR conversion to stop and degrade the volume so that I was given the "remove" option. Seems like it was working at first, but then it keeps failing to remove the volume and storage pool. After a reboot, I was able to remove it instantly. Very quirky.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

  • Question
Thanks, it finally worked I didn't pay attention to the next button at the bottom
Replies
6
Views
1,579
S
  • Question
Thanks Telos and others! Well, my problem is solved (before reading your post), it may have been an error...
Replies
5
Views
4,319
scooby_nas
S
  • Question
Gents, there is just single SATA 3 specification valid for all drives, then it doesn’t matter: - if the...
Replies
18
Views
12,090
Just FYI... When I was rebuilding a RAID0 pool recently, DSM warned me that one of the disks had bad...
Replies
8
Views
3,937

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Back
Top