Can't play any files on new LG TV

Currently reading
Can't play any files on new LG TV

8
0
NAS
220+
Operating system
  1. macOS
Mobile operating system
  1. Android
Hi all - just joined!

I've just got an LG TV (OLED 48" CX) and Synology NAS (220+). They are both connected to the router via ethernet. I've dumped a lot of movies onto the Synology in various formats - .avi, .mp4, .mkv, etc. I'm not using Plex or any other video streaming apps on the NAS. Media Server and Video Station apps are installed and running. Things are in the correct folders and fully indexed.

The films play all fine on other devices - i.e. streamed to my MacBook or Samsung mobile. The NAS is recognised by the LG as a source and comes up as an input option. However if I try and play any movies (I've tried various formats) I get the error message "This file cannot be recognised. Returning to list".

I've also tried playing using the Synology DS Video app on my S10 as a controller. Again it sees the LV as a device and I can select it, but when I chose a film I get the same error message and the movie won't play.

Also I can't view pictures or play music. Again the folders are showing up but nothing will load. Basically NOTHING on the 220+ will load onto the LG no matter the type or format.

Anyone have an idea what the problem might be? I'm eager to watch some movies on my new OLED!
 
8
0
NAS
220+
Operating system
  1. macOS
Mobile operating system
  1. Android
Thanks Tedster. Any idea where I should check?
 

Rusty

Moderator
NAS Support
3,211
959
www.blackvoid.club
NAS
DS718+, DS918+, 2x RS3614RPxs+
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
However if I try and play any movies (I've tried various formats) I get the error message "This file cannot be recognised. Returning to list".
Can you actually see the filename listed at this point?

Using DLNA will ignore any file/folder permissions, but as far as I know, it will only check for /video, /photo , and /music folders, not any other. Can't say for sure, I don't use the media server option, so not sure if anything has changed there.

Are your files located on some custom root folders or are you using /video for example?
 

fredbert

Moderator
NAS Support
Subscriber
1,957
790
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Media Server, Audio Station, and Video Station all rely on Control Panel / Indexing Service to specify and monitor those folders that will be used for their music, video, and photo files: I've not tested if Photo Station uses any different folders that its defaults.

Video Station has libraries that are created using these indexed video folders. Once in a library and scanned then these files can be played using Video Station web portal and DS video apps. Ultimately the playback client/device will determine if the file can be played natively or if it has to be offline or real time transcoded. Even so I recall that E-AC audio tracks are not supported in Chromecast (others?); I've had TrueHD stop videos playing in Mac Safari. From Video Station, during playback, you can select another player using Airplay and DLNA/UPnP.

Media Server can access any of the indexed folders and uses the DMA Menu Style to determine the menu structure that is displayed by the connecting device: there are three custom style that you can use to create menus that better reflect your tastes. Also you can opt to block new devices from accessing Media Server: those that are permit can also have their device profile changed (FWIW). Finally, there are DMA Compatibility settings that determine which video/audio formats need converting.

I'm not clear how you're trying to access and playback videos, having neither an LG TV nor S10 (??) I don't know if there are built-in apps or loadable third party apps for these things.
 
81
32
NAS
DS620slim, DS415+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
  2. iOS
Last edited:
I start the "photo and video" tab on my LG OLED tv, and then go to the media server nas using the tv remote.
Then browse to the correct folder in /video on the nas and start the movies.
Works with any video format you mention.
The mediaserver is running, transcoding for video is switched off (LG takes care for that).
 
8
0
NAS
220+
Operating system
  1. macOS
Mobile operating system
  1. Android
Thanks all!

EAZ1964. that's exactly what I'm doing and nothing will play - movies, photos or music. Any idea which settings on DSM I should check? Something is clearly wrong. All settings in MediaServer are either at default or unchecked.

I'm heartened by that fact you have the same setup and it works so there is hope!
 
81
32
NAS
DS620slim, DS415+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
  2. iOS
can you play photo's or music?
 
8
0
NAS
220+
Operating system
  1. macOS
Mobile operating system
  1. Android
can you play photo's or music?
No. All the folders show up - video/photo/music and I can navigate to sub-folders and see the files but nothing will play.

EDIT : I've copied a couple of videos from the NAS to a USB stick. One of them will play (avi), another won't (mp4).
 
81
32
NAS
DS620slim, DS415+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
  2. iOS
Last edited:
Did you check this?

-- post merged: --

or checked this:
https://www.reddit.com/r/OLED/comments/ej5poh
Nobody found a root cause so far... Sometimes a rename helps :)

On the nas side you might want to check the usual: SMB3 enabled, sufficient disk space available, standard settings on MTU, no jumbo frames etc.
 
8
0
NAS
220+
Operating system
  1. macOS
Mobile operating system
  1. Android
SMB3 enabled with default settings. Only used 5% of disk space. Standard settings on MTU.
 
81
32
NAS
DS620slim, DS415+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
  2. iOS
I really do not know. I'd probably try to find a way to see if it is a LG bug or a synology setting.
any other mediaservers available (via router or windows) do these play?
Or try Plex on synology and see if that plays.
(all assuming you have updated the LG OS to latest version first).
 
8
0
NAS
220+
Operating system
  1. macOS
Mobile operating system
  1. Android
Well - I can't even update software. It sometimes shows a new version available but when I try and install it either doesn't start or stalls at 2%. Other times it says no new update available! I've tried unplugging, trying via wifi rather than ethernet.
 
96
16
NAS
DS1819+, DS1815+
Operating system
  1. Windows
Mobile operating system
  1. iOS
Use a roku, firestick, or an Nvidia shield installed on the LG. I am running the Shield with Kodi installed accessing my nas via NFS and it plays back movies just fine.

DS Video is half baked and limited as to what audio/video playback codecs it supports.
 
8
0
NAS
220+
Operating system
  1. macOS
Mobile operating system
  1. Android
Use a roku, firestick, or an Nvidia shield installed on the LG. I am running the Shield with Kodi installed accessing my nas via NFS and it plays back movies just fine.

DS Video is half baked and limited as to what audio/video playback codecs it supports.
Thanks for the suggestions. Since posting I've found that pulling the ethernet cable and forcing it to connect via wifi gets it working again. I can't think of any reason why that should be but anyway!

As you say, DS Video seems a bit picky about codecs - there are a few films that the audio isn't supported, but for 95% it works OK so I'm happy with that.
 
96
16
NAS
DS1819+, DS1815+
Operating system
  1. Windows
Mobile operating system
  1. iOS
Thanks for the suggestions. Since posting I've found that pulling the ethernet cable and forcing it to connect via wifi gets it working again. I can't think of any reason why that should be but anyway!

As you say, DS Video seems a bit picky about codecs - there are a few films that the audio isn't supported, but for 95% it works OK so I'm happy with that.
not working via wired Ethernet makes no sense unless your wired and wireless networks are separate.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Similar threads

Similar threads

Trending threads

Top