Can’t verify account for 2FA - claims email sent but never received

Currently reading
Can’t verify account for 2FA - claims email sent but never received

4
2
NAS
DS1522+
I am setting up my new DS1522+ and was setting up 2FA for user login, as I’ve done on several other diskstations before. The 2FA works, but verifying the account so it will send me a one off code by email doesn’t seem to work. I select “send verification email”; it claims it has been sent but I never receive it. I’ve setup email in Notifications ok, it just seems to be around 2FA. I am sure I am making a stupid mistake, but would be delighted if someone could give me a clue what to try. It just feels too risky not being able to get the one time passcode via email in case my mobile phone is not working or I can’t find it, for the authenticator.
 
Thanks for the tip re. Authy - I wasn’t aware of it before and it does seem the ideal solution. It is already up and running. Greatly appreciated.
 
I use the Synology Secure SignIn app for my NAS logins. It works across my iPhone, iPad, Apple Watch, and my Macs. Strangely though, I don't see a Windows client available. There may be one, but I haven't really dug too deep to find it. The app has 2 kinds of verifications which it seems to pick at random which one to show. An Accept/Deny option, and an option that shows 3 different numbers and you choose the one the NAS login screen requests. It works quite well. It's also available for Android on the Play Store.

I use Authy for various logins as well such as my bank, NordVPN, etc, but with my NAS I prefer the in-house Synology created solution.

I hope this helps!

Tim
 
With my new enthusiasm for Authy, I thought I would use it for 2FA for my Synology Account - but it complains it doesn’t recognise the format of the QR code. Is this a known issue / feature, or am I doing something stupid?
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

  • Solved
Thank you for your help and @fredbert for the router manual .pdf sharing. Meanwhile, I could configure...
Replies
12
Views
1,450
I noticed on my Draytek syslog a shed load of blocks via my Country filters, as I did have a old DS118...
Replies
4
Views
2,705
I have seen your post on Mastodon and responded, but I see no issues with using 3rd party 2fa platforms...
Replies
6
Views
5,620
Same here, I look at it and check it out every once in a while. But my issues with it are a conveince...
Replies
6
Views
5,667
I had disabled my admin account but that broke cloudsync, so I restored it and put in a wild/crazy/long PW...
Replies
0
Views
1,679
Thank you for the useful suggestions, I am going to investigate this more. Much appreciated.
Replies
6
Views
1,793

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Back
Top