Complete newbie - Help needed

Currently reading
Complete newbie - Help needed

Operating system
  1. Windows
Mobile operating system
  1. iOS
Hello guys. I am trying to set up my NAS but it keeps going offline. I have set up a camera and it works for some long and then when I go back to it, the NAS is offline (albeit all lights are working normally and happily). Similarly the Synology Assistant keeps struggling to either find or when found load the login page.

I have no idea how to fix this but I need 24/7 camera coverage urgently and its driving me crazy - and giving me a genuine headache !

Set up is as follows - Windows 7 PC with Avast AV ...... DS212, Camera (PoE) and Windows 7 desktop all connected via ethernet into back of Cisco switch (which then connects to Vodafone (stock) broadband router).

I am sure its a simple fix but no idea where to start or what to do. Any help much appreciated
Hello Rusty. Yes it has the same IP address. I have checked that on Fing. But it never comes back of its own accord. I have to faff about resetting it or rebooting everything and keep trying Synology Assistant to try to get it to find it.
It has a static IP address. Some other info to add. Just tried a hard reset and wiped the DSM. Find. Synology is then supposed to identify the NAS under name Diskstation and enable you to reinstall the DSM. But mine just shows the IP address (nothing else) no name or anything see image below


  • NAS.png
    25 KB · Views: 12
Always difficult to analyze with a DS212 and W7 both out of support.
there are many factors that may have been fixed or not based on your setup and patch level.
W7 is well known for its network issues, and you might want to reset its network and flush the cache etc. Then make sure it has SMB2/3 set.
same for the DS212, set it on the latest DSM, make sure it is setup for SMB2/3
set the fixed IP for the DS 212 in the router DHCP to start with.
What I cannot understand is how come Fing and my Broadband Provider App can see the Diskstation but Synology Web Assistant and Synology Desktop Assistant cannot?

Further is there any way for me to manually force a new DSM install without using either of the above applications? I now have a 212 that has no DSM installed (after the ard reset) and cannot be found by Synology applications to do an automatic upload of DSM
Last edited:
You've not mentioned Fing or you 'Broadband Provider app' up to this point; it's not clear where these fit in.

Start with the basics. The W7 machine and the NAS need to be in the same subnet to see each other.
You NAS has IP; your W7 machine should also have an address of 192.168.1.x, and a subnet mask of Check this is the case.
How did you give your NAS its IP address - did you set it on your router, or in the DSM on the NAS?

Once you have made sure that both your W7 machine & the NAS are definitely on the same 192.168.1.x network, run the Synology Assistant app on the W7 machine; this should find the Synology.

If you are 100% sure that the network IPs are correct and the Syno still isn't being picked up, post back here and we can go through further steps - eg firewalls - to troubleshoot.
Last edited:
Fing was mentioned in post 2. Fing 'sees' the 212 and notes it is offline. So the 212 is clearly 'detectable' on the Fing check (and on my broadband app check - which also sees the 212). But the 212 does not show up under W7 control panel network devices. I will have a check on the rest of your suggestions. Many thanks
-- post merged: --

IP address of W7 is (so checks ok)
Subnet masks also checks ok (see cmd image)

I did not set the IP address on anything. I assumed it was automatically assigned.

The trouble is - as mentioned I did a hard reset (as per Synology instruction sheet and its wiped the DSM) but because the Assistants are not 'seeing' the 212 they cannot prompt a reconfigure and install new DSM.
-- post merged: --

Opps forgot to attach image


  • mask.png
    45.4 KB · Views: 14
Last edited:
The IP / subnet mask of the W7 machine is fine, as you said.
In post #5 you said the NAS has a static IP address; but in post #9 above you said you assume it was automatically assigned. Which is true? Was the screen grab in post #5 taken before you reset the NAS & removed DSM? I'm trying to see whether the NAS has still got the IP address that post #5 suggests.

Do you get any reply if you ping in a console from the W7 machine?

Are you running a firewall on either the W7 machine or the router that could be blocking traffic within the 192.168.1.x LAN?
Last edited:
As a newbie I thought if the IP address didnt change it was static. I have not hard coded the IP address on anything so I assumed it has been 'assigned' a 'static' one. Screen grab #5 was taken after hard reset because Syno instructions said click on web assistant to reinstall the DSM. NAS still shows as same IP address on Fing.

Pings host unreachable ... see below
-- post merged: --

Will check firewalls - standard Windows one is the only one I think. Avast firewall not installed but will check
-- post merged: --

That said ... I disabled all windows firewalls when trying to identify issue and syno still not found


  • ping.png
    12.6 KB · Views: 7
The NAS will be getting an IP address from the router via DHCP rather than being given a fixed, permanent address.
This means that the address it gets can change over time, sometimes after a reboot.

Yes, do check any & all firewalls (eg Avast, W7, router) that may be running - just turn them off whilst you're troubleshooting this.

One final network check - check you have yellow/green lights flickering on the ethernet port on the NAS. There should be intermittent activity here even though you're not connected.

The Synology instructions for resetting are here: How do I reset my Synology NAS? (For DSM 6.2.3 or earlier) - Synology Knowledge Center . Note this will wipe any configuration you have on the NAS meaning you will have to set it up again / restore from a backup config if you have one.

Follow the 'mode2' steps, checking that the beeps and status lights are as per the guide. According to the article, after following the reset steps, you should be able to open a browser and enter '' as an address to get to the DSM reinstall process.

I realise you said you've already reset the NAS, but I would try these steps exactly as per the guide again to make sure its done correctly.
Will do. Ethernet port flickers with activity - checked that already. And followed the Mode 2 to the letter - 4 seconds for beep immediate release and then press reset again until 3 beeps then wait 2 mins for status to flicker amber (from memory)

Is there another reset mode for DMS (later)? I seem to recall updating DSM when initially set up - like firmware update. 212 is brand new, bought it years ago and never used it so seem to recall looking for latest version
-- post merged: --

Found reset for later DSM its the same ... but will try again
I think the DS212 could go up to DSM 6.2.4 (?) The reset instructions for that are here: How do I reset my Synology NAS? (For DSM 6.2.4 or above) - Synology Knowledge Center
tbh the process looks very similar to v 6.2.3.

edit: you beat me to it.

If/when you have DSM reinstalled, go to Control Panel | Network | Network Interface | edit and assign the NAS a static IP address and subnet mask of '' in there. The address can be whatever address it currently has. This makes the address static and means the NAS can always be found at this address in eg a browser rather than being handed an address by the router that may possibly change.
It will not let me do a Mode 2 twice. It only ever beeps once after initial 4 seconds beep (not 3 times within next 10). So it must know no DSM on drive. All firewalls disabled (forgot the router one originally) and still not detectable by syno !
Last edited:
One other thought occurred; if the router is ~10yrs old and has never been used until recently, it might well have a dead CMOS battery, which could possibkly be the cause of the issues you're experiencing (Missing serial no, missing mac address, unable to hold network config).

Cross this bridge if/when you get DSM back up but worth considering.
I was going to ask if there is there any way to get DSM on the 212 without using finds.synology or desktop assistant?

But if the 212 is not being seen on network (in any event) its pointless
Step 5: Enter in the search bar of your web browser and locate your Synology NAS. The status of your Synology NAS should be Configuration lost.

Do you get nothing here?

At this point the NAS is out of spec and beyond regular troubleshooting. I'm not fmiliar with the DS212 but assume it has a CMOS battery like most PCs. If you can find a schematic this would confirm. If it has, I'd look at disassembling to get to teh mainboard to replace it, but this not recommended if you're new to this.
the 212 was working yesterday and this morning (I had set camera up and all seemed fine but when i left it to record and came back 30 mins later or so it kept going offline) and then wouldnt come back (hence hard reset)
-- post merged: --

At step 5 all i get is the grab in post 5
-- post merged: --

when i troubleshoot i also get this


  • Trouble1.png
    57.5 KB · Views: 10
I was going to ask if there is there any way to get DSM on the 212 without using finds.synology or desktop assistant?

But if the 212 is not being seen on network (in any event) its pointless
On Linux you could use a tool like netcat that will scan your LAN for any open ports on all the LAN IP addresses to see if there's any sign of the Syno. I'm afraid i'm not familiar with a windows equivalent but there will no doubt be one; these tools tend to run via the CLI are not particularly newbie-friendly however.

In all likelihood if the Syno Assistant app cant find the machine, and we're reasonably sure that your LAN is configured correctly, the NAS will be dead to these tools too.

I think you've taken this as far as you reasonably can.

PS dont forget to re-enable any firewalls you disabled.

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

  • Question
Control Panel > update and restore > reset there you will find the factory reset option that will allow...
The usbshare1 is not a folder, it is the operation system name for the usb disk itself. If you...
Drive, File, and Photos, are 3 separate apps with 3 specific major roles. Drive is your sync tool and...
  • Question
You use the original admin account password after reset mode 1. Just FYI...
Thanks folks, I appreciate your replies and have learnt much of what I didn't know! To answer questions...
You could power down the NAS and swap the disks around. See what happens when it powers up. My guess is...
Also bear in mind that if you go 2x RAID1, all your apps will be installed in the volume on the first RAID...

Welcome to! is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!