Contacts partially syncing - Solution?

Currently reading
Contacts partially syncing - Solution?

24
4
NAS
DS218
Router
  1. RT2600ac
Operating system
  1. macOS
  2. Windows
Mobile operating system
  1. iOS
I have 1756 contacts in a vcf file. I am trying to get synology contacts to sync them to my iPhone, iPad and MAC. This is not working for me.


I have tried multiple approaches, the latest one is as follows: Erased all contacts on iPhone, iPad and MAC; Uninstalled Synology Contacts package and reinstalled it. Created one contact on each device, iPhone, iPad and MAC, and the NAS. This worked. I am able to see the 4 contacts on all 4 devices.


I imported the vcf file into My Contacts in Synology so now I have 1760 contacts in the NAS (1756+4). I expect to see 1760 contacts on iPhone, iPad and MAC.


Well, I do not see 1760 contacts. I only see 1706! Why 1706? No idea.


I then edited 3 of the initial 4 contacts:


  1. The one I created/edited in Synology Contacts is replicated to the iPhone and iPad but not the MAC.
  2. The contact I created/edited on the MAC was replicated to all 3 devices, therefore I can see it on Synology, iPhone, iPad and MAC.
  3. The contact I created/edited on the iPhone is replicated to Synology, iPhone and iPad but not the MAC.
  4. I stopped/started Synology contacts hoping that this would trigger a push from the NAS to the other 3 devices.

Any ideas on how to fix this problem. Why only 1706 out of the 1760 contacts were synchronized and why the MAC synchronization of edited records does not work — or — am I just wasting my time with Synology Contacts?

Thanks in advance!
 
Last edited:
Unsure if this is related in any way....
xVDuUCF.png
 
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Synology contacts has never worked correctly for me - not on iOS or Android. I use Nextcloud in a docker...
Replies
8
Views
1,484
Well, it's probably some bug. I uninstalled the package, restarted NAS and again installed Synology...
Replies
5
Views
1,093

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top