DDNS failed.....

Currently reading
DDNS failed.....

Operating system
  1. macOS
Mobile operating system
  1. iOS
Last edited:
I'm seeing an issue today whereby the DDNS settings on the DS918+ are blank (instead of the external IP being shown) and the NAS is reporting there is no external connectivity. On checking the Synology account for the connection that reports all is normal.

I've rebooted the NAS and it looking at the Synology account it now shows that DDNS is offline. Hostname and IP blanked out...
Screenshot 2021-08-25 at 17.53.45.jpg

Any ideas folks?
Yes I do, but only when I rearranged the cables to swap between the router and the switch. It does not appear at any other times.

I had a response from Synology support:

Hi Customer,
Thank you for contacting Synology support.
I have checked the NAS, the DDNS is working now.
When this issue occurs again, would you please help us to press "update now" in the following page?
Please check the NTP sync could work or not.


So we'll see what transpires....
Upvote 0
Yes I do, but only when I rearranged the cables to swap between the router and the switch.
So we can deduct (not 100% though) that the network is fine.
It’s interesting that they want “customer” to press update now to update the time when the issue occurs. They are after something that’ll be in the logs.

Good luck, customer.
Upvote 0
Well to cut a long story short both Marius and Synology support reckoned the problem was with my router as it was not allowing test pings out to Google (which Synology use for testing). I've also been asked to change ports / ethernet cables which the NAS connects to. Synology finally told me to buy a new router, that was not going to happen as I use an expensive Netgear Orbi router which has been working flawlessly for 9 months.

Anyway while logged onto the NAS I noticed the Cloud Sync icon was showing a stalled state. In a fit of madness I thought hmmm, and changed the DNS on the NAS away from the Google DNS settings, which Synology had insisted I set as a default, and back to CloudFlare.

Immediately Cloud Sync syn'ed up to date and the problem with DDNS not connecting was fixed. So I've now set both the NAS & router to use CloudFlare as primary DNS and OpenDNS as secondary.

I may be counting chickens before they've hatched but so far no DDNS issues. So I'm crossing my fingers the issue is sorted....
Upvote 0
Alas it was offline last night between 00:35:06 - 01:17:05. The next test is to put the ISP BT router back in place for the weekend and see if the issue persists. If it fixes it then it's an issue with the Orbi if not then it is definitely the NAS.
Upvote 0
Situation update - I ran with the ISP router/modem in place for 24 hours, not a single problem. This morning I switched back to using the Orbi router (using the ISP’s DNS) and the Vigor 130 ADSL modem.

So far no issues at all.

What I’m wondering is……. The Vigor 130 modem had been online to the ISP since I installed it and the Orbi last December. At that point it grabbed and held the dynamic IP address assigned to me by my ISP.

I’m wondering if that IP was being attacked by third parties out there, this would tie in with the number of attacks I was seeing - I’d never seen any attacks on the NAS prior to the recent incidents which tie up roughly with when I noticed the DDNS issues.

Either that or it was an issue with the IP address and my ISP.

I’ll continue to monitor the situation. I’ve made a note to reboot the Vigor modem once a month. :)

I so hope this has fixed the issues!
Upvote 0
No errors with the DDNS since 03/09 00:21:59 so it looks as if the issue is fixed!

Still getting the Orbi system reporting on attacks coming through so it must have been the dynamic IP address and the ISP that was at fault!
Upvote 0
Alas the darned problem is back again……. Rebooted the Vigor modem, no difference….. Sigh. More testing I guess.
Upvote 0
Hmm after doing a lot of frantic DDG'ing on the web I've turned off the VPN server on the NAS and DDNS started working immediately.
Fingers crossed!
Upvote 0
Well that didn't work :)

However, it looks like it is an issue with the Orbi router I found this thread. I've now turned off daylight savings adjustments on the Orbi and raised an official ticket with Netgear to see what they come back with.

I guess this thread can be closed out as doesn't appear to be a NAS issue.
Upvote 0
LOL, looks like the fix is to turn off a couple of things so yeah, looking good so far. It'll be interesting to see what Netgear come back to on the ticket.
Upvote 0
Maybe too soon that that joke ;)
I had a Netgear once. It died silently without turning off (or on) anything (maybe it’s a security feature). That was my first and last Netgear.
-- post merged: --

LOL, looks like the fix is to turn off a couple of things so yeah, looking good so far. It'll be interesting to see what Netgear come back to on the ticket.
I know it’s Synoforum. But I’m curious. Add me to your mailing list if you have to :)
Upvote 0
I tried out 5 Mesh networking systems including big names like Linksys etc. The only system which performed up to expectations and worked reliably was the Netgear Orbi. I've used three Netgear routers over the years and all have performed very well indeed.
Upvote 0
Hmmm, still waiting for the Netgear engineers to contact me.

I've made the recommended changes to fix the issue and rebooted the Orbi. Been okay so far. Fingers crossed.

I'm wondering in the interim would it be worthwhile setting up DHCP on the NAS and use that instead of the Orbi?

Thinking that'd get around the broken DNS on the Orbi?
Upvote 0
Nope, I considered options like that and from what I've read if it tries to update it messes it up.

The annoying thing is that the firmware that I'm running is supposed to fix the bug, for me it brought it in. The 'interim fixes' for the last firmware was to turn off daylight saving awareness and turn off traffic monitoring and reboot the router.

I only turned on daylight saying awareness a week or so ago (which may have triggered the issue in the first place. Traffic monitoring I've never used.

When my good lady finishes work tonight I'm either going to try DHCP Server on the NAS (if I can work out how to implement it) and / or hard reset the Orbi and rest it and see hoe that goes.
Upvote 0
It's not a Synology issue, but alas is with the Orbi.

I've got a call with a Netgear Engineer tomorrow afternoon.

I've been through a whole host of testing, gone back to the ISP router to prove that has no issues, downgraded the Orbi firmware (which it auto-upgraded). Latest thing was to re-load an old config from back in April (which I know was good).

So far 6 hours without a DNS issue. I'm not convinced it's fixed it, at the issue had occurred at various intervals from 2 to 112 hours.

However, I did go through the settings to see what was different in this configuration and the only difference was NTP was set to use the Netgear NTP server instead of uk.pool.ntp.org.

In the raft of reading up on the issue I've done one guy mentioned it could be NTP related. So I switched the NTP server to uk.pool.ntp.org, had second thoughts and went back to the Netgear server. When I looked to confirm that change reversal I got an error message: "* Warning: The Orbi Router failed to connect to NTP server, please check your internet connectivity or try another NTP server".

I left it saved at using the Netgear NTP server, but I'm wondering if it is an NTP issue and the Netgear NTP server is broken is that what is stopping the problem from occurring?

Just a thought..... So can you check what your NTP settings are? Maybe set the NTP server to Netgear, see if you get the error I do? And more importantly if it fixes the problem for you?
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

  • Question
Hi, Trying to set up DDNS support through a registered hostname (with OVH) & cannot for the life of me...
Yep. Am on 900/900. Fortunately Fiberhop is small enough to talk turkey with, any of the big isps are...
Once ABB is setup with the valid LE certificate then it will continue to work. The LE certificate will...
Ok, this was another new thing for me to look into. Thanks!
These are results all over the place. Could it be that the built in DOH feature in those browsers is...
  • Question
Web Station by default uses TCP port 80 so the firewall rule in DSM would look like: Enabled Ports =...

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!