Deleted /lib/modules/tun.ko from DSM 7.0 Install

Currently reading
Deleted /lib/modules/tun.ko from DSM 7.0 Install

3
1
NAS
DS720+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. iOS
I accidentally deleted the lib/modules/tun.ko file from my DS720+ that I recently upgraded to DSM 7.0. Would anyone happen to have a copy of the file that they could post or know where I could get it? I was trying to get a docker container running transmission/openvpn working and I removed the wrong file. It doesn't appear to have broken anything, but I would still like to replace the file.

Any help would be greatly appreciated.
 
Last edited:
Is there a special way to re-apply? I tried to apply the same file I had used moments before to upgrade to 7.0 and it errored out and wouldn’t let me.

Do you have some more information on the update error you got?

Also, I don't know how you tried to re-apply the f/w upgrade but if you did it from within DMS7.0 itself you may want to try the (Desktop client) Synology Assistant and manually download and update the firmware with that instead.



Edit: I just realized it may throw an error if the firmware is the same or older version (in that case you need to use the Assistant method I described as far as I remember.
 
Upvote 0
Thanks everyone! I ended up using 7-zip to open the pat file and was able to grab the deleted file directly from there.
 
Upvote 0
Thanks everyone! I ended up using 7-zip to open the pat file and was able to grab the deleted file directly from there.
Hi Jeff! Just ran into the same issue (deleted tun.ko). When I open the .pat file, there's a bunch of .deb files. Do recall which one contains tun.ko, and how to extract it? Many thanks!
 
Upvote 0
i just run into the same issue :( and deleted my tun.ko due a mistake (shame on me!!)

I can not update my synology as there is no re-applying of the same version possible (even with Synology Assistend Desktop App as @forkless mentioned it is not possible)

i can not extract the tun.ko with 7-zip from the *.pat file since the *.pat is encrypted.

lsmodule and find / -name tun.ko did not find it.
sudo insmod /lib/modules/tun.ko leads to error
insmod: ERROR: could not load module /lib/modules/tun.ko: No such file or directory

can someone provide me the right file?
I dont want to do reset mode 2, because i have a lot of different settings/users/ etc...

DS920+ with DSM 7.1.1-42962 Update 5

Thank u !!!
 
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Back
Top