DKIM with Mail Server - what am I doing wrong?

Currently reading
DKIM with Mail Server - what am I doing wrong?

1
0
NAS
DS414
Hi,

I have a DS414 running DSM 6.2.4, and the current version of Synology Mail Server.

Synology Mail Server has been working fine, but Gmail has started not accepting mail without DKIM or SPF, so I want to add DKIM.



To understand my situation:

I have a dynamic IP address, and I am using dyndns, and CNAME.

I am also using a relay of my ISP.



I've been trying to set up DKIM, but it hasn't been working. Can someone please check what I am doing wrong?



My FQDN is set to istvan.szucs.net (that is what is typed in the field in Synology Mail Server)

SMTP relay is set up to my local ISP (t-online.hu).

I am using dyndns for my server. The server name on dyndns is sz.mine.nu.

I have the following DNS entries for szucs.net:

CNAME sz.mine.nu

MX istvan.szucs.net

I have a TXT redcord v=DKIM1; k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDvKE58RalEwOvBoCIvUfvz0VT7eMcNu8OnmT5KBDet9lEH9OSxg0LW7mMxotrhKiTU+CmiWFKQgmFnzyyPWy7vtMv4OnqsdLVUeRyySik9C11OrB9AsDD34xQ2lbvjILzvQ+OPVrJHs6qtjnfzcHPSCNwG2CJNn081J6e6HVQIDAQAB (public key copied from Synology mail server)

Can someone check what I am doing wrong?
 
I've not used DKIM but have added a SPF record, which seems to work.

TypeHostValue
TXT@v=spf1 mx a ip4:EMAIL_PROVIDER_IP_SUBNET a:smtp.MY_DOMAIN a:smtp.MY_ISP_DOMAIN include:MY_DOMAIN include:MY_ISP_DOMAIN include:_spf.google.com ~all

This is sort of how I built my record. You just need to think where you are going to be sending mail from for your domain and add these IPs, names, and domains to the SPF. For my domain I'm saying mail comes from my email service provider's IP addresses, but also I sometimes send via my ISP or Mail Server (using resolved to host and domain), then the Google one is mostly legacy and I should probably remove it. I could tighten the ISP declaration but they keep renaming the servers and their domain (I joined Virgin Media when it was NTL).
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

I thought I had DKIM and SPF sussed but Google disagrees. I'm sending mail from server.mydomain.tld but...
Replies
0
Views
519
  • Question
Not sure about Mail Server. But on MailPlus, you can find the setting under Auditing->Log management...
Replies
1
Views
681
  • Question
How have you configured high-availability with standard Mail Server on two NAS, with one static external...
Replies
3
Views
1,314
What happened when you clicked the Mail Logs 'Clear' button?
Replies
5
Views
2,485
UK... so almost the opposite of :) One other thing: I know Mail Server doesn't have this in the GUI but...
Replies
10
Views
2,061
trying to configure my DS918+ as email server that will tech emails form multiple servers: Installed...
Replies
0
Views
1,751
Just wait until the next update then. Hopefully it’ll be “magically” fixed :) That’s what happened to me...
Replies
8
Views
2,517

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Back
Top