docker on Nas Syno DS214+ : error synolocalAccountgroupeset failed, synoerr=01700

Currently reading
docker on Nas Syno DS214+ : error synolocalAccountgroupeset failed, synoerr=01700

Operating system
  1. Linux
Last edited:
You might want to ask the author of the gist, this is the comment page for it:

I tried to add it as link, but the link was always replaced by the content of the gist.

Though, you do understand that this "just" uses the official binary release - so no Syno Docker UI and the vfs storage driver (be prepared: it will waste a lot of storage space) and on top vfs is not mend to be used productive (docker says: use for testing purposes).

Honestly, you would be better off to buy a Raspberry Pi and use docker there.

I tried to use an old DS214+ for my home automation software, therefore I tried to install Docker on it.
CPU: MARVELL Armada XP MV78230

I'm receiving the following error message:
root@NAS:~# docker
-ash: /usr/local/bin/docker: cannot execute binary file: Exec format error

Any idea, why there is an Exec format error?

"ps auxf | grep dockerd" output:
root     10216  0.0  0.0   4856   952 pts/0    S+   13:37   0:00                      \_ grep --color=auto dockerd
Ok, I tried again with a different source: Docker on ARM-based Synology DS-line devices
Now I'm one step further!

cd ~/
mkdir docker_install
cd docker_install

tar xvf docker-24.0.2.tgz

cd ~/docker_install/
sudo cp docker/* /usr/bin/

Change the "daemon.json" with vi:
vi /etc/docker/daemon.json

"storage-driver": "vfs",
"iptables": false,
"bridge": "none",
"data-root": "/volume1/docker"

docker --version
Docker version 24.0.2, build cb74dfc
--> I'm using the right docker!!! (y)

If I'm entering
After some lines of startup routine, the following message is shown:
failed to start daemon: Devices cgroup isn't mounted

Any ideas to this?
cgroup is implemented in the Linux Kernel >=v3.10.
I have checked with "uname -r" the kernel version of the DS214+ running "DSM 7.1.1-42962 Update 6":
"Linux NAS 3.2.101"
--> The Kernel-Version is too old for cgroup... :cry:

For comparison I have checked the kernel version on my other DS:
DS1621+ running "DSM 7.2-64570 Update 1": Kernel Version 4.4.302+
DS920+ running "DSM 7.2-64570 Update 1": Kernel Version 4.4.302+

As far as I understood, the following Synology NAS will not receive an update to DSM 7.2:
  • XS Serie: RS3413xs+, RS10613xs+, RS3614xs+, RS3614xs, RS3614RPxs, RC18015xs+, DS3615xs, DS2015xs
  • Plus Serie: DS2413+, DS1813+, DS1513+, DS713+, RS2414RP+, RS2414+, RS814RP+, RS814+, DS214+, RS815RP+, RS815+, DS2415+, DS1815+, DS1515+, DS415+, DS215+
  • Value Serie: RS814, RS214, DS414, DS214, DS214play, DS114, RS815, DS1515,DS715, DS415play, DS115
  • J Serie: DS213j, DS414slim, DS414j, DS214se, DS215j, DS115j, DS416se
--> I'm not able to wait for the kernel update with DSM 7.2, because the DS214+ will not receive the update... 😭

I have tried several Docker Versions:
Docker Version 23.0.0 - 24.0.2: "failed to start daemon: Devices cgroup isn't mounted".
Docker Version 19.03.9 - 20.10.24: "Illegal instruction (core dumped)"
Docker Version 17.06.0-ce - 18.09.0: "Your Linux kernel version 3.2.101 is not supported for running docker. Please upgrade your kernel to 3.10.0 or newer."

My conclusions and possible solutions of the problem:
  • Use an older Docker version: Where do I find a Docker for armhf which is older then v17? (I found nothing older here: Index of linux/static/stable/armhf/)
  • Linux Kernel update: Is it possible to update the Linux Kernel in the DSM from Linux Kernel 3.2 to 3.10?

Or any other ideas for solving my problem (beside buying a newer DS ;))?
Last edited:
Use an older Docker version: Where do I find a Docker for armhf which is older then v17? (I found nothing older here
It always required cgroups. I doubt following this path will get you anywhere.

  • Linux Kernel update: Is it possible to update the Linux Kernel in the DSM from Linux Kernel 3.2 to 3.10?
This path is more promising. That is, if Syno has a newer kernel for your DS in their open source repos: Synology Open Source Project - Browse Files at The architecture for the DS214+ should be armadaxp.

If there is a matching toolkit and the kernel for that version, you could compile your own kernel. Though, you can not use a generic kernel, as Synology has a habit to make the kernels, libraries, and tools their own (aka have modifications) and you could potentially mess up your system if you try to use a compiled vanilla kernel on your NAS.

Even if you manage to build your own kernel, how did you embed it on you NAS? I have no idea how it's done. Maybe this post gives insights: Synology Community

Update: it looks like Synology removed the kernels from their Open Source page.

Update2: Is it really worth the trouble? If you get yourself a Raspberry PI 4, you get beefier hardware, and an ecosystem where everything is already established + a wide range of images that support the cpu architecture. Every Docker installation that requires vfs as a storage driver, can be considered a half-a**d play environment at best: it will neither be efficient on the storage, nor will it be fast when handling files.

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

I am struggling with that since I am only a copy & paste hacker. I have installed netdata on my Synology...
s4: It seems the INSTANCE_NAME is related to the world you have to create with the tool mentioned in the...
would be good to have some backup of the whole setup, but 99% all will be running just fine out of the...
Done on both my NAS'es running Docker! :) Thanks again!
  • Locked
Locking this thread due to publish tutorial...

Welcome to! is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads