Solved Docker package doesn't start anymore

Currently reading
Solved Docker package doesn't start anymore

80
23
NAS
DS209j | DS210j | DS410 | DS214 | DS216+II | DS916+ | DS920+
Router
  1. RT2600ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
I just did an update of the Docker package to 18.09.0-0513
and now the package wont start anymore.

Not even if I try manually after a reboot:
Code:
ash-4.3# synoservicecfg --enable pkgctl-Docker
service [pkgctl-Docker] start failed, synoerr=[0x0000]

somewhere I read VPN Package blocks the new start ("Docker can't create a network for itself when starting if a VPN is running" Synology Community )
but stopping the VPN Server didnt help.

Any other ideas?
Thanks!
paradeiser
 
just to let you know what caused the problem here a quick follow up

Synology support sent me this response after remote access:

Apparently the Network Database local-kv.db had been corrupted.

By renaming the File, Docker is not able to detect the existing corrupted Database and creates a new Database.

Docker was able to start with a new Database.

The Networksettings created in Docker previously will be lost however.

/case closed
 
Wow, glad they could sort it out. I never knew exactl where local metadata state was exactly stored. There are a couple of binary .db files in the root-data's subfolder. I probably would have deleted the whole root-data to reset the state to an empty state. Then I would have deployed all container from docker-compose.yml files again.

Learned something new today. Thanks for that :)
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

For the heck of it, I just checked again in docker container, and it announced an update was available. I...
Replies
4
Views
485
  • Question
Do realize, that enabling any user to run docker containers is largely the same as giving that user full...
Replies
6
Views
1,082
Hello, I already have it configured perfectly with wireguard. I was looking at the Gluetun configuration...
Replies
4
Views
764
Thanks... I tried something similar with rsync. The docker volume lived in...
Replies
7
Views
768
I can’t find any option to restore just the settings. 1710356648 Phew, managed to fix it. Within the...
Replies
4
Views
583
Good to hear. Deluge has not been updated for almost two years now as an app, nevertheless. But it gives...
Replies
12
Views
1,275
  • Question
Open an issue on that GitHub page. The developers will be glad to assist. OP has posted two threads on...
Replies
5
Views
1,238

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top