Solved Drive destkop client problem

Currently reading
Solved Drive destkop client problem

21
6
Hey there
I used nextcloud for quite a while. But i keep having some issues with external storage. Also I do not like the fact with the docker container not supporting th PUID feature...
Anyway i want to give synology drive a chance to prove itself.
I configured it with following parameters:
So far so good. Then I wanted to test this configuration: Opened the drive app on my iPhone: secret.com, user and password and use https check. And it worked perfect.
And now my struggle: This do not want to work on my computers. Inside the network or outside the network. Always the error: cannot connect to server.
I tried several diffrent option: customise word like secret.com/drive etc. No connection.
I tried it with three macs and a windows virtual machine.
I can only get a connection, when I use the direct IP-address of the server. When I connected with the direct IP I can use the forwarding of the client app to open the drive app in my browser. This is working.
For now... I do not have any addtional ideas.

Is there something I missed? Maybe a configuration? A hidden secret?

Thanks in advance!
 

Rusty

Moderator
NAS Support
4,101
1,179
www.blackvoid.club
NAS
DS718+, DS918+, 2x RS3614RPxs+
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
So trying to get to your FQDN drive.secret.com does not work inside your LAN on any desktop device in any browser? If so then your router does not support NAT loopback feature and you will have to use local nas ip/port to get around this.
 

Rusty

Moderator
NAS Support
4,101
1,179
www.blackvoid.club
NAS
DS718+, DS918+, 2x RS3614RPxs+
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Any firewall active?

Synology Drive Server80 (link sharing), 443 (link sharing), 5000 (HTTP), 5001 (HTTPS), 6690TCP
 
21
6
That is maybe a good hint. 6690 is a port I'm not aware of.
But then there should be a difference in the mobile and desktop version. The clients will use different ports.

I will check that!
 
2
0
NAS
DS718+
Operating system
  1. Windows
Mobile operating system
  1. Android
Last edited:
It was the port 6690 :)
Thanks Rusty!
Hi, I just have the same issue, but I don't have clear how to resolve. I redirected on my router the port 6690 to 443 for the reverse proxy do the work.
Here the RP resends from 443 to web interface drive port that I think that is not the way. (it works on browser perfectly).

But I think I missing something.

I just deactivated the firewall on the NAS. No good results.
I tried on synology drive desktop client to connect to drive.mydomain.com and mydomain.com and nothing. "Connection error".

for RP I have htaccess file like this.. for when I becomes an https petition... but it is for HTTP incoming calls redirect https calls.
I start thinking that it gonna be one rule I have that is MyDomain.com redirects directly to DSM Web interface, but it only answer if port is 443, not 6690...

RewriteEngine on
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

maybe it is redirecting to nowhere the 6690 over ssl?

Can you tell me how do you did that works?
 

Attachments

  • Captura.PNG
    Captura.PNG
    26.6 KB · Views: 22
2
0
NAS
DS718+
Operating system
  1. Windows
Mobile operating system
  1. Android
Ok I solved. just using my drive.domain.com and redirect from 6690 to 6690 on router to the nas.
:)
 

Rusty

Moderator
NAS Support
4,101
1,179
www.blackvoid.club
NAS
DS718+, DS918+, 2x RS3614RPxs+
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Ok I solved. just using my drive.domain.com and redirect from 6690 to 6690 on router to the nas.
:)
6690 is the Druve client port that desktop and especially mobiles apps use. Apart from that you can get to the drive ui via 443 but the client one needs 6690 to work.

Glad you got it going.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Was Drive Server v2 ever supported on DSM 7? I can't remember but the release notes don't seem to have a...
Replies
4
Views
157
I managed to nuke the Drive client install by just deleting all folders and hidden files I could find...
Replies
7
Views
191
  • Solved
Ahhh... makes perfect sense now. Thank you for taking the trouble to not only answer but also to clarify...
Replies
4
Views
390
  • Question
Not sure what to tell you here. Best to wait for some some potential answers/ideas from other members.
Replies
7
Views
263

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Top