DS audio DS Audio doesn't play anymore on iPhone

Currently reading
DS audio DS Audio doesn't play anymore on iPhone

Operating system
  1. macOS
Mobile operating system
  1. iOS

I'm a long time Synology, Audio Station and DS Audio user. Since a couple of weeks, my DS Audio app doesn't play songs anymore. When I select my Apple TV or an uPnP/DLNA renderer, it does play fine. But when I set it to play via my phones speaker or in the car via Bluetooth on the car stereo, it doesn't play. Whenever I select a playlist, all songs are added to the queue. Then DS Audio tries to play each song, but it doesn't succeed and skips to the next, until it reaches the end of the queue. When I first manually download a song and then play it from the "downloaded songs" list, it does play.

Does anyone have the same problem? How do I resolve this and prevent it from happening again? Any help would be highly appreciated!

After a lot of emails back and forth, Synology support was able to supply me with a work around. The problem is apparently caused by some security-compatibility thing with iOS. There are two possible work arounds:
  • Set the TLS/SSL profile level for the whole Diskstation to "Old backward compatibility"
  • Disable SSL for the DS audio app.

I chose the latter. Combined with a user that has only access to DS audio and the music folder, this should be fairly safe. Synology support says their product development has put this item on the list to be solved. So in the longer term, it should be able to stop using those work arounds.

I hope this is helpful for people experiencing the same problem.
I can log into DS Audio just fine. Music queues up fine but songs won’t play on iPhone 14 pro max. I click on play button and I briefly see the pause button before it’s replaced by the play button again. I’ve tried changing compatibility settings to no avail. Ive used suggested solutions to no avail.
Can you go to control panel, security, then advanced and let me know which TLS/SSL Profile Level you’re set to?
Upvote 0
Last edited:
Modern. Ive tried all 3 settings. no results
Modern causes issues, bring it to intermediate and give it some time. Log out of the app, force close it and give it some time to pass. Then check it again, I saw the same results. When I switched it to modern it did the same thing everyone else and you are saying. I then switched it and it didn’t start working right away it took some time; but ultimately it’s the modern profile. I’ve mentioned this earlier in the thread as well.

*Update I confirm again I changed my security profile from intermediate to modern, force closed the app then tried a list of songs. I clicked the first song and it skips down to the fourth song and plays. I then changed from modern to intermediate, forced closed the app, went back in and selected the same folder and list of songs. I clicked on the first song and it played properly without skipping.
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

DS audio DS Audio
I found if I unplug then plug back to Android Auto, DS Audio will continue playing; however, this is...
  • Question
Hi it doesn’t give the message when I’m looking at downloaded files when not logged into the NAS, it only...
  • Solved
Which means DS Audio is using TLS version 1.2
Yes that’s basically the way I was trying to explain. The only real difference between what successfully...
  • Question
Don't think I have any video files in MKV (H.264 / AAC). I have MKV (H.264 / LPCM plus other stereo and...

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!