Question DS1517+ Has it died on me?

Currently reading
Question DS1517+ Has it died on me?

Wow, official forum has plummeted to new depths, so dipping my toe in here!

DS1517+ with 5x WD HDDs, 10GbE PCIe card (a Syno E10G18-T1).

Reasonably flat network:

- Router providing 2 LANs and 1 VLAN, firewall, DHCP and DNS

- NAS resides on main LAN with an assigned address of 10.0.1.45

- NAS (normally) connected to Port #1 on primary switch, which also provides 10GbE links to 1 client (#2), 1 server (#3), router (#4, #6) and a 10GbE DAC link (#5) to secondary switch with clients and APs various:

Screenshot 2019-08-22 at 18.38.22.png


Symptoms:

NAS web page was slow to load. Link was up and normal. NAS was commanded to shutdown, which took much longer than normal. On restart the NAS boots normally, fans run-up, all 5 drives are spun and main status light turns steady green. Then drives 1,2,3+5 went to a fixed green light with drive 4 flashing. 10GbE link established but no IP address set and arp shows only a self-assigned address (169.254 etc) with “(incomplete)” reported under the MAC address. No change for some time so tried restart attempt 2, this time from the power button:

Same boot, link, no arp other than APIPA, no MAC but this time drives 1,2,3+4 are showing a fixed green activity light with the flashing activity light now on drive 5.

The status light has remained green, the blue power light is steady and I have let the system to run in the state above. At some point during this period the NAS managed an “improper shutdown” email but I didn’t notice such an event.

The NAS does not respond to ping on either its normal static address or the APIPA self-assigned. The link remains “up” on the switch side and negotiates to 10GbE and the NAS NIC will accept any manually entered link speed offered. Also tried a standard ethernet cable to a native LAN port on the NAS, just to rule-out the PCIe card - no change.

I’m not sure what mode the NAS is in or why the status light is green with a steady blue power light. The active drive almost sounds like it is indexing, albeit at a slower rate.

Ideas?
 

Rusty

Moderator
NAS Support
2,232
670
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
RT1900ac, RT2600ac, MR2200ac
Could be a C2000 cpu bug. Open up a ticket with syno.
 
Thanks Rusty,

I thought the DS1517+ was outside the range of the C2000 series issues - did the original catchment group grow to include more recent units?
 

Rusty

Moderator
NAS Support
2,232
670
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
RT1900ac, RT2600ac, MR2200ac
Not saying that’s the case. The cpu is the same so that’s why I said it could be but not sure for a fact.
 
Fair point. When Synology acknowledged the issue they suggested the 17 models and above had a fix in place at manufacture. This may have been overtaken by time and events.
 
The back and forth with Synology support was painful and protracted. In the end I just lost faith in their circular efforts and stripped-it back to basics, factory reset and built the raid back from backups. I was very concerned with their desire to use Telnet and port forwarding to gain remote access. Not exactly security friendly!

The 'support' could not get passed a problem with DSM itself. I could install it ok on a fresh disk and then add the remaining raid disks but the bad DSM then corrupted the new load. The Synology tools and remote support just could not get a fresh copy of DSM to install. Many, many days of effort over weeks achieved nothing.

I'm a month in to the clean and fresh rebuild and all is well.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Top