Question DS412+ not booting: serial console shows EFI Internal Shell missing boot devices, but EFI partition on internal storage seems intact

Currently reading
Question DS412+ not booting: serial console shows EFI Internal Shell missing boot devices, but EFI partition on internal storage seems intact

Hey everyone

I am having issues booting my DS412+ that appeared after I had shut it down for just a while to reposition the unit. The unit does start, the fans work fine, but I am not getting any startup sound, only the blue LED blinking forever. The disks do not even spin up anymore and the reset button is not responding at all.

Since this unit has always been very reliable behind my UPS, I started looking for what was wrong. Using the serial port, I was able to see this screen as one would expect:

Granite Well.png


Afterwards I would expect the EFI to boot GRUB from the internal storage. However, I am receiving a mapping error
map: Cannot find required map name.
thus being redirected to the EFI Internal Shell:

EFI Internal Shell.png


I then replaced the CR1220 battery inside the device just to be sure, but to no avail. I then suspected the mass storage device to be broken or containing corrupt data.

Unfortunately, the EFI is said to have been modified in a way to not allow any other USB boot device (than the onboard USB DOM) to even show up in the list of boot devices, so I cannot just try booting from a flash drive.

I then took a look at the data on the USB DOM, where I would expect the EFI boot partition to reside:

Partition.png


The partition looks like an ordinary EFI partition and appears to contain the boot loader. It should work.

The EFI also looks like it still contains the configuration that Synology programmed into it:

Code:
Variable NV+RT+BS 'Efi:Boot0000' DataSize = 58
  00000000: 01 00 00 00 2C 00 45 00-46 00 49 00 20 00 49 00  *....,.E.F.I. .I.*
  00000010: 6E 00 74 00 65 00 72 00-6E 00 61 00 6C 00 20 00  *n.t.e.r.n.a.l. .*
  00000020: 53 00 68 00 65 00 6C 00-6C 00 00 00 04 07 14 00  *S.h.e.l.l.......*
  00000030: 01 ED D9 30 D2 38 8A 41-90 D5 C5 61 75 0B F8 0F  *...0.8.A...au...*
  00000040: 04 06 14 00 B7 D6 7A C5-15 05 A8 40 9D 21 55 16  *[email protected]!U.*
  00000050: 52 85 4E 37 7F FF 04 00-                         *R.N7....*
Variable NV+RT+BS 'Efi:Boot0001' DataSize = 40
  00000000: 01 00 00 00 1C 00 45 00-46 00 49 00 20 00 55 00  *......E.F.I. .U.*
  00000010: 53 00 42 00 20 00 44 00-65 00 76 00 69 00 63 00  *S.B. .D.e.v.i.c.*
  00000020: 65 00 00 00 02 01 0C 00-D0 41 03 0A 00 00 00 00  *e........A......*
  00000030: 01 01 06 00 07 1D 03 05-06 00 00 00 7F FF 04 00  *................*
Variable NV+RT+BS 'Efi:Boot0002' DataSize = 9C
  00000000: 01 00 00 00 84 00 53 00-59 00 4E 00 4F 00 4C 00  *......S.Y.N.O.L.*
  00000010: 4F 00 47 00 59 00 00 00-02 01 0C 00 D0 41 03 0A  *O.G.Y........A..*
  00000020: 00 00 00 00 01 01 06 00-07 1D 03 05 06 00 00 00  *................*
  00000030: 04 01 2A 00 01 00 00 00-3F 00 00 00 00 00 00 00  *..*.....?.......*
  00000040: 43 7D 00 00 00 00 00 00-33 3D 06 2B 6F 52 80 46  *C.......3=.+oR.F*
  00000050: B3 44 32 9B 22 9B C2 59-02 02 04 04 3E 00 5C 00  *.D2."..Y....>.\.*
  00000060: 45 00 46 00 49 00 5C 00-62 00 6F 00 6F 00 74 00  *E.F.I.\.b.o.o.t.*
  00000070: 5C 00 53 00 79 00 6E 00-6F 00 42 00 6F 00 6F 00  *\.S.y.n.o.B.o.o.*
  00000080: 74 00 4C 00 6F 00 61 00-64 00 65 00 72 00 2E 00  *t.L.o.a.d.e.r...*
  00000090: 65 00 66 00 69 00 00 00-7F FF 04 00              *e.f.i.......*
Variable NV+RT+BS 'Efi:BootOrder' DataSize = 2
  00000000: 00 00

In conclusion, both EFI and the mass storage device inside the unit look fine, but the EFI cannot find the storage to continue booting from it. Exiting the EFI Internal Shell does not present me with any helpful options, either.

I would greatly appreciate if anyone had a suggestion on how to track down the cause of this behaviour and maybe even how I would go about fixing it. My DS412+ is working fine and I would love to keep it around.
 
1
0
NAS
DS412+
Hi Orditivi,

Have you made any progress with your unit?

I have also recently had a DS412+ fail to boot. I too only have the fans and the flashing blue power light. In my case, it happened when I was updating the DSM and my theory is that something went wrong with the update and caused some corruption with the boot media however I have been unable to find how to connect to the board via serial. Could you please share how you did this?
 
1
0
NAS
DS412+
Operating system
  1. Linux
  2. Windows
Mobile operating system
  1. Android
  2. iOS
Any solutions? I have same problem.
With another usb pendrive with PID/VID F400/F400 DS412+ is booting - from flash it cant.
 
5
0
NAS
DS620slim, DS2413+, DS414slim, DS214play
Operating system
  1. Windows
Mobile operating system
  1. iOS
Hello

This is a known Problem.
The DS412+ (and NAS with same CPU like DS1512+ DS2413+ etc.)
show
map: Cannot find required map name.
when the DOM (Flash Module) is damaged.

When you connect the DOM to a PC you will find it well working and see no problem. However if you create an Image you will find out that its really slow (< 1MByte/sec - Normally it would be 5MByte /sec).

USB Details will show that its only working in USB1 Mode.
That usually will never be problem unless you have a DS412+

The DS412+ simply seem to have no drivers for a DOM working in USB1 Mode.
That is why it will not work anymore.

Solution is simple:
You only need a new DOM, copy the image to it and it works again.


Other NAS can work with USB1 DOM

As Reason for this damage it was sometimes told that a Power Outage happened. Anyway it is likely that the USB-Chip on the DOM is just too old and is not able anymore to confirm the required USB2 Connection.

Nico
 
10
0
NAS
Synology 412+
Operating system
  1. macOS
  2. Windows
Mobile operating system
  1. iOS
Hi. Did a standard restart and now won't boot. I think this is the issue with my 412+. Nico (or anyone) - any chance at posting detailed instructions on how to get to the DOM/Flash Module, transfer/connect it to a PC, copy the existing image, replace the DOM and copy the old image to it. Can this be done using a serial port or do I have to open up the unit? I'm pretty good and fearless, but after a few hours of internet searching I can't find much help on how to do this. Thanks so much. Really need to boot this unit at least one more time to rescue the data.

I did just find an iFixit guide on how to get to the ram module. That I can do. From here not sure how to plug the module into another PC, copy the image, etc. Any and all thoughts SO APPRECIATED.

Thanks,

Chris
 
5
0
NAS
DS620slim, DS2413+, DS414slim, DS214play
Operating system
  1. Windows
Mobile operating system
  1. iOS
Hello Chris

You need to open the unit in any case.
The Serial Port and DOM/Flash are accesible from the inside only.

Important:
Please take all your harddisks out and DO NOT MAKE ANY TEST Run with them. Also you should not try to recover any DATA. The Data is still good and the Syno is repaired it can be used like before. So I would not try to make anything with the disks until then.

To determine what could be wrong you can either check the DOM/Flash or the serial Port.

The serial access is usefull for any type of problems. You will need a levelshifter because the serial port on the syno works with 3.3V the serial port of a PC works with 5V. When starting the unit should output a starting log which should look similar to the one posted by Orditivi. This output indicates that the DOM/Flash is defective. Still you need the image to build a new one.

The DOM/Flash could also be examined itself, for this you will need to connect it to a pc. If you are lucky your DOM/Flash has a micro usb connector (this would make it really easy). If it does not have a micro usb connector you need an adapter.
Once it is connected to a pc you can create an image and with that test the DOM/Flash. I was using the USB Image Tool and messuring the time which the creation of the image needs. Its 128MByte in size. If it takes less than 1 minute it would be ok, if it takes longer than its defective (but the image is still good).

Please Check which way (serial or DOM) you can go and then get back to me.

Greetings
Nico
 
10
0
NAS
Synology 412+
Operating system
  1. macOS
  2. Windows
Mobile operating system
  1. iOS
Hi Nico. I'm finally getting to this. Needed some courage. I'm going to purchase this serial adaptor. Hopefully correct. That will get me into the serial port. My DOM/Flash doesn't have a micro USB and I'm a little confused about how I would access it. It plugs into the board by a 10-pin connector and I'm not sure how I would access the female connector. You mention an adaptor above but haven't seen one in my travels on the web. Or, can I read the DOM/Flash through the serial port? I really appreciate your help. Have considered doing bit by bit copies of the drives, purchasing a more modern Synology and hoping it will read the drives but that seems very expensive and anything but a sure thing. A couple of inexpensive adaptor cords and perhaps a new DOM/Flash seems much more practical if I can figure it out. Thanks again!!!
 
5
0
NAS
DS620slim, DS2413+, DS414slim, DS214play
Operating system
  1. Windows
Mobile operating system
  1. iOS
Hello Chris

I can not tell for sure but I think your Adapter should be correct.
Important is, that the Adapter does not provide any 3.3Voltage to the mainboard,
yours has only 3 Cables (Ground + RX + TX) so its fine. Leave the 3.3V Pin open.

For pinout see the following table and picture.
On your PC you need a terminal app like putty.
Serial speed must be set to 115200bps

Connect everyting and open putty for the proper serial port.
Then Start the NAS. If all is good you should see some text
in the screen. If not you may exchange TX+RX connectors
any try again.

If you see Text scrolling it may stop at one point with an Error.
In that case please copy at least the last few lines in here so
that I can see them.

Good Luck :)
Nico

Pin numberFunction
13.3V
2GND
4TX
6RX
 

Attachments

  • syno_ser_pins.jpg
    syno_ser_pins.jpg
    9.8 KB · Views: 5
10
0
NAS
Synology 412+
Operating system
  1. macOS
  2. Windows
Mobile operating system
  1. iOS
Hi Nico. A noob with questions. Ugh. I thank you for your patience!

Got the Adafruit 954 serial to USB cord and may have messed up. The power is 5V but TX ar RX are 3.3. Also the female adaptors are too big for the below JP1 pins. Here's a picture of my board:

Synology 412+ Board.jpg


First - do I need power for this? As I re-read above seems I don't. I do have this connector handy and could reverse engineer for pins 2,4, and 6 (it does fit) if I only need GND, TX and RX.

Smaller Connector.jpg


Thoughts? Thanks so much!!!
 

Attachments

  • Smaller Connector.jpg
    Smaller Connector.jpg
    499.7 KB · Views: 8
  • Synology 412+ Board.jpg
    Synology 412+ Board.jpg
    2.1 MB · Views: 12
10
0
NAS
Synology 412+
Operating system
  1. macOS
  2. Windows
Mobile operating system
  1. iOS
Last edited:
Hi Nico. The good news - I have PuTTY set up with drivers and connected to proper com ports. Bad news - no output when turning on the board. I'm just not confident in my molex connectors to JP1. It was some pretty bad MacGyver action. Actually really struggling with these connectors. Can't figure out what size to ask for. Been online for a few hours and I'm nowhere. They seem like the female connectors for motherboard HD indicators and speakers, but maybe even smaller. Any advice appreciated. I could just solder into the above connector but I'm not entirely positive I'm making great connection to the JP1 pins. Thanks!
 
10
0
NAS
Synology 412+
Operating system
  1. macOS
  2. Windows
Mobile operating system
  1. iOS
Hello Nico (or anyone who want to jump in,)

Beginning to think I'm out of luck. Now confident in my connections to JP2 serial port and use of PuTTY and ExtraPutty. Even switching TX and RX I'm just not getting any output at all. Nada. The board starts and then blinks blue forever but no output to PuTTY. I've been shutting down by just holding the on/off button down until the lights go off. I could try another serial to usb cord but I have no reason to believe the Adafruit 954 is faulty or wrong for this application. This unit bricked on a proper restart.

Question - if I bought a used DS412+, would it be safe to put the disks in and start? Would it be better to create bit-by-bit copies before doing this? Could I buy and try a newer Synology?

Finally, any thoughts on the windows raid recovery programs from Stellar, EaseUS, etc.. Full disclosure - I did attempt the Linux approach as recommended by Synology. mdadm did see an active Raid 5 group named VG1000. However it threw a warning that the VG in VG1000 is using an old PV header and to modify the VG to update. Way above my pay grade and stopped right there.

Goal is obviously to rescue the contents of the raid array, but I would like to have some form of NAS back in my life. Any and all thoughts welcome!

Chris
 
7
4
NAS
DS412+
Operating system
  1. Linux
  2. Windows
Mobile operating system
  1. Android
  2. iOS
Last edited:
Hello,

same problem here, Blue LED of Death blinking :cool:
I am at the same point - serial console attached, Log says "Cannot find required map name".
I have attached the USB DOM to my Rasberry and made an Image without any problems. The resulting image could also be mounted on my raspberry. There are two EFI Partitions.

Hello

map: Cannot find required map name.
[...]
When you connect the DOM to a PC you will find it well working and see no problem.
[...]
Solution is simple:
You only need a new DOM, copy the image to it and it works again.

Other NAS can work with USB1 DOM
As Reason for this damage it was sometimes told that a Power Outage happened. Anyway it is likely that the USB-Chip on the DOM is just too old and is not able anymore to confirm the required USB2 Connection.

Can anyone clearify this to me?
The DOM only works for some reason in USB1.1 Mode instead of USB2? From one boot to another one?

Is that a problem with
  • the Controller Chip on the DOM (USBest UT165)
  • the Flash Chip on the DOM (Samsung K9F1G08U0C-PCB0)
  • or something with the USB Host connection residing on the Synology Mainboard?
  • something else (Xtal?)

My idea is to replace the damaged chip, but I would be great if anyone could provide an info which chip is defective.

Thanks
Sebastian
 
1
0
NAS
DS1512+
Last edited:
Google brought me here. My trusty DS1512+ is giving me the blue LED of death blinking after a weather-related power outage last week.

Waiting on the serial cable to be delivered Friday.

Plugged in a mini USB cable to my DOM. I am able to see the drive (in both Windows and Linux) and see two partitions 16 + 96 MB (and 13MB free). I'm unable to mount or interact with the drive without things hanging until I disconnect USB. I imagine I need a new DOM. What is a suitable replacement and how would one reimage it since I can't read from the original?
 
7
4
NAS
DS412+
Operating system
  1. Linux
  2. Windows
Mobile operating system
  1. Android
  2. iOS
Last edited:
Hello,

I have ordered a new flash chip and also a new UT165 Chip (Spoiler: there seem to be at least two Revisions of this chip).

Important: Do a full backup of the dom including the device descriptors (especially the serial). Hopefully you are able to access the old Dom with USB1.1....
I have done this with a raspberry:
Backup up whole flash:
Bash:
dd if=/dev/sda of=sda_complete.img conv=sync,noerror
Note: The resulting file will be everytime diffent at the end (I am not sure why).

Also do a backup of each partition:
Bash:
dd if=/dev/sda1 of=sda_1.img conv=sync,noerror
dd if=/dev/sda2 of=sda_2.img conv=sync,noerror
Note: When doing this multiple times, the files should be the same.

Also save the printout of lsusb -v:
Code:
Bus 001 Device 003: ID f400:f400 Synology Diskstation
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0        64
  idVendor           0xf400
  idProduct          0xf400
  bcdDevice            1.00
  iManufacturer           1 Synology
  iProduct                2 Diskstation
  iSerial                 3 12345678901234

After saving these data I replaced successfully the Flash Chip (Samsung K9F1G08U0C) - the idea was that this chip is defect because of aging.

After pluggin the DOM again in, it was recognized as "USBest USB2FlashStorage" - interesting. That means that the config-data of the USB-Chip is being stored in the flash Memory. The DOM was detected, but I was unable to mount it.

Important: All tools I have used, I used with Windows XP 32bit. I am pretty sure that newer Windows versions will not work! I am also pretty sure, that 32bit is a must-have.

Some google´ing later I found a recovery tool for the UT165:
USbest UT165 rescue v1.0.3.1 format tool
This tool started, regognized the DOM and installed the default firmware / formatted the stick - whatever. After finishing, the DOM was correctly found and I was able to store data on it - so far so good.

Now it´s time to customize the DOM again as Synology Diskstation, VID/PID f400/f400 (see the output of lsusb). Therefore I needed the USB165 MPtool. Heads up: There are different versions, I needed 1.65.17.0 for the flash being detected correctly. UT165 1.65.17.0 — FlashBoot.ru

After saving all required values and tested against "lsusb" I finally wrote back my saved Image:
Bash:
dd if=sda_complete.img of=/dev/sda

The result looked good; data was restored, stick identifies correctly. So I gave it an try in my Diskstation.
It did not came up, same error as before - frustrating.

After checking everything twice I noticed that the stick was still detected as USB1 instead of USB2.
Time to replace the UT165 chip....

After replacing the chip, the connection runs on USB2 - yes, nice !!
But my Flash is not being recognized anymore :-(

Google was my friend again - it seems there is an UT165 A0A and at least a second version UT165 A1B out there. The original one was A0A, my one is an A1B. It seems the difference are the supported flash chips. So I have ordered a new flash chip (this time a K9F8G08U0M) which seems to be pin compatible and being suppored by the UT165 A1B (It´s easier to remove the flash chip a second time than the UT165).

Actually I am waiting for the new flash and I will do the whole procedure once more.
I am very hopeful this will solve the issue - as @Nicommander wrote before:
Anyway it is likely that the USB-Chip on the DOM is just too old and is not able anymore to confirm the required USB2 Connection.

@tctlrld I did not find a replacement. Sometimes it seems that USB Sticks with an UT165 are being used (after provisioning them as described before), but it´s hard to find a model in which this chip is being used. Alternatively other USB Sticks are working also well, when the identification is correct. Also use the Front-USB Port, not the back ones. How to get an image of the old DOM? I do not know :) Try to readout your old one with Linux as described before. When thats not possible, try to replace the UT165 (with the exact type A0A/A1B !!).

Regards,
Sebastian
 

Attachments

  • 342617418-UT165-A1B-Flash-Support-List-26-pdf.pdf
    61.9 KB · Views: 17
  • UT165 A0A Flash Support List-13.pdf
    34.9 KB · Views: 16
7
0
NAS
Synology DS412+
Operating system
  1. Windows
Last edited by a moderator:
Hello,
I have (partly) the same problem as Orditivi:
  • Synology 214+ after a power failure the blue blinking led;
  • changed the CR1220 battery (old one was 1.15 V);
  • with a UART FTDI cable on JP1 on PuTTy the message "cannot find required map name";
  • as I understand it correctly the UT165 chip must could be the problem.

My question is how to connect a Windows PC to that chip. On the USB Flash/DOM I try to make a connection without succes. The connection is not visable in device manager of by the UT-165 rescue software.
My question is how to make a connection with the UT165 chip with a Windows PC.
Can I use the UART FTDI cable cable for this connection or an old USB cable?

1673804120409.png


1673804133190.png
 
7
4
NAS
DS412+
Operating system
  1. Linux
  2. Windows
Mobile operating system
  1. Android
  2. iOS
Hi!

UART FTDI is a completey other thing - it´s for a serial (RS232) connection on the client side, not for USB-Mass-Storage (=USB DOM).
Use simply an old USB Cable with USB-A Connector and conntect it like described in the link posted by you. The pinout of the USB-A Connector is here: Male to Male a to a USB Cable

Sebastian
 
7
0
NAS
Synology DS412+
Operating system
  1. Windows
Hello Sebastian,

Thank you for the reply.
I have connected with an old USB cable, unfortunately that does not work.
It is striking that after this action the connection to the JP1 port is no longer established.

Stan
 
7
4
NAS
DS412+
Operating system
  1. Linux
  2. Windows
Mobile operating system
  1. Android
  2. iOS
Hi!

you need an Image of the USB-Dom. Luckily I was able to restore mine (it worked still on USB1.1) - but it´s not an 214+.
I am not sure, where the serial is encoded in the DOM:
1. the serial is only coded into the usb dom (in the hardware description)
2. the serial is also coded in the files residing on the dom.

I am not sure, the first try is to get an image of your 214+ DOM from another user/device.

The best case would be to get two images aof the dom from different devices but with the same firmware version. Then it would be possible to compare the two ones wo check for option 1.) or 2.).

Sebastian
 
7
0
NAS
Synology DS412+
Operating system
  1. Windows
Last edited:
Hello Sebastiaan,

I made the USB cable, can you please instruct me about the software (for Windows) to establish the connection and how to read and change the data.

Stan
 

Attachments

  • Bioschip_412+.png
    Bioschip_412+.png
    335.7 KB · Views: 19
  • Connection_pinlocation.png
    Connection_pinlocation.png
    180.3 KB · Views: 24
  • Connection_to_old_USB_cable.png
    Connection_to_old_USB_cable.png
    371.9 KB · Views: 20
  • USB_chip_412+.png
    USB_chip_412+.png
    339.4 KB · Views: 13

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Thanks for clarification. Can you change the location of the shared folder that stores the VM to the other...
Replies
3
Views
384

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Top