DSM 7.1 upgrade bricked my DS718+

Currently reading
DSM 7.1 upgrade bricked my DS718+

Operating system
  1. Windows
Mobile operating system
  1. Android
Hey guys, new to this forum and looking to confirm the bad news. Is this thing bricked?
I've had a DS718+ for the last 4 yrs or so. 2 WD RED 4TB drives in SHR mode, BTFRS.
This is primarily storage for family pics. I also ran pi-hole and Unifi in docker containers. Since day 1, I installed an addition 8GB of RAM:

Crucial RAM 8GB DDR3 1600 MHz CL11 CT102464BF160B​

I know that although it's unsupported, but it's been solid all these years with 10GB

I've always kept my NAS up-to-date over the years. On May 18 I said yes to DSM 7.1, and it failed to update. Now it won't boot up: I get the status light blinking orange.

I've gone through tech support level 1, and now level 2. I've run extended tests on both drives (WD Lifeguard diagnostics). Took nearly 8 hours each, and they're both fine.
I've attempted reinstall on a blank SSD, and it always fails with: Failed to install the file. The file is probably corrupt. (13)
I've verified the md5 hash on all downloads, tried every version imaginable and it always fails the same way.

There's a support article that mentions 3 possible reasons for such failure: bad RAM, bad sectors on the drives, or system partition too small:

I confirmed that after formatting a spare SSD, and after the DSM installation fails, that the SSD drive contains 2 system partitions: 2:38GB and 2.00GB

I also tried all of the above with only the original 2GB module installed, and again with only the 8GB module installed.
I can also telnet to the NAS and login as root, though the busybox ash shell has a limited set of commands, don't think I can get anything useful out of this.

I'm seriously questioning sticking with a Synology box. Anyone ever see this issue?
According to Synology support, the onboard flash is likely the problem. I can't believe this isn't a replaceable part, considering it is not soldered to the main board.

Can it be reflashed?

Synology will blame your memory for corrupting the chip.
Don't see how.
It's total BS. They did say the memory could have done it... After nearly 4 years? Give me a break, it was the upgrade to 7.1 that bricked it.
Isn't that flash only there for boot / recovery? As far as I can tell DSM installation resides in a partition on the drives.
Now even if I eat this, and get a DS720+ to replace it, now my two WD40EFRX are not in the supported list. FML.
Good news, it looks like they can flash an image onto a new chip for me, around $30 shipped. They just need my MAC address and serial number. Totally worth a try in my book, vs. shelling out another $399 for a new NAS. I'll let you guys know how it goes.
$20 for the new USB flash drive on a chip + $9.45 shipping and I'm back in business.
One thing I noticed, the new flash drive showed a valid serial number when discovered via Synology assistant. The old one was blank. They needed the serial # and MAC addresses to be able to flash the new hardware.
Good news, it looks like they can flash an image onto a new chip for me, around $30 shipped. They just need my MAC address and serial number. Totally worth a try in my book, vs. shelling out another $399 for a new NAS. I'll let you guys know how it goes.
I've had exactly the same issues that you've had since "upgrading" to DSM 7, I too had been running Crucial RAM (16GB) flawlessly for four years previously. In my case it just stops communicating and I have to go several reboots and it will eventually restart and perform below par until the next crash. I'm going to see if I can get the same re-flash tool. Thanks for updating the forum on your predicament.
To be clear, it's not a tool. It's a USB flash on a PCB - they need your MAC address and serial number to flash it.

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Welcome to the forum. Your update path should be this: Have you managed to download these...
This is going to be complicated in the long run. Once you update to v6, there are a series of updates to...
I've not seen this, but have never used the mobile app... only PC apps.
  • Question
Any chance the NAS is being blocked in traffic control of router? The screenshots you posted are the Same...
Thanks @BobW ... NFS worked a treat once it was activated and connected via file station ... all good now
Hi, thank you, it was that simple😃. At least my test message went through.
OK... I've lost track of what your end game was. I thought you were converting from a Basic volume to...

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads