DSM 7.2 Update 1 - Not possible to save directly on Diskstation

Currently reading
DSM 7.2 Update 1 - Not possible to save directly on Diskstation

Operating system
  1. macOS
Mobile operating system
  1. iOS
Hello at all,

I am facing a very serious problem which is also very annoying.
I am using a 1621+ and updated to latest 7.2 Update 1 on monday.

Since then I have the following problem:
I connect via Finder to the Diskstation and open a document, e.g. a word document, which is saved on the Diskstation. I
then make some edits and press CMD + S to save it directly. In the past this worked fine, since 7.2 Update 1 it won't work anymore.
The program which tries to save the file freezes, then everything freezes on the Mac and I have to force restart it.

I then restarted the Diskstation and the Mac several times, I also tried a possible SMB settings, but nothing works.
But I noticed one thing: The user I use to connect the Mac to the Diskstation contains a dot (firstname.lastname). When I change that
username to firstnamelastname (i.e. without dot) saving directly on the Mac works again and everything's back to normal.
When I change the username back to a username with a dot, the problems start again and the Mac freezes.

So it somehow must have to do with the dot in the username, which I find strange, because according to the Synology website a dot
is not a problematic character in the username (and I have been using this username since at least 15 years with different Diskstations).

Do you have any idea how I can solve this without having to permanently change the username?

Thank you in advance!
Have you done the update to the latest SMB Service? This was updated recently and probably separately to DSM.

Yes, sure... the latest SMB Service update that is available on Synology's website is installed.
I would raise a ticket with Synology Support. You might try using a + character and see if that also has the problem, and also other similar characters.

I had an issue a while ago where LDAP users would get access to local DSM accounts where the email short name had an equivalent DSM account. For example, LDAP user [email protected] would log into local user fred when using SMB*. It took some back-and-forth with Support but they eventually fixed it. Their idea was to make it easier for people not to have to enter the full email, and hadn't thought through the full scenario.

*Probably a unique situation as I had the two account with the same passwords, since they were for the same person on the same NAS (and Mail Server are protected from outside access, only to receive from email provider's IP range). I use LDAP accounts with Mail Server because the .MailDir is visible in File Station and I didn't want an "I don't use that, I'll delete it" situation. Anyway, this SMB issue resulted logging into a home folder that had nothing but .MailDir and no user files.
I have the same problem since DSM was updated to 7.2 Update 1.
I found in logs that after I press CMD + S in Word or Excel, the SMB user drops connection to the SMB service and immediately recconects. This happens multiple times per second (10+) and continues indefinitely. Word or Excel becomes unresponsive.

@HarryMe: Were you able to find a solution?

Unfortunately, I have no solution to this problem. Synology support tells me they tried it but cannot reproduce the problem so they think I should contact Apple as well.

Maybe you could also contact Synology so that they know it is not an individual problem.
I see.

I opened a ticket on synology in the morning (CET).

I am quite sure the problem is the latest DMS update, which updated SMB package as well. We were using the Diskstation normally up until the upgrade. Immediately after the update the issue appeared. I had no Apple or MS Office updates yesterday, so I do not believe Apple or Microsoft had anything to do with it.
Me too… it immediately happened after the 7.2 update with the new SMB package. I had no Office or MacOS update either. And it only happens with a dot in the username.
In their feedback to me, Synology stated that they are aware of the issue but have not been able to find a workaround or offer a patch. They said they are working on the issue and that a solution should be available in the next DSM 7.3 update. No timeframe was given.

Until then we should work with files locally and transfer them to the Diskstation afterwards. Also they suggested to keep the SMB Package fully updated as new updates may also fix the issue.

I Hope the issue gets resolved fast.
Strangeness happened to me on Friday gone. Suddenly large file transfers started stalling and would crash the Finder (5gb or more).
Couldn't relaunch finder, had to restart!
Eventually noticed that during a large file copy/ or a delete the nas seems to briefly disappear, then appear back in the network list. Tried loads of tweaks with the SMB settings in both dim & osx. Managed to improve it but is still crapping out.

Currently connecting to it using AFP instead which works perfectly and is actually slightly faster.
In their feedback to me, Synology stated that they are aware of the issue but have not been able to find a workaround or offer a patch. They said they are working on the issue and that a solution should be available in the next DSM 7.3 update. No timeframe was given.
Sounds like the type of response I had with my SMB issue. Hope you get a fix soon. Mine got resolved with a temporary fix and then some time later was rolled into an update.
Not a very satisfaying answer.
However, at least they seem to acknowledge thaf there is a problem. In the feedback they gave me they stated that they tried it and cannot reproduce the problem.
For those of you on a Mac, have you tried turning off smb and using afp? There is more on this thread here.


Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Go to your unit's Downloads page and select your preferred DSM version... the page will then show you the...
DSM 6.2.4 is available on your download page. Have you tried that?
My PhotoStation 6 and DS Photo are functioning normally. I am running DSM 6.2.4-25556 Update 7, Photo...
The current version Is dsm 7.1.1_42962 update 1 not sure of the previous dsm but I had to download this...
SSH into your NAS and check the /var/log/messages file for more details. Maybe there you will find some...
  • Question
I’ve not checked my DS218+, which has a scheduled on/off for HB backup destination, but I have noted a...
all my other devices returned fine after this update, except my RS814+.... not sure why or whats going...

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads