DSM 7.0 DSM7.0 won't find Plex server error code 32400/web

Currently reading
DSM 7.0 DSM7.0 won't find Plex server error code 32400/web

Operating system
  1. macOS
Mobile operating system
  1. iOS
Thanks for accepting me on this forum !!
I am hoping somebody can help!!
I have a new DS920+ running DSM 7.0. I have loaded the available Plex (Beta version) App from Packages.
All loaded as expected and as the subsequent support pages I have researched, have confirmed , however when I try to open Plex it comes back with Plex server not responding error code 32400/web.
I have tried various Webb searches but couldn't see a specific "how to"solution for this issue.

Any help in steering me would be much appreciated.

Great support thank you -
I have deleted Plex app completely and restarted NAS.
I have download direct from Plex site and installed manually - Plex Synology DMS 7.0 - 64 bit ( this did not show as a beta version )
I opened Plex and I have the same error !
I have now seen a log on this forum regarding the firewall as a potential issue.
I have turned the firewall ON which was off, I assume by default this is off.
I have added a TCP connection on LAN 1 to 32400 but this still gives me the same error.
To be honest this action is out of my depth now guys, so any advice/instructions greatly appreciated.

Upvote 0
of course;


-- post merged: --

Upvote 0
Using blah.direct.quickconnect.to willl resolve to your ISP IP, if your QC name is 'blah': notice the 'direct' bit of the name and I think it's new in DSM 7.

But accessing using the LAN IP (if you're trying from the home LAN) should work...


If you are having problems then it is most likely due to HTTPS and the SSL certificate not matching the NAS_IP or blah.direct.quickconnect.to that you've used. Mac Safari can be quite finicky about this, even if you've admin authorised the connection to proceed. I usually have to open Keychain Access and change the Trust settings on the certificate to 'Always Trust'.
Upvote 0
Thanks for this help, two steps forward and I think one step back...
I couldn't see a way of steering Plex away from my quick connect link and direct to my local ip without deleting Plex and disabling quick connect. (f there is a way to do this, can someone please update me?)
So did this and reloaded Plex and it connected :) -
Plex advised an update Was required, so manually updated the Plex app and all works as expected even steered to my NAS media folder and it also works.
However when I now enable quick connect Plex switches to the quick connect link and won't connect again !!
Is there a way to stop Plex changing its connection link?
Upvote 0
I've never seen Plex use QC. The Plex apps seem to default to using plex.tv addresses that redirect to my Plex service, or I web browser direct using either the NAS LAN IP or a via my personal domain. If the QC address isn't working then there may be a couple of reasons...
  1. Package Center shows a link that, IIRC, is to HTTP and if you've set your Plex server to only allow HTTPS then this HTTP link won't work.
  2. The QC direct.to address will end up resolving to your Internet IP and if your router doesn't support local loopback* then this request will fail as the router won't know where to direct it.

*local loopback (when supported) will redirect LAN requests to your Internet IP back to the LAN device, when there is a port forwarding rule for the specific TCP/UDP port. In effect it treats requests to forwarded services regardless of whether the request comes from a device on the Internet or the LAN.
Upvote 0
Last edited:
Afair the first setup must be done from a local ip, once the server is claimed with your plex.tv account and remote access is configured, the PMS instance will register itself at Plex's pub/sub service, which is used by clients to know how to contant your PMS instance.

Even if you manage to use a QC address to access Plex, It will "just" load the PlexWeb client stuff from the PMS instance and nothing else .There is no benefit in not using Plex instead.. Once PlexWeb is loaded in your browser it will query the server list and try the shortest path - if you are within your lan, it will use a generated plex domain name that resolves to your internal ip (it's their trick to align the domain name with the https certificate they create for you) - but this requires to add an exlcusion for "plex.direct" in your your router's DNS-Rebind protection.

The only way to "fully" levarage the QC address is to take care of the TLS certificates yourself and register is as "Custom server access url". If configured the Custom server access url will be registered at Plex's pub/sub service and clients will only get this url presented in the future. Been there, done that and concluded it is not worth the trouble!
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Not heard of TVHeadend before. Unless someone comes along that does use it it may help if you add more...

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!