External FTP & web access

Currently reading
External FTP & web access

Screenshot 2021-07-28 at 09.55.01.png


First, make sure that your NAS is accessible from the outside by having access via External Access options in the control panel (QC or DDNS).

Then open the FTP port (or a secure one) on your router, and finally use the client to connect via FTP to your NAS (with a valid account).
 
Thanks for reply.
Already done all that,can access ftp fine through local ip,but not through web address or Quickconnect name.
How can i check my Nas external ip
 
Getting
Code:
[12:10:50] Winsock 2.2 -- OpenSSL 1.1.0e  16 Feb 2017
[12:11:54] [R] Unable to resolve host: ftp://QuickConnect.to/******
[12:11:54] [R] Delaying for 10 seconds before reconnect attempt #1
[12:12:04] [R] Attempting to Reconnect.
Router is forwarded.
Have you set your account permissions to use FTP?
Not sure how to do that?
 
Not sure how to do that?
Under your account details in Control Panel, you can select apps and services that have permission (or not).

The fact that you have been unable to resolve the host, can mean that your nas is really not accessible/visible on the net as it should be. Check port forward again, and check if your firewall is not the problem (on your router and on the nas itself)
 
Sorry new to this,old & disabled.


Try again.


All ports are forwarded in router & have been checked by Canyouseeme.
firewall disabled.


Even tried DMZ


Ip is Virgin media static running through TP-Link router


All i want to do is access DS414 via Ftp from external address.Local works fine.


Ftp client works on port 21 on my other external addresses,just not Synology.


It seems that anything external is blocked by DSM7.


Tried using Quick connect using this format "myid.synology.me" which wont connect,


Also No-Ip ddns,This connects to NAS,as it should,but wont work with ftp
 
Last edited:
Tried disabling Windows firewall,Nas firewall & router firewall,still the same.
getting this on Remote connection setup,This address connects to Nas fine.nasftp.jpg
 
Ftp client works on port 21 on my other external addresses,just not Synology.
You mean that you're running FTP servers on other devices behind your firewall/router? And that you've an Internet IP subnet assigned to map to these devices?

How have you configured the firewall policy on the router to allow these FTP servers to work successfully?

Here's a well written piece on active and passive mode in FTP.

Within Synology FTP service you will have a port range assigned for listening for data connection sessions. Have you opened the router's firewall and NAT to enable these connections?

1627547701742.png
 
Many Thanks for help but think this is all sorted.
Hadn't realise that you cant access external content from local pc.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Had simelar issue last Thursday. Router and 1 NAS worked, 2 NAS’s didn’t! This occurred as I was adding...
Replies
5
Views
709
  • Question
My certificate is confirmed. Did you mean in synology? 1678195913 OK, I set up 2FA on all accounts. This...
Replies
5
Views
2,262
External Access is generally there to configure outside services that will allow for external access like...
Replies
1
Views
2,523
Just to add here that I've had to move to a different platform as I have never found the solution to get...
Replies
5
Views
1,311
Well opening locally and remotely are 2 different scenarios as well as the protocol being used. Try and...
Replies
11
Views
3,025

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top