Faulty DS710+ console access

Currently reading
Faulty DS710+ console access

6
0
NAS
DS-720+
Operating system
  1. macOS
Mobile operating system
  1. iOS
Hi, I don't see any threads relating to DS710+ in Resources or Forums that I should put this three on, so posting here. Please feel free to move if I've missed something.

I have 2 seemingly 'dead' DS710+ NASs. Neither will boot, no matter what I've tried (disconnected everything/removed drives etc). Both give the blue blinking light of death on the Power button LED which never stops. Fan runs, reset doesn't work, sometimes Disk2 and Network LEDs come up. One failed during a power outage, so wondering if contents of USB Flash (or BIOS?) have been corrupted. Don't have the history of the other one.

Have been able to remove and inspect contents of the internal removable USB Boot Flash module (connects to J2) on both units by connecting these to a Linux machine. The file structures are there and look ok, but can't be sure there aren't some anomalies somewhere in the contents of the files, so may need to reconstruct those. There are significant differences between the contents of the USB Flashes of both dead machines, but I don't have another working unit to compare them with to tell whether both are faulty or which one is good/better than the other, so have to assume both aren't good.

Have also tried booting them from a bootable USB stick, but I get no response/change behaviour then either. Have removed and replaced the CR1220 CMOS battery, but not sure if that is critical. And anyway, how do you get in to BIOS to update it if anything needs to be set manually?
Beginning to suspect that I may not even be getting into/through BIOS, or that BIOS itself is corrupt?(presuming that could happen, since I believe the BIOS is updatable?).
In which case, do I really just have two bricks due to unrecoverable firmware changes, or failed hardware/motherboards?(If so, it seems suspicious to me that there are a number of reports around linked to failures tat occurred during a power event).

SO what to do now? Give up? Or persist with trying to see if the hardware actually is trying to work, but can't because of boot loader or BIOS firmware issues?

To do the latter, I need to know where to connect a serial console connection to the board. Read on a German Syno support forum that J4 is the connector to use? But I could not find a J4 on the motherboard, only a JP4 (6 pin header near one of the heat sinked processors), so my guess would be the JP4, or possibly the JP2 header?

1) Can anyone tell me what connector to hook up a JTAG style TTL->Serial/USB cable to, and what pins are what? (Would surely expect the 710+ boards to have some way of getting in to the internals?).

2) Also can anyone confirm that the VGA port should work with a monitor and USB keyboard connected? Should I be able to get into BIOS by holding down Del (or F2?) and expect to see the VGA monitor light up? Or was that option removed from the latest BIOS's. (These boards look like they were both running DSM 5.2 (5967). Should I expect to be able to get system boot progress messages displayed on the VGA monitor, or only the serial console?

3) Where doe the BIOS actually reside? Is it in the chip with the DS710+ V1.00 label on it?) Presumably it would be possible to inspect/change the contents of it once console access is available?

4) Can anyone share a known good USB flash I could compare the 'faulty' ones against? Or is there a way or a procedure I can follow to reconstruct the content of the USB flash module?

5) Can anyone provide insights into how the checksum process works when Syno NAS' boot up? (which checksums are used against what to check file/image integrity? eg checksum.syno, grub_cksum.syno, zImage:Encrypted, rd.gz: Encrypted etc

Or am I just wasting my time? Seems a shame to have to bin some useful devices if all that is really wrong is firmware/software related and fixable!

I have attached a photo of the board showing the jumpers I could find.

Hope someone can help. Many thanks, in anticipation!
 

Attachments

  • DS710+jumpers.jpg
    DS710+jumpers.jpg
    1.6 MB · Views: 65

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top