File system questions

Currently reading
File system questions

6
1
NAS
DS220+
Operating system
  1. Linux
  2. Windows
  1. Is there a list of file systems that can be used in Command Line "mount -t"? I'm loading different drives during the process of copying from my old Linksys NAS200 NAS to Synology DS220+. The file system types in Synology's GNU Linux don't seem consistent with other uses in Ubuntu or the NAS200 Linux. What I'm seeing with one drive may be getting more confused because of the difference between the partitioning scheme and the file systems of the partitions, but nevertheless it's hard to tell - and thus to mount the drive in the Synology box. My Ubuntu system, using 'disks', says that partitioning is Master Boot Record. Synology 'parted' says it's msdos, but 'mount' generates an umbrella error - "wrong fs type, bad option, bad superblock, missing codepage or helper program, or other error" - not helpful.
  2. The Ubuntu box shows the partition I'm interested in as xfs. I don't see any reference to xfs in Synology NAS docs.
  3. The secondary drive from the LinksysNAS uses MBR, and ext2 for partitions. I was able to mount and copy from this to an existing internal drive in the Synology NAS.
  4. It might be a red herring (other than the process), or relevant for other drives with different packages. I installed the ExFAT package from the Package Manager, I don't think it actually started (although I did restart) but perhaps its only relevant to DSM, not the CLI - or external USB drives, not internal. In any case, how does a Package get started?
  5. Are there any community packages with additional file systems?
  6. Is it possible to install an alternative to Synology mount from the Command line which has more file systems? And then remove it after I'm done migrating?

Right now, I'm finessing the issue (I hope) by using my Ubuntu box to copy from the Linksys NAS200 drive to a drive that I want to put in the DS220. It's got GUID partition table and Ext4 file system on the partition. Fingers crossed.

Thanks!s
 
286
95
NAS
DS620slim, DS415+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
  2. iOS
Lots of questions...
Generally, most of your work on file systems is not officially supported.
Most of us would just install disks in the Syno box, choose between BTRFS or ext4, setup the desired raid (1, SHR) configuration or different volumes. Then copy all data over ethernet to the setup, either from your linksys box, Linux or whatever.
The way you describe ( add data on a disk in an external device) may lead to issues and I do not recommend to work like that. You also might get into trouble with permissions etc.

The exfat is for external disks only. The package will activate once needed.

In ancient times I installed disk in the synology (=only possible without raid), took it out and copied data on the large data partition. That worked.
 
Upvote 0
6
1
NAS
DS220+
Operating system
  1. Linux
  2. Windows
Thanks very much @EAZ1964.

I understand the risks, and I'm trying not to do anything that's irreversible. If I have to start over, it's OK at this stage.

Most of what I'm doing sounds like the reverse of what you describe. I want to put drives into the Synology (internal or USB), not take the Synology drive out to populate using another system. One reason for doing more locally is to minimize use of the network (it's not just the Ethernet speed, but also software, and the Linksys was/is very poor at that). But rsync over the network is not fast either (faster than Linksys NAS though).

As far as I can tell, if I can get everything I need on a single drive, then I can add a second drive and make it RAID. And than I can do more consolidation over the network. I'm not great at command line rsync, and my first attempt messed up permissions, but it was quick to correct. Extra question on that topic - I'd like to manually change the user and group IDs for normal users to match what's on other systems to make it clearer. I don't know how easy that would be to accomplish (haven't checked docs yet), but it's probably something that should be tried (if at all) before I reach irreversible.

Thanks for the note on ExFAT. I'm sure I'll be using one or more drives through the USB ports.

The copy on my Ubuntu machine (to the drive that will be placed in the Synology and copied to the existing drive) is going pretty quickly). About 2 hours, 80% complete.

I expect to use GUI and remote sharing 99% of the time after the initial population.
 
Upvote 0
286
95
NAS
DS620slim, DS415+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. Android
  2. iOS
I understand how you would like to do this, but not how you want to prepare a disk outside the synology and add it. The syno will no recognise it and try to format it, as system volume is not ok. I think you will only succeed if you prepare the disk in the synology.
 
Upvote 0
6
1
NAS
DS220+
Operating system
  1. Linux
  2. Windows
It's taken me longer to get back to this than I'd hoped. A power outage after the first round didn't help.

@Telos - thanks for the link. I hope to investigate further as I consolidate other straggling hierarchies. I'm nervous about messing with LVM and filesystems, but it turns out that even ancient NAS200 has references to LVM, and it looks like it might be good to use in a Ubuntu box.

The bulk copy of the 1TB drive was completed, but I thought from the total sizes seen on Windows, that there might have been some missing files. However, as I've just discovered, my interpretation might be incorrect, or only part of the story.

Something got messed up (or I messed up - more likely) with the bulk copy I'd intended to make from the 1 TB drive in the NAS200 to the second 4TB drive in a dock. I think the overall drive was GPT, and the partitions were ext4. The data for the earlier copies was still there, but inaccessible. And I'm not sure if the 1TB copy was complete to that drive before the problems showed up. I played with a couple of tools including testdisk on Ubuntu and then started using the Autopsy front end to Sleuthkit from Windows. That's how I know data is still there, even if the partitions aren't properly set. Autopsy ran out of disk space creating the database, so I put that effort on hold.

Next was using the biggest drive I've got - a 5TB USB drive - and copying from the 1TB NAS200 drive using grsync on the Ubuntu box. Then copying with rsync on the Synology into a Shared Volume on the one populated SATA bay. Because the source drive was a USB drive, I didn't have any reason to further test the assumption that I can copy from one SATA drive to another without turning the source into part of the SHR system. Actually, I think I already proved that works - it's just file systems getting in the way.

That's when I did comparisons of overall drive space used, file counts etc. And I'm pretty sure it's where I went off track with the potential need for repeating with modified parameters. I've been trying to understand why people wrote about rsync being as useful locally as remotely (speed aside) when I was seeing error messages for the destination about "chown filepath/filename operation not permitted (1)". Most references suggested the problem was that the remote system wasn't allowing superuser privileges (to run chown). It took me a long time before I found somewhere that described the file system capabilities for permissions as a limitation. Since the external 5TB drive was intended for the Windows world, and formatted as exFAT, and exFAT doesn't have a permission system that maps to Linux - that's why all the messages were showing up.

There are a few different approaches that I'll be considering going forward. Now that I've got an (out-of-date) version of the NAS200 drives on the DS220+ hopefully I'll be able to stop the consolidation process becoming worse, by cleaning up space as I go. Unfortunately, the drive that's intended to be the second DS220 drive is out of commission, and the largest drive will need clean up before creating a partition that's compatible with the DS220 (file system filter mods from the other post aside). Other than the external drives, (and perhaps one other in a bone pile laptop), everything I have is SSDs and 2.5" hard drives which are 500G max. Decisions decisions.

Thanks for making me think.
 
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

By Default, is off for everyone. I turned it on and behaves much better for my usage (I'm using it for...
Replies
11
Views
322
This just in from Synology no real reason why it doesn't have "File Requests" but I am not supprised I got...
Replies
1
Views
242
Im sorry , the 3rd party App is actually name DS File Browser Which looks exactly as the official Syno app...
Replies
4
Views
361

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Top