Have those issues related to Samsung 870 EVO on Synology NAS been resolved?

Currently reading
Have those issues related to Samsung 870 EVO on Synology NAS been resolved?

53
4
NAS
DS1522+, E10G22-T1-Mini RJ45 10G Ethernet Module
Hello, I read some users complaining that their Samsung 870 Evo SSD failed to function within a few months of use in Synology NAS. What are the real causes? Bad batch? Samsung Evo not playing well with Synology NAS? Bad Firmware? Have all those issues been resolved?
 
There was a Samsung thread seen 6 or so months ago, that listed by model and firmware so users could check—find their unit, and see if their unit was part of issue, needing a firmware update to fix it. That firmware did not reset the % of life lost, prior to repaired firmware—just fixed the issue keeping existing degraded information. Saw some nasty comments on that one.
My unit was ok based on firmware installed.
I have incurred No issues: It’s ~2 years old.
 
There was a Samsung thread seen 6 or so months ago, that listed by model and firmware so users could check—find their unit, and see if their unit was part of issue, needing a firmware update to fix it. That firmware did not reset the % of life lost, prior to repaired firmware—just fixed the issue keeping existing degraded information. Saw some nasty comments on that one.
My unit was ok based on firmware installed.
I have incurred No issues: It’s ~2 years old.

Are you referring to the big issue related to their 980, 990 NVMe SSD?

I wonder if the short lifespan of the 870 EVO in Synology NAS is also caused by that.
 
Last edited:
I read reports of high failure rates. I was concerned about the Samsung cache Devices I purchased for my 720+.

Found the above mentioned location, 6 or so months ago linking model numbers and firmware in a list, indicating which needed firmware updates, and links to download a firmware update per model #. That location also gave instructions for the procedure and software to update firmware, which I seem to recall needing a motherboard access for M2 devices.

That’s all I know: the information exists. Because I only had 2 devices, and normally buy Seagate devices, I did not save location. I do believe it was at Samsungs Support Site. I was lucky: Device & firmware was OK, as I do not have a motherboard with M2 slot! (Had a firmware update would be needed!)
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top