• Hello Guest! SynoForum.com is celebrating its 5th anniversary! 🥳🎉 Read more...

Help required to recover my bricked DS220+

Currently reading
Help required to recover my bricked DS220+

6
1
NAS
DS220+
Hi!!

The story: My DS220+ died recently. After a lot of research and a lot of time lost trying to bring my DS220+ alive I have had lost almost any hope...

Problem is: The internal USB DOM where the bootloader is held, died. I tried to recover data from it but it is impossible, it's burned. I tried to extract files from other friends' NASes DOM modules (other models), like DS218+ and RS21+ but they're not working in my unit (previously i prepared a new usb dom with the correct VID/PID F400/F400) with the SynoBootLoader.efi (from the other friend's models) and the rest of the files from the update packages downloaded for my model. As I could see, in these modern units, the EFI file is tied to the BIOS of the exact model, so only a DS220+ EFI bootloader will work with this model. The main problem is that the efi bootloader and config files (and maybe other files) are not included in the downloadable update packages from synology website, only in the original DOM. I tried to contact with people I know with synology NASes, nobody has a DS220+, only other models, as I tried before. So i feel lost.

My question is, as I think these forums are almost my last chance... could you help me to recover my DS220+ dumping the required files for the DOM? there are multiple options, for example, a /dev/synoboot dump (complete DOM dump) I understand if you don't want to do it, anyway, if the concern is the MAC/serial included in the "vender" (vendor) file, you can omit that file or that partition if you want. Anyway I will change data there to my own MAC/serial in stickers. there is also option to dump the partitions separately /dev/synoboot1 and /dev/synoboot2 , or the separate files (omitting the vendor file).

example of full DOM dump, using ssh: dd if=/dev/synoboot of=/volume1/[yoursharedfolderhere]

You can also get individual files mounting the partitions as FAT (example of doing it here: TUTORIAL: How to mount synoboot in shell to modify grub.cfg)

I would be eternally grateful for this. It would be a pity to throw that valuable piece of hardware because of missing some files...

Thank you in advance!!!!!
 
Merry Xmas to everyone! :)

I continue the investigation, If it's not possible to get the files from a DS220+ , maybe files from similiar models would work, according to the platform.ini:

ID,DS920+
ID,DS720+
ID,DS220+
ID,DS420+
ID,DS1520+

They could have the same signature (required for the secure boot process of the EFI Bios).

I guess that getting the SynoBootloader.efi and .conf files from any of these models would be enough to save this NAS! :)

Anyone?? :D

Thank you again in advance!!
 
What is the correct sytax at the SSH prompt to output the files you need?
 
Hi!
Thank you a lot for replying!!! :)

The easiest and safest way to get the files is to dump the little first partition of the DOM, where they are located. This can be done, once logged via SSH, and being "MYSHAREDFOLDER" the name of a folder you have shared in one of your disk volumes (let's assume it's "volume1"), it can be done with this command:

Code:
sudo dd if=/dev/synoboot1 of=/volume1/MYSHAREDFOLDER/synoboot1.img

If it asks you for password for the "sudo" command, you'll have to type it.

Once the "dd" dump process is finished after a few seconds, you can find the "synoboot1.img" file in the NAS web GUI, in the File Station, in your shared folder you typed above. Then you can download/zip it.


Again, thank you a LOT for helping with this. Let me know if I can help you with something you could need.

And, in addition, If I get this NAS to work again, I'll post a guide with the steps done to recover it, files needed, etc, to be able to help others in the same situation.

Cheers!
 
I will give it a try when I get home from work. What do you think the cause of the failure was?
 
Thank you.
The cause of the failure? I don't know for sure. It stopped booting one day, for no apparent reason. One thing I was thinking about is that last month we had several power outages at home, maybe that had something to do with the failure. Maybe the DOM was defective in some way, that after months of use it died... don't know. I hope this is not a common problem with these models.
 
Happy 2024! :)
I hope this year will be the year of the fix :) I still need help finding the correct files.

CopyAce, any progess? Were you able to make the dump?

Thanks!!
 
Is there any instruction on changing the MAC and serial number? I can’t find it on the Internet.
I can check if any friends have DS220+
Unless I'm mistaken, this seems to be unrelated to this thread other than DS220+. Suggest you create a new one.
 
Hi smyo,

My DS218+ just died recently because of the blue light blinking problem, would you mind sending me a copy of your DS218+ DOM modules? Many thanks in advance!!!
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

I don't have /dev/synobot because the device has not started, I'm accessing to it by telnet. So my problem...
Replies
12
Views
3,526

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top