RT2600ac Help : RT2600ac and a huawey LMT 4G - not working :(

Currently reading
RT2600ac Help : RT2600ac and a huawey LMT 4G - not working :(

12
0
NAS
DS416play
Router
  1. RT2600ac
Operating system
  1. macOS
  2. Windows
Mobile operating system
  1. Android
Hi,

I'm desperately trying this simple usage :

Home network -> RT2600ac -> LMT 4G (internet)

RT config is :

primary interface -
IP address : 192.168.3.2
Subnet : 255.255.255.0
GW : 192.168.3.1
DNS Server : 192.168.3.1
Set as default GW : Enable

LMT config is : DHCP : 192.168.3.1 up to 255

... and this is not working !

When directly connecting a PC to the LMT (wifi or ethernet), it is working fine, I got an IP like 192.168.3.xx and I can surf on the internet.

When connecting the PC to the RT2600, the PC got his local PI Address (192.168.1.xx), I can reach the admin interface of the LMT, using 192.168.3.1, but impossible to go to the internet.

I have to add that when I do the same with my regular dsl ISP Box instead of the LMT 4G, it is working fine...

I'm lost...
 
Last edited:
Hi, I just changed the gateway to do the test you proposed (but maybe I misinterpret you instructions... sorry);
default config is with all parameter in same subnet.
If I remove the primary config, and keep only the secondary, it is not working.
-- post merged: --

Lol,

it's even worst : Now I'm back to normal config (see screen capture), then nothing is working anymore.

The only way to get to the internet is to disable the secondary interface.
I made no change at all on boxes config, only on the RT2600, so my guess is there is a bug somewhere on the router.
I'm a little bored I have to say :/

Capture d’écran 2021-06-18 à 10.34.26.png
 
Upvote 0
I'd have used traceroute as well as ping, as this shows each step of the test.

To go back over the settings, you've got Smart WAN set to LAN1 and failover or load-balancing and failover: load-balancing should use both paths.

On the Smart WAN tab it looks like you can manually switch the active interface.



BTW looking back at your Local Network settings, it's more secure to disable UPnP. This setting allows local devices to configure their own firewall policies on the router. In an ideal world that would be ok, but in an ideal world we won't need a firewall. Instead you should set to disabled and then manually create the firewall policies you want.
1624015366100.png
 
Upvote 0
Hi,

I used failover mode, as I want to use the 4G only for the PC used for my work (through Route Policy).
This is working very well using a simple phone plugged in USB port of the RT2600 by the way.

I think I will stop investigating time trying to use the Huawei and use an old phone instead, if the phone is able to keep the connectivity sharing constantly enabled.

Thanks for the advise about the upnp, will have a look on it.
 
Upvote 0
There was a recent-ish bug fixed in SRM for using a phone as the 4G modem. Whenever it was that I tried by using an old iPhone 6, like you, it seemed to work too. Even have an iPhone 5S knocking about somewhere that might be work. It's all down to having a very occasional need, where mostly it'll be a coupe of hours max. of chill time, vs keeping a SIM card working an data'ed up (i.e. paying for it when it mostly isn't being used).

As for your 4G router, have you thought about having it as a separate WiFi network for users to manually switch to as needed? Not much use for NAS/wired devices but client devices would still get Internet access.

Or if you have [semi-] managed switch you could leave it plugged in and the switch port off, then switch port status for both routers (on/off, on/off) during outage. The 4G router could then have the same or similar LAN setting, but unlikely the SRM WiFi will route back and out via the 4G router.
 
Upvote 0
There was a recent-ish bug fixed in SRM for using a phone as the 4G modem. Whenever it was that I tried by using an old iPhone 6, like you, it seemed to work too. Even have an iPhone 5S knocking about somewhere that might be work. It's all down to having a very occasional need, where mostly it'll be a coupe of hours max. of chill time, vs keeping a SIM card working an data'ed up (i.e. paying for it when it mostly isn't being used).

As for your 4G router, have you thought about having it as a separate WiFi network for users to manually switch to as needed? Not much use for NAS/wired devices but client devices would still get Internet access.

Or if you have [semi-] managed switch you could leave it plugged in and the switch port off, then switch port status for both routers (on/off, on/off) during outage. The 4G router could then have the same or similar LAN setting, but unlikely the SRM WiFi will route back and out via the 4G router.
Hi fredbert,

Thanks for your reply.
Yes, I have thought about using the 4g directly, but : if so, I prefer to directly share a connection from my mobile.
The goal was also to benefits from the RT2600 fail over capabilities in case of primary loss.

Well, it is working well with the mobile plugged in usb... At least.
 
Upvote 0
Grief my typing is awful! :) Well done for wading through it.

If I was going to keep a backup connection paid-up I would opt for the mobile phone or compatible USB modem: it's powered via the RT2600ac; seems to be the least complex to setup. But mine is a home use case not business critical.
 
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Just sharing my experience here. I was getting a little jumpy after having my 2nd Synology router the...
Replies
0
Views
555
All. One minute I can see where to post then I look away and its gone (ok down off the page under...
Replies
0
Views
562
  • Question
The self-signed certificate is created just to enable secure services to work. But you can create a new...
Replies
1
Views
501

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top