Help with DSM Help

Currently reading
Help with DSM Help

Telos

Subscriber
2,839
898
NAS
DS418play, DS213j, DS3622+, DSM 7.2.4-11091
I'm puzzled. Each time I invoke the "?" (Help) feature in Control Panel, it hangs for a bit and then tells me...

8D8Xhov.png


Which is quite obviously wrong since I have concurrent upload/download activity happening.

I briefly disabled the firewall and that had no effect.

Any ideas here? This has to be something basic/simple.... doesn't it?
 

Telos

Subscriber
2,839
898
NAS
DS418play, DS213j, DS3622+, DSM 7.2.4-11091
OK... but did y'all confirm you are using online mode? Any ideas on why this is happening?
 

Telos

Subscriber
2,839
898
NAS
DS418play, DS213j, DS3622+, DSM 7.2.4-11091
Well I'm screwed here... cause some of the installed packages don't seem to have offline help. For example... I tried to bring up USB Copy help and I have no offline source... and online isn't available :mad:

... and my backup NAS has the same issue. My router DNS uses Google DNS... so that should not be an issue.
 

Telos

Subscriber
2,839
898
NAS
DS418play, DS213j, DS3622+, DSM 7.2.4-11091
Well... Synology checked out my NAS and had no issue getting the online help to appear when they logged in with QuickConnect.

I'm still perplexed... this suggests my modem/ISP? (Weirdly though I can get these links via SSH (NAS + curl) and through my laptop browser)... Notably, both my NAS have this issue (only DSM is common to them).

I tried connecting from my laptop using the QuickConnect link, and still online help was unavailable.

My router is using Google DNS, as is the NAS. I could try changing both to OpenDNS, but I doubt that will have an effect. I could also set up an outbound VPN connection from the NAS, and see if results change.

This is odd. Not only am I stuck with offline help, but several installed packages do not install offline help files, so I am left with the browser to access "help".
 

fredbert

Moderator
NAS Support
Subscriber
4,075
1,614
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
  3. RT6600ax
Operating system
  1. macOS
Mobile operating system
  1. iOS
You have a RT1900ac IIRC ... does this also have the same problem?

Other things:
Use a different DSM account.
Try from a new administrator account.
Web browser language or DSM and DSM account language selection issue when accessing the online help?
Different web browser.


I'm trying to think how DSM portal is working.
  1. Test the online help is accessible by creating the URL based on DSM collected info about the hardware etc
  2. If it works then the help window presents the index to the left and a frame to the URL for the specific online help. [I right-clicked to get my browser to open that frame source in a new tab]
  3. It's the browser that gets the actual page but DSM thinks it can't access it.
  4. Would suggest DSM hasn't formed the right baseline URL . Central to this URL is language, DSM version, DSM hardware.
  5. Synology support use their own account to login and the help works? Maybe your account has some corruption?

What do we know:
  • NAS from SSH can access the online help URLs
    • NAS's DNS is working to resolve correctly
    • NAS's MAC address and IP are not blocked from accessing the right URLs
    • Your Internet IP is not blocked from accessing the right URLs
  • Web browser on laptop can access the online help URLs
    • PC's DNS is working to resolve correctly
    • PC's MAC address and IP are not blocked from accessing the right URLs
 

Telos

Subscriber
2,839
898
NAS
DS418play, DS213j, DS3622+, DSM 7.2.4-11091
Last edited:
Other things:
Use a different DSM account.
Try from a new administrator account.
Web browser language or DSM and DSM account language selection issue when accessing the online help?
Different web browser.

Thank you. 🍪🍪🍪

Did all those things and it turned out to be a dynamic browser extension (Privacy Badger) which learned some wrong things. I'm half-embarrassed that I overlooked such a basic issue. Aging is not for woosies.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

  • Sticky
At the moment there's a good chance that questions about DSM 7 will be asked, but not everyone that can...
Replies
0
Views
1,037
I added Crucial CT8G4SFS8266 (1 x 8GB, DDR4-2666, SO-DIMM 260 to my DS920+ and works without any problems...
Replies
3
Views
1,153
As others have mentioned, definitely need some more information. One thing that doesn't sit right with me...
Replies
4
Views
1,342
Hi, I hope someone here can help me! I'm failry new to the Synology ecosystem (got myself a treat during...
Replies
0
Views
1,680
  • Question
I received a message saying that my volume 2 is fragmented and that I need to expand storage capacity...
Replies
0
Views
835
  • Question
Thanks, unfortunately I don't have any other way to test them. I've swapped them around 4 times now with...
Replies
2
Views
754
I was able to get access to my NAS when I was "locked out" using the DS Finder app on my iphone.
Replies
7
Views
1,716

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Top