Help with DSM Help

Currently reading
Help with DSM Help

4,152
1,428
NAS
DS4l8play, DS202j, DS3623xs+, DSM 8.025847-𝘣𝘦𝘵𝘢
I'm puzzled. Each time I invoke the "?" (Help) feature in Control Panel, it hangs for a bit and then tells me...

8D8Xhov.png


Which is quite obviously wrong since I have concurrent upload/download activity happening.

I briefly disabled the firewall and that had no effect.

Any ideas here? This has to be something basic/simple.... doesn't it?
 
Well I'm screwed here... cause some of the installed packages don't seem to have offline help. For example... I tried to bring up USB Copy help and I have no offline source... and online isn't available :mad:

... and my backup NAS has the same issue. My router DNS uses Google DNS... so that should not be an issue.
 
Did you try restarting?
Yes. No effect.
and here is the URL that my DSM links to for it's online view
Thanks. My local browser has no issue loading those links... so my router seems vindicated. Really odd that the NAS have this issue (even with no DSM firewall active).

I filed a support ticket.
 
Well... Synology checked out my NAS and had no issue getting the online help to appear when they logged in with QuickConnect.

I'm still perplexed... this suggests my modem/ISP? (Weirdly though I can get these links via SSH (NAS + curl) and through my laptop browser)... Notably, both my NAS have this issue (only DSM is common to them).

I tried connecting from my laptop using the QuickConnect link, and still online help was unavailable.

My router is using Google DNS, as is the NAS. I could try changing both to OpenDNS, but I doubt that will have an effect. I could also set up an outbound VPN connection from the NAS, and see if results change.

This is odd. Not only am I stuck with offline help, but several installed packages do not install offline help files, so I am left with the browser to access "help".
 
You have a RT1900ac IIRC ... does this also have the same problem?

Other things:
Use a different DSM account.
Try from a new administrator account.
Web browser language or DSM and DSM account language selection issue when accessing the online help?
Different web browser.


I'm trying to think how DSM portal is working.
  1. Test the online help is accessible by creating the URL based on DSM collected info about the hardware etc
  2. If it works then the help window presents the index to the left and a frame to the URL for the specific online help. [I right-clicked to get my browser to open that frame source in a new tab]
  3. It's the browser that gets the actual page but DSM thinks it can't access it.
  4. Would suggest DSM hasn't formed the right baseline URL . Central to this URL is language, DSM version, DSM hardware.
  5. Synology support use their own account to login and the help works? Maybe your account has some corruption?

What do we know:
  • NAS from SSH can access the online help URLs
    • NAS's DNS is working to resolve correctly
    • NAS's MAC address and IP are not blocked from accessing the right URLs
    • Your Internet IP is not blocked from accessing the right URLs
  • Web browser on laptop can access the online help URLs
    • PC's DNS is working to resolve correctly
    • PC's MAC address and IP are not blocked from accessing the right URLs
 
Last edited:
Other things:
Use a different DSM account.
Try from a new administrator account.
Web browser language or DSM and DSM account language selection issue when accessing the online help?
Different web browser.

Thank you. 🍪🍪🍪

Did all those things and it turned out to be a dynamic browser extension (Privacy Badger) which learned some wrong things. I'm half-embarrassed that I overlooked such a basic issue. Aging is not for woosies.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

What do you mean by ‘my root folder’? Are you talking about Linux ‘/‘ or somewhere located on /volume1...
Replies
2
Views
370
After lots of trialing external sharing options (specifically quick connect vs VPN vs reverse proxy), the...
Replies
0
Views
626
Hey @fredbert and @strikes2k. It worked. I created a test-bed with a test camera and Netgear GS308E. Each...
Replies
7
Views
1,920
  • Question
Thank you all for your help I am now able to use the 5tb drive. I reformatted the drive using exfat and...
Replies
13
Views
1,683
For failure rate, the backblaze article on the topic is interesting...
Replies
6
Views
890
Everytime I log into DSM my NAS-connected USB-drives wake up from sleep, even if I'm not in filestation...
Replies
0
Views
586
mind the series and you will be fine None that I have tried to apply
Replies
2
Views
900

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Back
Top