• Hello Guest! SynoForum.com is celebrating its 5th anniversary! 🥳🎉 Read more...

homes permissions messed up somehow

Currently reading
homes permissions messed up somehow

Hi, I am new to Synology. Setting up a DS1618+ and getting it ready for my users. I have enabled User Home Service and home folders are being created under homes shared folder automatically. However, I am noticing that if log a normal user into the NAS and they go to FileStation, they can see the "homes" shared folder, and they can browse to any other users home folder. I assume this is not the correct behavior as I would expect users to NOT be able to reach another users home folder and access the contents.

Perhaps in my initial configurations I have done something that has broken the permissions on the 'homes' shared folder? Can someone review and advise?

Thank you so much!
First, make sure your users are not in the administrators' group.

Second... Did you modify permissions at /homes level, even in the slightest? Only administrators can see /homes if no one mucked with groupings or changed access rights.
I did originally have an issue where I had actually manually created a homes folder before enabling the user home service, which screwed up the home service entirely. I was able to delete my manually created folder and enable the service and it started creating home folders.

I do think I might have figured it out. I turned on the tick box for "Enable Advanced Share Permissions" for the homes shared folder and the 'homes' share is now hidden to my normal users, with their own home directory still being accessible.

Thank you for the prompt reply!
If you are satisfied with that approach... fine. But there is only one way to re-establish default permissions wrt /homes.

1. Disable "user home"
2. Delete the share "homes"
3. Re-enable "user home".

doing so will recreate the share and set the correct permissions.
This is what I did already that led me to this position. Do you know on a normally-created 'homes' share does it have "Advanced Share Permissions" turned on ?
Do you know on a normally-created 'homes' share does it have "Advanced Share Permissions" turned on ?
Got it. I went ahead and just again disabled user home, deleted the shared folder, and reenabled User home and I appear to be working correctly now. Thank you for your time on this, it is very much appreciated!

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Just joined the forum to post that this did help me in the end and how I got this to work for me. I...
worked out what the problem was - schoolboy error. i hadn't created a user on the NAS with the same...
have you tried to use the same account for both apps?
I’ve also noticed a weird date string, although it’s in the log center history and not file sharing

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!