DSM 6.2 How can I restore /usr/sbin/iptables?

Currently reading
DSM 6.2 How can I restore /usr/sbin/iptables?

413j, 918+
Operating system
  1. macOS
Mobile operating system
  1. Android
  2. iOS
In trying to fix another issue, I ran the following command:
ln -sf /usr/sbin/iptables-legacy /usr/sbin/iptables

When that failed to fix the issue, I tried to undo it with the following:
rm /usr/sbin/iptables
...and caused my own demise.

Unfortunately, that broke my Docker images including Bitwarden with the following error
/sbin/iptables: error while loading shared libraries: libxtables.so.12: cannot open shared object file: No such file or directory\n (exit status 127))"}.

I've tried copying what appear to be valid versions from the /volume1/@docker/btrfs/subvolumes/... directory to no avail.
How can I get this up and running again on DSM 6.2.4?
If I copy iptables from another 918+ running 6.2.4, would it come back?

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!