Solved How to browse shared folders without SMB1

Currently reading
Solved How to browse shared folders without SMB1

34
5
NAS
ds1511+, wd red 3TB RAID1, 3GB ram. DS 940+,wd red 3TB RAID1, 12GB ram
I searched, but didn't find anything that seemed current and on point.

My Linux Mint 19.3 (Samba ver 4.7.6) & Ubuntu 18.04 fresh installs don't show the shared folders on my DSM 6.2 DS1511+ nas in their file managers. Nemo & Nautilus respectively.
However MacOS High Sierra can see & connect to the shares in finder.

All machines are on the same LAN segment.

DSM file services > advanced > SMB is set for SMB2 as minimum protocol, with SMB3 as max. If minimum protocol is set as SMB1 I can see the shares.

SMB1 is not being used as too many security issues. Neither on NAS or Linux boxes.

Has anyone got a setup with those Linux versions, No SMB1 and are able to see shared folders?

Both Linux systems have Avahi and Samba installed. Their smb.conf files are "virgin" except for update of workgroup = myworkgroup and client min protocol = smb2.
No domain controllers are used.

I'm aware that eliminating SMB1 breaks many browsing methods and that Synology's WS discovery is broken.

FWIW, the Linux machines can't browse their own shared folders either. I can connect with smb://ipaddr/sharedfoldername/. Just can't browse shares.

There are a bewildering (to me) array of utilities and settings potentially relevant, but I stress that I've not intentionally messed with almost any of it and the Synology Shares used to be visible in Ubuntu & Mint. I think something about installing SAMBA on the Linux boxes broke the ability to see the shares.

Any thoughts very much appreciated!
 
Thanks, but I'm hoping to find a definitive answer that Synology no longer supports Linux share browsing with SMB > v1 before opening the potential NFS can of worms.

What NFS version are you running and with what fstab and security/permissions setup?

Thanks!
 
do you need waste a time with SMB for Lnx, when more reliable NFS is available?
there is support up to NFSv4.1
OFC vulnerable ver. 2 or 3 also (only for LAN)
rest of info you can find in official Syno KB, here
 
just to be sure, when you need use SMB3 as must (and no way use NFS):
1. you need upgrade your SMB client to newest (client side):
Code:
sudo apt-get install cifs-utils
2. then you can mount any shared folder from your NAS to your Lnx, tested, used in my Ubuntu 18.04.3LTS from Files:
Code:
smb://yourNASaddress/YourSharedFolder

I can see in DSM log, that this user from Ubuntu is accessed shared folder via [CIFS(SMB3)]
Done.

Note: I have setup in my NAS for SMB range = SMB2 minimum with Large MTU, preferred SMB3


also you can use also CLI in your Lnx client side:
sudo mount -t cifs -o vers=3.0, user=YOUR-NAS-USER, password=YOUR-NAS-PSW,rw,uid=YOUR-NAS-USER-ID,gid=YOUR-NAS-GROUP-ID //yourNASaddress/YourSharedFolder /YOUR-LOCAL-MOUNT-POINT
Note:
a) mount must be created before
Code:
sudo mkdir /ANYPLACE
b) you can check your NAS UID/GID by command from SSH
Code:
id

and yes there is also possible way put all these into /etc/fstab ...follow fstab rules
just to be sure, don't put your user/psw into fstab :cool: ... google knows why
 
Thanks for the replies.
Note that my issue is not mounting SMB shares. I can always do that just fine.

The issue is BROWSING for the shared folders when I dbl click a hostname in file manager's (Nemo) network folder. I have repeatedly seen this fail to show the shared folders with the error:

"unable to mount location. Failed to retrieve share list from server. Connection timed out."

Rebooting the linux box showing the problem makes the shared folders visible again to browse and connect by dbl click. It can be the case that one linux machine can see the shares while another cannot.

It seems like something responsible for producing the folder share lists breaks over time or with some other activity. Sorry, but I only recently discovered the reboot fixing things.

I regularly check for updates and SAMBA (which I understand is just the server side components) was installed last week.

So a rephrase of my issue is how to determine if the service responsible for folder share browsing is operating correctly? smbd, nmbd, avahi, caching, what???

Thanks!
 
so,
just to be sure, here is prepared scenario for a confirmation (your/mine point of view):

nautilus1.png


It will happen, when you will click to Network/NAS icon?

when yes: did you tried, what was proposed by me in previous post?
because it works - look for an evidence:

nautilus2.png

nautilus3.png

nautilus4.png


you can browse as you wish

when you have still problem with the connection (browsing), we need to check it your samba client:

1. install sambaclient, if does'n exist in your sys
Code:
sudo apt install smbclient

2. try to connect to your SMB server share folder:
Code:
mbclient //NAS-IP/share_name -U username
where username = NAS user

any luck?
 
Note that my issue is not mounting SMB shares. I can always do that just fine.

The issue is BROWSING for the shared folders when I dbl click a hostname in file manager's (Nemo) network folder. I have repeatedly seen this fail to show the shared folders with the error:

"unable to mount location. Failed to retrieve share list from server. Connection timed out."

seems to be you think, that when you see Network/Host icon in Nautilus, then the host is already mounted. This is wrong in your consideration. Your host is just listed, not mounted.
then when you will click to the host, you will receive such Error notification.
 
Thanks for your efforts.

As I've mentioned:
I'm using Mint & Nemo not Ubuntu & Nautilus.
I know what mounting is. E.g., smb://foo.local/Public & supplying SMBpasswd for registered user.

Problem was dbl-clicking a hostname in list of network hosts did NOT produce a list of shared folders on that host.

As it seems to be working now (I get a list of shares) which means it CAN work w/o SMBv1, I'm marking this solved.

Thanks for the help.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Old thread notice: There have been no replies in this thread for quite some time. The last reply was on .
The content in this thread may no longer be relevant. It might be better to open a new thread instead.

Similar threads

I have shared a file which can be downloaded by friends. I was checking the Log Center to see if the file...
Replies
0
Views
468
Try deleting one of those "missing" folders, then recreate it (are you able to delete it?).
Replies
3
Views
1,318
  • Solved
Thank you Actually the reason of this query is for VIPs When VIPs received the link they want a less...
Replies
4
Views
2,233
It's amazing how many tricky concurrency issues in multi-threaded programming get fixed with a...
Replies
12
Views
4,636
Deleted member 5784
D
It does. That's what the web UI of Drive looks like using a web browser.
Replies
3
Views
1,281
If you haven't got the encryption key then you won't be able to decrypt the shared folder. If it was...
Replies
1
Views
3,231

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Back
Top