hyper backup between versions

Currently reading
hyper backup between versions

3
1
NAS
ds1621+, ds1515+
Operating system
  1. Linux
  2. Windows
Mobile operating system
  1. Android
How to backup whole nas

Hi I have a ds1621+, which replaced a ds1515+. I'd like to now use the 1515 as a backup for the 1621.

My first idea was to use hyper backup, but the 1515 cannot run dsm later than 7,1, while the 1621 runs the current dsm7.2, and the the hyper backup on dsm7.2 (v 4.1.0) refuses to talk to the hyper backup vault as old as the latest version available for dsm7.1 (v 3.0.2)

Is there a way to get compatible versions of hyper backup on dsm 7.1 and 7.2?

Is this limitation a good reason to steer well clear of hyper backup? (a half-decent backup package SHOULD be able to work between different versions!!) ?

Or is there a better solution than hyper backup?

I'm currently using a home-grown solution using rsync, but that only backs up the shared volume content, and not dsm and dsm configs.
 
This should work just fine for data segment. I have a number of 7.2 and 7.1.1 (HB 3.0.2) machines and 7.2 > 7.1.1 (HB 4.1 > 3.0.2) works with 0 issues.

Are you using the default proprietary format or some other method when starting the wizard?

but that only backs up the shared volume content, and not dsm and dsm configs
Full DSM and config backup can only be done using using HB with the following conditions (if you are using the Entier System option):

While Hyper Backup does work on every single device, this new feature has limitations and prerequisites.

In order to have this full system recovery feature active, these are the requirements:

  • DSM 7.2 or better
  • Hyper Backup 4.1 or better
  • Hyper Backup Vault must be installed on the remote Synology NAS to store the backup data.
  • The backup data of the entire system can only be restored on the same model or its successor.
In terms of model support the list is extensive, but not all devices will support this feature. The "value" and "J" models are unsupported, as well as some high-end models. Also, considering that DSM 7.2 is a prerequisite, this means that no model older than x15 can't be used. But on top of this HB 4.1 has a minimum 2018 generation model, so taking all this into consideration the final list of supported models is this:

FS series: FS6400, FS3600, FS3410, FS3400, FS2500, FS1018
SA series: SA6400, SA3610, SA3600, SA3410, SA3400
23 series: RS2423RP+, RS2423+, DS1823xs+, DS923+, DS723+, DS423+
22 series: RS822RP+, RS822+, RS422+, DS3622xs+, DS2422+, DS1522+, DVA1622
21 series: RS4021xs+, RS3621xs+, RS3621RPxs, RS2821RP+, RS2421RP+, RS2421+, RS1221RP+, RS1221+, DS1821+, DS1621xs+, DS1621+, DVA3221
20 series: RS820RP+, RS820+, DS1520+, DS920+, DS720+, DS620slim, DS420+, DS220+
19 series: RS1619xs+, DS2419+II, DS2419+, DS1819+, DS1019+, DVA3219
18 series: RS3618xs, RS2818RP+, RS2418RP+, RS2418+, DS3018xs, DS1618+, DS918+, DS718+, DS418play, DS218+


If you do want a full DSM backup on top of data, you might want to use Active Backup for Business and see if that will work for you. ABB is much faster then HB when it comes to full system.
 
Upvote 0
This should work just fine for data segment. I have a number of 7.2 and 7.1.1 (HB 3.0.2) machines and 7.2 > 7.1.1 (HB 4.1 > 3.0.2) works with 0 issues.

Are you using the default proprietary format or some other method when starting the wizard?


Full DSM and config backup can only be done using using HB with the following conditions (if you are using the Entier System option):

While Hyper Backup does work on every single device, this new feature has limitations and prerequisites.

In order to have this full system recovery feature active, these are the requirements:

  • DSM 7.2 or better
  • Hyper Backup 4.1 or better
  • Hyper Backup Vault must be installed on the remote Synology NAS to store the backup data.
  • The backup data of the entire system can only be restored on the same model or its successor.
In terms of model support the list is extensive, but not all devices will support this feature. The "value" and "J" models are unsupported, as well as some high-end models. Also, considering that DSM 7.2 is a prerequisite, this means that no model older than x15 can't be used. But on top of this HB 4.1 has a minimum 2018 generation model, so taking all this into consideration the final list of supported models is this:

FS series: FS6400, FS3600, FS3410, FS3400, FS2500, FS1018
SA series: SA6400, SA3610, SA3600, SA3410, SA3400
23 series: RS2423RP+, RS2423+, DS1823xs+, DS923+, DS723+, DS423+
22 series: RS822RP+, RS822+, RS422+, DS3622xs+, DS2422+, DS1522+, DVA1622
21 series: RS4021xs+, RS3621xs+, RS3621RPxs, RS2821RP+, RS2421RP+, RS2421+, RS1221RP+, RS1221+, DS1821+, DS1621xs+, DS1621+, DVA3221
20 series: RS820RP+, RS820+, DS1520+, DS920+, DS720+, DS620slim, DS420+, DS220+
19 series: RS1619xs+, DS2419+II, DS2419+, DS1819+, DS1019+, DVA3219
18 series: RS3618xs, RS2818RP+, RS2418RP+, RS2418+, DS3018xs, DS1618+, DS918+, DS718+, DS418play, DS218+


If you do want a full DSM backup on top of data, you might want to use Active Backup for Business and see if that will work for you. ABB is much faster then HB when it comes to full system.

I was trying 'entire system' backup

now I'm trying again.

1 reinstalled hb on 1621 and hb vault on 1515.
2 set up a backup task for 'folders and packages' with just two small folders as a test.
3 Seems to work !
4 then trying again with 'entire system' backup - that's when I get the version mismatch error.

So Thanks for your help - I'll now experiment to see if the 'folder and packages' backup option does all that I need.

I presume that on an empty 1621, I'd first install dsm afresh, then restore those configs and folders that I needed. This looks
like something I'd be satisfied with, so no real need for entire system backup.
 
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Old thread notice: There have been no replies in this thread for quite some time. The last reply was on .
The content in this thread may no longer be relevant. It might be better to open a new thread instead.

Similar threads

  • Question
I thought and did the same. I did fresh run and created new backup job...Ongoing...
Replies
7
Views
678
  • Question
HB/HBV updates are tied to the underlying DSM and may not be available unless your DSM is current. For...
Replies
3
Views
787
The documentation in that DSM 7 article is dated. It has evolved over time. There are still issued with...
Replies
1
Views
667
That option will work ofc and if time is a factor then use this method. USB copy also have several options...
Replies
1
Views
748
I bought some storage in a server to use Hyper Backup to drop my offsite backup in. However, I have not...
Replies
0
Views
943
No, at that time that was not v4. I can confirm that 4.1 beta for example will not be compatible with...
Replies
4
Views
1,870
HB would be a way to go, but it depends what settings you have selected on the initial HB wizard. Direct...
Replies
1
Views
1,218

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Back
Top