Hyper Backup not compatible with Hyper Backup Vault

Currently reading
Hyper Backup not compatible with Hyper Backup Vault

5
1
NAS
DS1621+,DS218+,DS1513+
Operating system
  1. Linux
  2. Windows
Mobile operating system
  1. iOS
Lat year I replaced my DS1513 with a DS1621+ which I am happy with however I want to make use of my DS1513+ and thought that it would be good to use as a backup store for my main DS1621+. So after reading some of the forums here I decided to try Hyper Backup.

I have installed Hyper Backup v4.1.0- on my DS1621+ ( running DSM 7.2.1-69057) and Hyper Backup Vault v3.0.2 on the DS1513+ (running DSM 7.1.1-42962 Update6 ) only to find that Hyper Backup would not run due to the Hyper Backup Vault not being the latest version but I cannot update Hyper Backup Vault to v4 as it requires DSM 7.2 which is not available to download for the DS1513+.
This seems crazy to me that Synology will not let me use the DS1513+ for such a simple task.
I could not find earlier versions to roll back Hyper Backup to v3.0.2 so was wondering if anyone had any suggestions to get round this or suggest another way to backup the DS1612+ to the DS1513+.

Thanks in advance.

Keefer
 
There is the alternative to running Hyper Backup to another DSM NAS running Hyper Backup Vault: Hyper Backup task to rsync server. I did this to an old NAS before I had a spare/old DSM NAS.

DSM has rsync server capability in Control Panel / File Services. Enable this on the old NAS and create a task on the new NAS using backup destination File Server -> rsync.

HBV adds a slightly easier way to do NAS to NAS tasks, and you get so see:
  1. Backup stats, same as in HB on the source NAS
  2. Text summary of the task config, so what you see and can edit on the source NAS
  3. Version list, same as... you know what I'm going to say
  4. Log specific to this task, but you can see logs in HB on the source NAS
 
@keefer, that's strange. I use a DS920+ to make a backups to a DS713+. It is working without problems with exactly the same DSM, Hyper Backup and Hyper Backup Vault versions as on your systems.
 
@keefer, that's strange. I use a DS920+ to make a backups to a DS713+. It is working without problems with exactly the same DSM, Hyper Backup and Hyper Backup Vault versions as on your systems.
Now you mention it, I just tested from my DS218+ (DSM 7.2.1) Hyper Backup 4.1.0 to DS215j (DSM 7.1.1) Hyper Backup Vault 3.0.2. Created a small task to backup DNS and LDAP servers, and the task ran without any alerts or errors.

I was assuming this had been tested and wasn't working.
 
Last edited:
Maybe this will help


Guessing you want to backup 1621 to 1513 right?
Thank you for the older version link

Guessing you want to backup 1621 to 1513 right?
Absolutely to make use of the old Nas.
-- post merged: --

There is the alternative to running Hyper Backup to another DSM NAS running Hyper Backup Vault: Hyper Backup task to rsync server. I did this to an old NAS before I had a spare/old DSM NAS.

DSM has rsync server capability in Control Panel / File Services. Enable this on the old NAS and create a task on the new NAS using backup destination File Server -> rsync.

HBV adds a slightly easier way to do NAS to NAS tasks, and you get so see:
  1. Backup stats, same as in HB on the source NAS
  2. Text summary of the task config, so what you see and can edit on the source NAS
  3. Version list, same as... you know what I'm going to say
  4. Log specific to this task, but you can see logs in HB on the source NAS
Thank you Fredbert it's good to know that there are alternative methods available.
-- post merged: --

@keefer, that's strange. I use a DS920+ to make a backups to a DS713+. It is working without problems with exactly the same DSM, Hyper Backup and Hyper Backup Vault versions as on your systems.
Thank you for letting me know.
This is really odd because I just tried again and after the handshake login it wont let me choose a destination folder as
I get this popup warning of the incompatibility.
I have attached a screenshot.
I cannot think of another reason why it would give this error.
Does anyone have any suggestions?
 

Attachments

  • hbv_incom.png
    hbv_incom.png
    151 KB · Views: 50
Last edited:
Just to add the remote HBV version is shown in the attachment.
As you can see according to the notes this is the latest version and it was last updated in order to be compatible with HB v3.02. So I am wondering how come that your same versions do not give this error and also whether HBV does need an update to be compatible with HB v4.1.0 without DSM7.2. (unlikely due to DSM7.2)
It looks like I am stuck with this.

When I look at the Synology package download site for the DS1513+ this is the latest version available.

Of course for the DS1621 you are offered HBV version Version: 4.1.0-3718 which as it says requires DSM 7.2.
It looks like I may have to rollback HB after all.

 

Attachments

  • HBVver302.JPG
    HBVver302.JPG
    41.6 KB · Views: 18
If you're getting the error that's stops mixing HB v4 with HBV v3 then that's makes it a no-go, and I don't know why I and @Hoorna can have this working.

While I tested DS218+ HB v4 to DS215j HBV v3, my day-to-day usage it to use my DS218+ as the Hyper Backup destination (HBV and rsync) for all my NAS, where I only really care about data and services on the DS1520+. So that means the DS215j HB v3 is targeting the DS218+ HBV v4.

If this is being problematic I would just use rsync task types since you aren't losing much [any] functionality that isn't available on the source NAS.
 
If you're getting the error that's stops mixing HB v4 with HBV v3 then that's makes it a no-go, and I don't know why I and @Hoorna can have this working.

While I tested DS218+ HB v4 to DS215j HBV v3, my day-to-day usage it to use my DS218+ as the Hyper Backup destination (HBV and rsync) for all my NAS, where I only really care about data and services on the DS1520+. So that means the DS215j HB v3 is targeting the DS218+ HBV v4.

If this is being problematic I would just use rsync task types since you aren't losing much [any] functionality that isn't available on the source NAS.
Thank you fredbert for your response.
I agree and I guess that if I use the HB v3 the Synology is likely to keep nagging me to apply the update anyway.

So am looking to go down the rsync route and create a script then set a scheduled task for a periodic run.
Does the script need to live in a specific folder or can I place it anywhere?

Also I created a direct connection between the two to create a separate network. So will need to steer the rsync down this network.
 
You are welcome! Glad that you got it eventually working.

You can still create a Synology support ticket and ask what is causing your issue. If I were you than I would be a little concerned if things are not working as expected (because the underlying reason for the disfunctioning is still unknown).
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

  • Question
That will work with 4.1 version. Looks like user feedback has been implemented.
Replies
4
Views
1,006
Well in a way this is expected. Your DSM6 machine (host) is still on an older version and anything other...
Replies
1
Views
604
  • Question
A bit odd tbh. Not sure how the name could be a factor here as Synology doesn't have a list of all bucket...
Replies
4
Views
993
Not sure what to say... I have about 5-6 separate tasks towards C2 and not a single time on any of them...
Replies
3
Views
1,230
Sorry, I do not know how to write a script for this but I am confused and have a question. Maybe there is...
Replies
1
Views
957
Adding some info. In fact when setting up your Hyperbackup you can opt to not only backup folders...
Replies
3
Views
1,214

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top