Hyper Thread Authetication failed

Currently reading
Hyper Thread Authetication failed

10
0
Operating system
  1. Windows
Mobile operating system
  1. Android
Hi all

I am having an issue with Hyperback up at the moment, i have a Synology NAS as my main NAS and a Qnap TS231P(Given as a gift) as a backup.

I have set up rsync job on the Hyper Back up on the Synology and Hybrid back up on the Qnap with no issues, i have performed the initial backup which went perfectly, once either the Synology or Qnap restarts the rsync job on the Synology displays Authentication failed.

I have hit the re-authentication button but it does nothing the target still stays offline, i have also tried reentering the Qnaps user name and password but i get the following "Authentication failed. Please check the authentication credentials"

I have checked and rechecked the Qnaps log in user name and password and they are correct
 

Rusty

Moderator
NAS Support
2,503
754
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
So this is done in LAN or over the Internet?

Have you checked if the rsync port on Qnap (target) side is still open and working? Sometimes you get authentification error and it turns out that it was unable to authenticate because of port not being open.

How did you exactly set up this job on HB side? Did you use a single file method?
 
10
0
Operating system
  1. Windows
Mobile operating system
  1. Android
Last edited:
So this is done in LAN or over the Internet?

Have you checked if the rsync port on Qnap (target) side is still open and working? Sometimes you get authentification error and it turns out that it was unable to authenticate because of port not being open.

How did you exactly set up this job on HB side? Did you use a single file method?
Hi Rusty, thank you for the response

This I done over my network, yeah the rsync is using 873 and open on both devices

I set up in Hyper sync by selecting add data sync Task,
rsync copy,
selected rsync compatible server, Qnap IP, user name and password
Selected the folders
and replicated.

Funny thing is I tried creating another job the same as I did before and it wont accept the credentials but if I delete the job and create it the same way again it will work until I reboot the QNAP or the Synology and the same thing will happen
 

Rusty

Moderator
NAS Support
2,503
754
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Try and check /var/log/messages via ssh for more details on the error. Maybe there will be a bit more details there apart from the authentification error.
 
10
0
Operating system
  1. Windows
Mobile operating system
  1. Android
Try and check /var/log/messages via ssh for more details on the error. Maybe there will be a bit more details there apart from the authentification error.
Ok that went a little over my head sorry
 

Rusty

Moderator
NAS Support
2,503
754
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
ok sorry..

you should be able to log into your NAS using SSH protocol. Depending on your OS of choise, this can be done using Terminal app on Linux/Mac or PUTTY on Windows.

To make this work, go to your DSM control panel > terminal section and enable ssh (port 22 by default). After that open Terminal/putty and use the following command:

ssh [email protected] and hit return. Then enter your password when asked.

This will land your in the command line. To access messages file you will need to open it as root. So now you need to 1st elevate your account to root access. Do this by typing:

sudo -i then enter your usual DSM user password that you used in step 1. If you have done everything correctly, your should see root as your new command line prompt.

Now time to access the messages file. Type:

cat /var/log/messages and hit return. This will open up the messages file and you can view it. Now initiate your HB task again and when it fails, check the log. Just CAT into it again to refresh it.
 
10
0
Operating system
  1. Windows
Mobile operating system
  1. Android
ok sorry..

you should be able to log into your NAS using SSH protocol. Depending on your OS of choise, this can be done using Terminal app on Linux/Mac or PUTTY on Windows.

To make this work, go to your DSM control panel > terminal section and enable ssh (port 22 by default). After that open Terminal/putty and use the following command:

ssh [email protected] and hit return. Then enter your password when asked.

This will land your in the command line. To access messages file you will need to open it as root. So now you need to 1st elevate your account to root access. Do this by typing:

sudo -i then enter your usual DSM user password that you used in step 1. If you have done everything correctly, your should see root as your new command line prompt.

Now time to access the messages file. Type:

cat /var/log/messages and hit return. This will open up the messages file and you can view it. Now initiate your HB task again and when it fails, check the log. Just CAT into it again to refresh it.

HiuRusty I did as you suggested but its Alien to me
 

Attachments

  • Synology log.txt
    923 bytes · Views: 5

Rusty

Moderator
NAS Support
2,503
754
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Hmm not 100% sure about this, but are you sure those are all the lines that are covered with this "attempt"? Last 2 lines I think have nothing to do with it as they state that there was an error running a curl command that's going to the internet towards a synocommunity repository (3rd party). Think those 2 are not connected.

The 2nd and 3rd line are connected with HB and they are reporting an error with parsing global_def.h file in line 70 on a path that I do not see on the NAS, so not sure what's going on there.
 
10
0
Operating system
  1. Windows
Mobile operating system
  1. Android
Hmm not 100% sure about this, but are you sure those are all the lines that are covered with this "attempt"? Last 2 lines I think have nothing to do with it as they state that there was an error running a curl command that's going to the internet towards a synocommunity repository (3rd party). Think those 2 are not connected.

The 2nd and 3rd line are connected with HB and they are reporting an error with parsing global_def.h file in line 70 on a path that I do not see on the NAS, so not sure what's going on there.
Yeah sorry about that I cut it off bugger it

will shoot you the whole log via pm if ok
 

Rusty

Moderator
NAS Support
2,503
754
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Well, nothing special in there regarding HB tasks that you already send. I would say this is still a traffic problem of some sort at some level. One way to be sure is to SSH into your Synology NAS and test 873 port towards your Qnap NAS.
 
10
0
Operating system
  1. Windows
Mobile operating system
  1. Android
Well, nothing special in there regarding HB tasks that you already send. I would say this is still a traffic problem of some sort at some level. One way to be sure is to SSH into your Synology NAS and test 873 port towards your Qnap NAS.
Hey ZRusty, thanks mate, what is the command on Putty to run from the Synology to test the port on the Qnap?

I got a folder sync going from the Qnap to the Synology but as soon as I create a one way or two way rsync job to the Qnap I get an authentication error no matter what Qnap user ID I use be it the default Admin or other one I create
 

Rusty

Moderator
NAS Support
2,503
754
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
You could install telnet command line on syno side and then do this from ssh command line: telnet qnapipaddress 873

You will get connected or refused message.
 
10
0
Operating system
  1. Windows
Mobile operating system
  1. Android
You could install telnet command line on syno side and then do this from ssh command line: telnet qnapipaddress 873

You will get connected or refused message.
Thanks man, OMG is there an easy way to install Telnet command line ot the Synology?

Would it help resetting the Qnap to factory default seeming this is the issue area?
 

Rusty

Moderator
NAS Support
2,503
754
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Would it help resetting the Qnap to factory default seeming this is the issue area?
Well not sure what qnap problem might be... but if you are certain that the traffic is working and the username and pass are correct then do it. Before that, you could try and just turn off/on rsync on qnap side... maybe thats the problem, before you nuke the whole think.
 

fredbert

Moderator
NAS Support
Subscriber
1,700
692
NAS
DS1520+, DS218+, DS215j
Router
  1. RT2600ac
  2. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Since DSM doesn't include command line telnet or nc (netcat) then you can try a bit of a hack using curl. It's really for getting web resources but you will get some fedback if the port is active even if it's not a web server listening...

curl <IP address>:<port number>
curl <domain address>:<port number>
 
10
0
Operating system
  1. Windows
Mobile operating system
  1. Android
Well not sure what qnap problem might be... but if you are certain that the traffic is working and the username and pass are correct then do it. Before that, you could try and just turn off/on rsync on qnap side... maybe thats the problem, before you nuke the whole think.
Hey mate, yeah just before I was about to reset the Qnap I thought I would turn off the.
On the rsync then I just you say the same thing (great minds) I reentered the same user name and password and created a new job in Hyper sync and it worked, I logged out of the Synology and back in then ran the back up again with no probs.

I restarted the Qnap and during that time the startup of the Qnap was showing off line on the Synology as expected. When the Qnap came back up that Authentication error error came up on the Synology again and I would enter the same user name and password and it would not work.
I went back to the Qnap and turned off rsync, turned it back on and entered the same user name and password as I had used before , went back into the Y ology and hit reauthorize and it worked.
i tried restarting the Qnap again about an hour later and same thing happened , so it seems each time the Qnap reboots it looses its settings
 
10
0
Operating system
  1. Windows
Mobile operating system
  1. Android
Since DSM doesn't include command line telnet or nc (netcat) then you can try a bit of a hack using curl. It's really for getting web resources but you will get some fedback if the port is active even if it's not a web server listening...

curl <IP address>:<port number>
curl <domain address>:<port number>
Thank you Fredbert, I will do some reading
 

Rusty

Moderator
NAS Support
2,503
754
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
I went back to the Qnap and turned off rsync, turned it back on and entered the same user name and password as I had used before , went back into the Y ology and hit reauthorize and it worked.
As I suspected then. Looks like the problem with rsync element on the qnap side then. Any updates pending on qnap side? latest OS running etc?
 
10
0
Operating system
  1. Windows
Mobile operating system
  1. Android
As I suspected then. Looks like the problem with rsync element on the qnap side then. Any updates pending on qnap side? latest OS running etc?
Hi no updates available at this stage, bugger it I am ongoing to hit the setup and see what happens
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Similar threads

Similar threads

Trending threads

Top