Improving NAS performance

Currently reading
Improving NAS performance

687
226
NAS
DS918+
Operating system
  1. macOS
Mobile operating system
  1. iOS
I'm looking to improve NAS performance and speed up the machine to get the best out of the resources. I own a DS918+ and the packages I've got installed are:

Screenshot 2022-10-19 at 13.23.23.jpg


I'm considering:
  • OAuth Service - Is this really needed and can it be safely removed?
  • Log Center - For day to day operation can it be disabled, or is that not wise?
  • Antivirus Essential - As you can see I've got this turned this off. I've full powerful AVs running on all client machines so I don't think it's needful.
  • PHP 7.4 - Needed by Web Station, but I could upgrade to PHP 8.0, however this means both PHP systems would be running in parallel which I guess would take more resources?
I can't see anything else I can change to save resources? Any suggestions guys re the above or any settings changes?
 
Solution
AV is one thing that I always found "wtf", but I'm a Mac user so AV is not something that I ever looked at as something mandatory. I don't have it on any of my boxes (ever).

Log Center will not "save" you in terms of resources as the default Log center will still run in the background and this "enhanced version" will just remove some added features.

Oauth I think is one of those "built-in" services that you will not be able to remove.

PHP x version (other than those that you have installed) can't be removed as the OS uses them under the hood (even outside WebStation being installed), just presented inside the Package Center (like File Station for example).

This is all part of the DSM separation of specific apps/modules in order to...
Last edited:
Couple new pieces of information:
First... EDIT: Windows Discovery settings in SMB Must remain ON -- when icons are created at Windows end (7-64 and 10 Pro)

Second.. Did the same thing with Task Scheduler Script file as root: to shut down and remove Active Insight

synopkg stop ActiveInsight && synopkg uninstall ActiveInsight
 
Upvote 0
And the saga continues.......

As of yesterday afternoon the IOW problem had returned with it varying between 20-37%. A lot of deep thought went into this much of it during a restless night.

The only things which had changed yesterday was that we'd suffered a 3 second drop in our Virgin Fibre connection, and for some reason after that the Orbi router had stopped logging external attacks so I'd rebooted it.

Very illogically, the IOW changes occurred after that reboot.

So this morning I checked the Orbis logs, and noted many instances of DHCP allocations being repeated:

[DHCP IP: 192.168.1.100] to MAC address 56:ef:7e:c4:88:d7, Friday, October 21, 2022 22:32:57
[DHCP IP: 192.168.1.100] to MAC address 56:ef:7e:c4:88:d7, Friday, October 21, 2022 22:27:46
[DHCP IP: 192.168.1.100] to MAC address 56:ef:7e:c4:88:d7, Friday, October 21, 2022 22:22:43
[DHCP IP: 192.168.1.101] to MAC address 36:85:14:9d:43:64, Friday, October 21, 2022 22:20:43
[DHCP IP: 192.168.1.100] to MAC address 56:ef:7e:c4:88:d7, Friday, October 21, 2022 22:20:01
[DHCP IP: 192.168.1.101] to MAC address 36:85:14:9d:43:64, Friday, October 21, 2022 22:19:52
[DHCP IP: 192.168.1.100] to MAC address 56:ef:7e:c4:88:d7, Friday, October 21, 2022 22:19:00

These continued through to this morning. So I rebooted the Orbi yet again.

Lo..... and indeed behold ........ The Orbi is now no longer giving out multiple IPs to devices, and IOW & CPU loading looks to be back to 'normal', that is:
Screenshot 2022-10-22 at 11.33.28.jpg

Screenshot 2022-10-22 at 11.33.36.jpg


Sheesh...... and I thought I'd retired .....
 
Upvote 0
Last edited:
I ran into an equivalent with Zito & T3& T4 cable errors this year, causing multiple DHCP releases & renews. Ended up being amp downstream of entire development. Finally fixed a month ago. We were all complaining but only when we compared notes at HOA meeting did we determine it was all happening simultaneously. Zito call center in another state with no maps, and never caught on until I called after meeting with subdivision map in hand with names they could find in their database! Then their guy met me and I gave them my printouts and community map. Fixed in 2 weeks! Be happy it was your modem!
 
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Welcome to the forum. Occam's razor suggest that you moved, not copied the data that would explain this...
Replies
1
Views
456
  • Question
I had a similar issue. I went through all the stuff in this thread, but eventually I solved it. I also...
Replies
2
Views
526
FYI you can attach multiple Plex servers to the same Plex account: they appear in the list of servers when...
Replies
8
Views
995
Thank you, Rusty, for your reply. I especially appreciate the photo of the HDD brackets with 2.5” drives...
Replies
4
Views
573
I try to keep things simple. I use mapped drives via SMB to my NAS to store data. Keep as little as...
Replies
4
Views
742
I’ve multiple 1TB Drives, sitting on shelf, now without a home. Starting from 1TB Drives. I’d upgrade...
Replies
3
Views
573
From what I understand..... If I'm wrong, please correct me! The update needs these rules to be allowed...
Replies
10
Views
1,160

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Back
Top