Inconsistent NFS mount success, LINUX mint

Currently reading
Inconsistent NFS mount success, LINUX mint

6
1
NAS
DS218j
Operating system
  1. Linux
  2. Windows
Mobile operating system
  1. Android
Hi, I am effectively a LINUX novice but am trying to mount the shares of my DS218j successfully using NFS.

This NAS has approx. 5 shared folders, however I only managed to mount one of them successfully.

DSM gives me the mount names of the shared folders in the bottom left corner in the edit shared folder NFS tab as:

/volume1/Data

/volume1/homes

/volume1/photos

/volume1/music

Using the command

sudo mount -t nfs 192.168.1.122:/volume1/homes /synology-nas/Files

mounts the homes folder successfully in the assigned directory and will not echo anything.

Now if I intend to mount the remaining shares using the same mount point I am not successful, for e.g. /volume1/Data the server replies:

Created symlink /run/systemd/system/remote-fs.target.wants/rpc-statd.service → /lib/systemd/system/rpc-statd.service.

mount.nfs: mounting 192.168.1.122:/volume1/Data failed, reason given by server: No such file or directory

This is whether I have umonted the previous share or not and also using identical parameters as used with the successful share.

The mount path names are spelled exactly as displayed in DSM and typed accordingly, all capitalisation is correct. All settings parameters for the other shares are the same as /homes. If I go back into DSM edit shared folder data at times it complains that NFS needs activating, but going into the settings reveals of course it is ticked as “active” (and /homes is mounted with NFS).

I want to finally fully transition from Windows and I am not successful using SMB while there is a VPN connection. Sadly I seem to fail with LINUX with fairly elementary functionality like this or trying to print a page successfully :)

If anyone has a suggestion as to what might be going on here I’d appreciate your help!

Using LINUX mint 21 mate Vanessa




Thanks




Michael
 
Are the problematic shares encrypted? If so, have you decrypted them before trying to mount them?

Have you created an NFS share for the shared folder(s) (Control Panel, Shared Folders, edit the share)?
 
Upvote 0
Expanding on Fortran's comment:
also, I think you mount command should look apx. like this:
mount.nfs: mounting 192.168.1.122:/volume1/Data /home/data
Last bit "/home/data" is the mount-point, where Synology share is mounted.
Create folder /home/data, before mounting.
That is, if you want Synology "data" folder to be mounted in your (linux mint) home folder.
 
Upvote 0
No, the shares are not encrypted.
No, /volume1/Data is not the mount point. It is the mount path as displayed in the Shared folder details:

1698262854818.png


/synology-nas/Files is the mount point where I want the share to be mounted.


@Opti990:~$ sudo mount -t nfs 192.168.1.122:/volume1/Data /synology-nas/Files
[sudo] password for family:
mount.nfs: mounting 192.168.1.122:/volume1/Data failed, reason given by server: No such file or directory


As I said I am using the identical command to the one that is successful except for swapping the mount path to what is as it is displayed in the snap above and I get the No such file or directory result for all but the /volume1/homes share.

Sometimes
1698263082940.png


is displayed but NFS is running and it is ticked as an active service. I can access the /volume/homes share successfully.
Hope that explains things a little better.

Thanks

Michael
 
Upvote 0
Try running the mount with a -vvvv flag to see if there are any more helpful details when it fails. My hunch is it's something amiss in your Mint client, but it's only a hunch. Do you have any other *nix boxen you could try mounting from?
 
Upvote 0
Good idea, u see I am not versed in these commands yet and I cannot make much of the info:

family@Opti990:~$ sudo mount -vt nfs 192.168.1.122:/volume1/music /synology-nas/Files
mount.nfs: timeout set for Wed Oct 25 23:11:03 2023
mount.nfs: trying text-based options 'vers=4.2,addr=192.168.1.122,clientaddr=192.168.1.112'
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options 'vers=4,minorversion=1,addr=192.168.1.122,clientaddr=192.168.1.112'
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options 'vers=4,addr=192.168.1.122,clientaddr=192.168.1.112'
mount.nfs: mount(2): No such file or directory
mount.nfs: trying text-based options 'addr=192.168.1.122'
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 192.168.1.122 prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=17
mount.nfs: trying 192.168.1.122 prog 100005 vers 3 prot UDP port 892
mount.nfs: mount(2): Permission denied
mount.nfs: mounting 192.168.1.122:/volume1/music failed, reason given by server: No such file or directory


Not sure if there is a version conflict and it stryign to downgrade? This is what is set in DSM:
1698272098946.png



Thanks!
 
Upvote 0
Last edited by a moderator:
The output shows the Mint client trying with NFS v4.2 & 4.1 and failing to negotiate these with the NAS, but succeeding with v4, before this then fails with No such file or directory. This all looks as you'd expect it to tbh. I'm assuming those IP addresses for the NAS and the client are correct?

There's nothing weird with the permissions of the 'Data' share that fails vs the 'homes' share that succeeds is there? I'd expect a different error msg if it was a regular permissions problem, but sometimes permissions issues can raise other more opaque errors.

Do you have any other Linux or MacOS device you could try issuing the mount cmd from, just to rule out your Mint client config being the culprit?
-- post merged: --

Also, just check the status of the rpc.bind service on the Mint client: sudo systemctl status rcp.bind
This should be enabled and running (it prob is as your mount of /homes worked but just check it anyway).
-- post merged: --

Also, worth trying the mount forcing nfs v3: sudo mount -vt nfs -o nfsvers=3 192.168.1.122:/volume1/music /synology-nas/Files
 
Upvote 0
Last edited:
Thanks verymuch for your input Fortran!

I best paste some output here from the commands, the rcp.bind (whatever that is, no idea yet) does not exist.
1) bind command
2) trying to mount /music
3 trying to mount /homes (which works but also seems to output some strange stuff, this time with -v
4) umount /homes

family@Opti990:~$ sudo systemctl status rcp.bind
[sudo] password for family:
Unit rcp.bind.service could not be found.
family@Opti990:~$ sudo mount -vt nfs -o nfsver=3 192.168.1.122:/volume1/music /synology-nas/Files
mount.nfs: timeout set for Thu Oct 26 20:29:41 2023
mount.nfs: trying text-based options 'nfsver=3,vers=4.2,addr=192.168.1.122,clientaddr=192.168.1.112'
mount.nfs: mount(2): Invalid argument
mount.nfs: trying text-based options 'nfsver=3,vers=4,minorversion=1,addr=192.168.1.122,clientaddr=192.168.1.112'
mount.nfs: mount(2): Invalid argument
mount.nfs: trying text-based options 'nfsver=3,vers=4,addr=192.168.1.122,clientaddr=192.168.1.112'
mount.nfs: mount(2): Invalid argument
Created symlink /run/systemd/system/remote-fs.target.wants/rpc-statd.service → /lib/systemd/system/rpc-statd.service.
mount.nfs: trying text-based options 'nfsver=3,addr=192.168.1.122'
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 192.168.1.122 prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=17
mount.nfs: trying 192.168.1.122 prog 100005 vers 3 prot UDP port 892
mount.nfs: mount(2): Invalid argument
mount.nfs: an incorrect mount option was specified
family@Opti990:~$ sudo mount -vt nfs 192.168.1.122:/volume1/homes /synology-nas/Files
mount.nfs: timeout set for Thu Oct 26 20:33:02 2023
mount.nfs: trying text-based options 'vers=4.2,addr=192.168.1.122,clientaddr=192.168.1.112'
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options 'vers=4,minorversion=1,addr=192.168.1.122,clientaddr=192.168.1.112'
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options 'vers=4,addr=192.168.1.122,clientaddr=192.168.1.112'
family@Opti990:~$ sudo umount /synology-nas/Files



Hopefully this gives some insight.

Michael
-- post merged: --

BTW I jsut tried a Laptop w LINUX mint, same version and I get exactly the same results.
/homes works, the rest won't.

Cheers

Michael
 
Upvote 0
Last edited by a moderator:
Sorry, typos galore at my end:
1) bind command test should be: sudo systemctl status rcpbind.service. Worth testing this but as I said likely shows as enabled and running, which means all is good.
2) the version 3 test should be: sudo mount -vt nfs -o vers=3 192.168.1.122:/volume1/music /synology-nas/Files - but tbh there's no point trying as your log above confirms that nfs version 4 is working for both client and NAS (per the /volume1/homes example).

fwiw I created a number of nfs mounts of Synology shares to my Macbook using your same settings outlined in post #4 above and all worked as expected.

Having created a dir called 'test' in my home directory, the command I used was eg sudo mount -t nfs 192.168.1.11:/volume1/photo test I tried using both the built-in shares like 'music' and 'photo', as well as custom shares like 'data' I created from scratch. All worked 1st time.

I'm afraid other than the bind test i'm out of ideas. Your test with another laptop rules out a weird config issue on the client (unless its a problem specific to Mint, which I doubt), so this suggests maybe something with the Syno. I note your comment about the occasional 'NFS service is not enabled' warning - this could be something worth pursuing with Synology.

Also, as mentioned above just check that permissions on the 'Data' share on the NAS are resonable and similar to those on your 'homes' share, eg does the NAS admin have at least read access to the share etc. Permission issues generally result in a different 'permission denied' error, but sometimes you get other errors due to them.
 
Upvote 0
rcpbind:

family@Opti990:~$ sudo systemctl status rcpbind.service
Unit rcpbind.service could not be found.


I have found the problem:
1698356122965.png

For the other shares "/" was actually a colon. Not sure if it should be there at all.

NFS not activated comes up more and more now. Odd!
Need to read up on the permissions still, not clear to me.


I created a few more folders under /synology-nas:

family@Opti990:~$ sudo mount -vt nfs 192.168.1.122:/volume1/photo /synology-nas/photo
mount.nfs: timeout set for Thu Oct 26 22:32:08 2023
mount.nfs: trying text-based options 'vers=4.2,addr=192.168.1.122,clientaddr=192.168.1.112'
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options 'vers=4,minorversion=1,addr=192.168.1.122,clientaddr=192.168.1.112'
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options 'vers=4,addr=192.168.1.122,clientaddr=192.168.1.112'
family@Opti990:~$ sudo mount -vt nfs 192.168.1.122:/volume1/Data /synology-nas/Data
mount.nfs: timeout set for Thu Oct 26 22:33:59 2023
mount.nfs: trying text-based options 'vers=4.2,addr=192.168.1.122,clientaddr=192.168.1.112'
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options 'vers=4,minorversion=1,addr=192.168.1.122,clientaddr=192.168.1.112'
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options 'vers=4,addr=192.168.1.122,clientaddr=192.168.1.112'

Does the above mean that protocols are negotiated and only vers 4 eventually works properly?

It works now, thank you very much for your help, in the end it was my incompetence of course.

Now I need to get it into the fstab, adventures in LINUX :))

Cheers

Michael
 
Upvote 0
Bingo - you got there in the end!

The '/24' is CIDR notation which defines a subnet mask; this is how you specify an entire range of IP addreses rather than just a single address. In your eg above, 192.168.1.122/24 should more correctly be written as 192.168.1.0/24 and this means all the IP addresses between 192.168.1.0 and 192.168.1.255.

If you're saying you put a colon in there, this is used to denote a port number at an IP address; putting one in that field should have been picked up by that form's field validation and likely either stripped off or the value rejected.

The above protocol negotiation indeed shows client and server settling on NFSv4.

hth
 
Upvote 0
@MikeP

I think your actual problem was that you were trying to mount all your folders to the same mountpoint "/Synology-Nas/Files". You first mapped "/Synology-Nas/Files" = "homes". Then you try to map "/Synology-Nas/Files" = "Data" as well as "/Synology-Nas/Files" = "music" onto an existing "mount" ("/Synology-Nas/Files") without first doing an "unmount" command.

UNLESS.. you left out a lot of information that you show in post #10 ("I created a few more folders"). At this point you mounted each into its own folder under "/Synology-Nas".

"/Synology-Nas/photo" = "photo" and "/Synology-Nas/Data" = "Data" AND "/Synology-Nas/Files" may still be pointing to "homes"

It seems your original idea might have been to mount all folders as such "/Synology-Nas/Files/homes", "/Synology-Nas/Files/Data". But I'm only guessing here...

Of course I could be totally wrong, but it's the vibe I get from reading this thread...

@Fortran.. Not sure why Synology would allow having a colon in there. It didn't complain with the below even though it's not one of the valid formats shown under "i". Maybe just ignoring ":24"?

Screenshot 2023-11-23 at 12.05.32 PM.png
 
Upvote 0

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Hey All, I have recently been playing with 2.5Gbe usb Nics, I previously had a single share via NFS to...
Replies
0
Views
897
Hello, I am running a DS218play with DSM 7.0 I have it configured for LDAP through Jumpcloud. I have...
Replies
0
Views
1,575
Sorry, I thought I could edit my post but I can't see where to do that. Some additional info: I have also...
Replies
1
Views
3,320
I am trying to connect a shared synology folder to my debian. I am more a Windows guy, so i am trying but...
Replies
0
Views
556

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Back
Top