Installing MailCow on Synology NAS

Currently reading
Installing MailCow on Synology NAS

DS216+II, DS118, DS718+, DS720+
  1. RT2600ac
  2. MR2200ac
Operating system
  1. Windows
Mobile operating system
  1. Android
Last edited by a moderator:
In this thread I still find it too expensive to be able to add 5 mailboxes to Synology MailPlus. I've heard MailCow is a good alternative as it provides an entire mailsuite like MailPlus.

Prepare your system - mailcow: dockerized documentation


Mailcow on Synology


So, this can't run in Synology Docker. But apparently I can use Synology Virtual Machine Manager, set up a virtual linux server. Then setup docker inside that VM and try to install Mailcow from there. Thats why I don't know where to post... :)

I've never installed Linux (yet?). I've downloaded the Ubuntu 18.04 server image ISO file (from the official website). So I'm trowing myself straight into the deep..

Here we go:

Stay tuned..? :|
Installed the Ubuntu with OpenSSH access so I can optionally also manage it via Putty from my Windows machine. Installation was kinda straight forward. I did find it interresting that the distro comes with nice extra's straight out-of-the-box, like Docker:


However, the MailCow installation guides recommends not to use the Docker engine that comes with the distro as it may not be the latest version:

Also made a snapshot in VMM, altough I do not see yet how I can safeguard this VMM snapshot to another NAS of mine in another location.

Oh, and Installing the Synology Guest agent in this VM is probaly a good idea: apt-get install qemu-guest-agent
Last edited:
Following the instructions from here: Installation - mailcow: dockerized documentation

I seem to have successfully managed to install MailCow on the Ubuntu VM running on my NAS. :)



First time I've seen a multi-containerized application/service. Pretty cool:

Anyway, the domains I want to test MailCow with already have SSL certs. MailCow seems to have a LE container to generate certs, but I don't want it do to that.

On this page I found the answers I need. To disable the auto-generate of certs, but also how to use my own SSL certs. My lack of Linux knowledge comes to play, cuz I cant seem to figure out how to get files from my NAS into this Ubuntu VM. I tried stuff like:

rsync /path/on/nas user@vm:/path/on/vm

But I'm constantly getting:
rsync: mkstemp failed: Permission denied (13)

EDIT: This video helped me alot:
To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.
So I've changed the group permissions so my normal account can do write operations in the certs folder. The above exampled rsync command worked.
Which version of Ubuntu server did you install? Do you have a link?
I have tried Ubuntu ubuntu-20.04.1-live-server-amd64.iso. but It won't install keep getting a installer loop
Installation instructions:

Fresh VM Ubunti installation

Ubuntu 18.04.5 LTS (Bionic Beaver)

Do not install additional packets during OS setup like Docker .

Install new Docker engine
sudo apt update
sudo apt-get install apt-transport-https ca-certificates curl gnupg-agent software

curl -fsSL | sudo apt-key add -
sudo apt-key fingerprint 0EBFCD88

sudo add-apt-repository "deb [arch=amd64] Index of linux/ubuntu/ $(lsb_release -cs) stable"

sudo apt update
sudo apt-get install docker-ce docker-ce-cli

Install Docker Compose
sudo curl -L "$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose

sudo chmod +x /usr/local/bin/docker-compose
sudo ln -s /usr/local/bin/docker-compose /usr/bin/docker-compose

sudo usermod -aG docker %USERNAME%

Install Mailcow
sudo apt install git
cd /opt
sudo git clone mailcow/mailcow-dockerized
cd mailcow-dockerized

sudo ./

sudo docker-compose pull
(wait for download to complete)

sudo docker-compose up -d

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Old thread notice: There have been no replies in this thread for quite some time. The last reply was on .
The content in this thread may no longer be relevant. It might be better to open a new thread instead.

Similar threads

Hello, I was able to restore a VM Thread even though I was told that it was NOT possible and with BTRFS...
Location are here /volumeX/@Repository /volumeX/vdsm_repo.conf And what do you know... Apparently they...

Welcome to! is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads