Solved Installing Resourcespace

Currently reading
Solved Installing Resourcespace

20
1
NAS
DS216+
Progress! I've got to the installation page of ResourceSpace - so thank you for that, though its not accepting the MySQL Server - I've tried localhost and 127.0.0.1 and the local IP but none are being accpted
 
20
1
NAS
DS216+
One last question, its currently working on myddns.synology.me:8888
Can I get it to work with mydomain.co.uk
 
1,822
757
NAS
DS220+ : DS1019+ : DS216+II : DS118 : DS120j : APC Back UPS ES 700 — Mac/iOS user
Last edited:
You’re the man. Do you happen to know anything about a thing called MongoDB and how to make it work with another thing called Rocket chat (both are containers on something called Docker)?

Not in hurry at all. Anytime this year would do. Thanks :)
 
20
1
NAS
DS216+
I've hit a stumbling block, normally to get ResourceSpace to process images you would run the staticsync.php which is in pages/tool which I dont have access too, this would be set to run as a cron job every hour
 
Last edited:
@kevinneal: i have no idea about the appilcation, though you could add a task in your snyo and fire a hourly task with following command: 'docker exec resourcespace /var/www/html/staticsync.php'. Not sure about the path to staticsync.php though - according the Dockerfile /var/www/html is the root location of the embedded apache server.
 
You’re the man. Do you happen to know anything about a thing called MongoDB and how to make it work with another thing called Rocket chat (both are containers on something called Docker)?

Not in hurry at all. Anytime this year would do. Thanks :)
Thread hijacking is not how forums are supposed to be used. Open a thread and we will see.
 

Rusty

Moderator
NAS Support
3,636
1,049
www.blackvoid.club
NAS
DS718+, DS918+, 2x RS3614RPxs+
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
I was merely asking. Don't worry about it. No need. Thanks.
I told you I will give you a hand with it... I'm running several RC instances ;) There was a change on MongoDB side when moving up from 0.73 to 1.0 RC so there will be a need to explain this matter.

Considering I'm tight with time I didn't make a resource on the matter, and I was planing on it. Will try to write it up with some pictures as well and hopefully that will be enough to kick off the topic.
 
1,822
757
NAS
DS220+ : DS1019+ : DS216+II : DS118 : DS120j : APC Back UPS ES 700 — Mac/iOS user
I told you I will give you a hand with it...
Thanks @Rusty. I know I can count on your vast knowledge and help. It’s just that I see you’re not around very often so it’s obvious that you’re very busy. Didn’t want to bother you with it. And as I said it’s not urgent.

I just saw that this thread was winding down as the issue here was solved so I asked. But “hijacking” is not allowed.
 

Rusty

Moderator
NAS Support
3,636
1,049
www.blackvoid.club
NAS
DS718+, DS918+, 2x RS3614RPxs+
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Well I'm sure that @kevinneal will mark it as solved soon and we can def start a new thread for any other platform.
 
20
1
NAS
DS216+
@kevinneal: Not sure about the path to staticsync.php though - according the Dockerfile /var/www/html is the root location of the embedded apache server.

I tried "sudo docker exec resourcespace /var/www/html/pages/tools/staticsync.php" which I think might be the right path, but got this error:

rpc error: code = 2 desc = oci runtime error: exec failed: container_linux.go:247: starting container process caused "exec format error"
 
20
1
NAS
DS216+
ok "sudo docker exec resourcespace php /var/www/html/pages/tools/staticsync.php" seems to run the process.

But another error, as its trying to find the folder "/volume1/Clients" it can't see it, is that because its not looking outside of the container?

The staticsync.php is what processes the images and imports them into ResourseSpace, so in the RS config you set a folder for it to process, for me this is /volume1/Clients on the synology
 
20
1
NAS
DS216+
Oh I'm getting the hang of this - just needed to make a volume in the container setting

I'll go ahead and close this now, I have a working ResourceSpace installed that is importing my assets from the synology automatcally.

Once again thank you so much, really appreciate your patience :)
 
uhm, a container can never see anything from the host, except what it is allowed to see.
If you want any folders to be accessible inside the container, you have to map them from the host to the container...
 

Rusty

Moderator
NAS Support
3,636
1,049
www.blackvoid.club
NAS
DS718+, DS918+, 2x RS3614RPxs+
Router
  1. RT1900ac
  2. RT2600ac
  3. MR2200ac
Operating system
  1. macOS
Mobile operating system
  1. iOS
Thanks @Rusty. I know I can count on your vast knowledge and help. It’s just that I see you’re not around very often so it’s obvious that you’re very busy. Didn’t want to bother you with it. And as I said it’s not urgent.

I just saw that this thread was winding down as the issue here was solved so I asked. But “hijacking” is not allowed.
There is a new post in the resources section for RC.
 
1,822
757
NAS
DS220+ : DS1019+ : DS216+II : DS118 : DS120j : APC Back UPS ES 700 — Mac/iOS user
Thanks a million for this one @Rusty :)
I'll be dedicating the weekend to this with a nice brew of my finest Earl Grey.

I'll be coming back with some questions/problems for sure. As nothing goes as planned.
 
1
1
NAS
1515+
Operating system
  1. Linux
  2. macOS
  3. Windows
Mobile operating system
  1. iOS
Great resource - esp one-eyed king. Addendum to entry #22 - I used MariaDB instead of MySQL (almost the same - but not) and when I entered the docker container name / server name I got failure to process MySQL errors from RS. Checked both the RS & MariaDB docker logs and saw that my user was being rejected.

I SSH'd into the NAS, then DOCKER PS into the container, checked with MySQL and found my user name password etc specified in the environment variables was not present. I added that user - but @localhost - , granted full access and nada. Checked the logs again and saw my user wasn't @localhost but @IP. Went back into the MariaDB, DROP USER @Localhost user, ADD USER w/@IP, granted, purged then stopped and restarted the service just to be sure.

Stopped and restarted the RS container, processed the setup page...clicked the button an viola - RS is up and running. Whew. I know I blew thru this explanation but if it's needed I can go thru each setup entry by entry if anyone needs it.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Top