Jellyfin - VAAPI hardware transcoding

Currently reading
Jellyfin - VAAPI hardware transcoding

245
47
NAS
DS918+, DS414j
Operating system
  1. Linux
  2. Windows
  3. other
Mobile operating system
  1. Android
Hi, I'm running Jellyfin (tried both 10.6.4 and 10.7) in a container on my DS918+ and am trying to use VAAPI transcoding to transcode from 4K to 1080p when not at home (Yes I know we're all at home all the time at the moment but I'm planning ahead).
Has anyone got this working?
I've got the built in ffmpeg to recognise the device /dev/dri/renderD128 and claims to be using it but I'm still not getting above 10-15 fps.
The transcode folder is on an SSD (but the file itself resides on an HDD)
Plex appears to be able to transcode the file fast enough but I don't want to use Plex or get a Plex pass.
My docker compose is attached.
 

Attachments

  • docker-compose.txt
    833 bytes · Views: 207

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Back
Top