Link shortener

Currently reading
Link shortener

33
34
www.adrianearnshaw.com
NAS
1819+
Router
RT2600ac, MR2200ac
Operating system
Linux, Windows
Mobile operating system
Android
If it's any consolation I get the same problem. When I access the port I have yourls on I get the Apache message that I do not have permission to access the resource.

Maria is running as I have several apps using it.
 
33
34
www.adrianearnshaw.com
NAS
1819+
Router
RT2600ac, MR2200ac
Operating system
Linux, Windows
Mobile operating system
Android
If I enter my NAS ip followed by the port number I get the Apache message. If I append admin to the URL then I get another page, this time a splash screen saying RTFM.

For the avoidance of doubt the URL used is http://nas ip address:3000/admin which takes me to the splash screen.
 

Attachments

Rusty

Moderator
NAS Support
1,826
562
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
RT1900ac, RT2600ac, MR2200ac
If I enter my NAS ip followed by the port number I get the Apache message. If I append admin to the URL then I get another page, this time a splash screen saying RTFM.

For the avoidance of doubt the URL used is http://nas ip address:3000/admin which takes me to the splash screen.
Do you have YOURLS_SITE variable defined pointing to your own domain?
 
33
34
www.adrianearnshaw.com
NAS
1819+
Router
RT2600ac, MR2200ac
Operating system
Linux, Windows
Mobile operating system
Android
Thanks for getting back. If I put that environment variable in the config file and enter my NAS ip address and port 3000 it redirects to the domain name and 404 not found.
 

Rusty

Moderator
NAS Support
1,826
562
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
RT1900ac, RT2600ac, MR2200ac
Thanks for getting back. If I put that environment variable in the config file and enter my NAS ip address and port 3000 it redirects to the domain name and 404 not found.
Are you running with docker?
 

Rusty

Moderator
NAS Support
1,826
562
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
RT1900ac, RT2600ac, MR2200ac
Thanks for getting back. If I put that environment variable in the config file and enter my NAS ip address and port 3000 it redirects to the domain name and 404 not found.
That variable is an environment variable, no need to put it in the config file

Yes, using the settings you suggested in the short tutorial and substituting in my NAS ip address for the mariadb.
Not sure I understand 100% this. Would it be a problem to post back how your container (yourls) is setup?
 
33
34
www.adrianearnshaw.com
NAS
1819+
Router
RT2600ac, MR2200ac
Operating system
Linux, Windows
Mobile operating system
Android
Okay, I have attached the Environment Variable entries that I have used. I did get it to the login screen where it asked for my username and password but even though I have set the variables it will not let me login. Naturally, I had to blank out the entries but to give you an idea of what I entered into the blanked out bits:-

YOURLS_SITE - somedomain.com
YOURLS_DB_HOST - 123.456.7.8:3306
YOURLS_DB_USER - dbusername
YOURLS_DB_PASS - dbpassword

I set some variables for YOURLS_USER and YOURLS_PASS in the vain hope that this would let me access the admin part.
 

Attachments

Rusty

Moderator
NAS Support
1,826
562
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
RT1900ac, RT2600ac, MR2200ac
Check your config.php file and search for:

Code:
$yourls_user_passwords = array(                                                                                                                           
  getenv('YOURLS_USER') => getenv('YOURLS_PASS'),                                                                                                         
  'yourusername'    =>      'passwordxxxxxx'
If it's missing, add your values here and restart the container and then try and log in. More info here
 
Okey - now its running. Great! Thank you very much @all!

But can someone please tell me the default user/password for SSH connection? I defined the Passwort for admin login in the docker values. But I cant change the password again. Its not working.
 
Last edited:
Can someone please tell me how to edit the config while running it in a docker container? I want to change the password set on first installation.

Best regards
PD
 

Rusty

Moderator
NAS Support
1,826
562
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
RT1900ac, RT2600ac, MR2200ac
Can someone please tell me how to edit the config while running it in a docker container? I want to change the password set on first installation.

Best regards
PD
Are we talking about link shortener here or what password exactly? Also, how does your mapping look like regarding this container?
 
Yes - the yourls admin password for entering the webgui. The value fot user/pw in the docker container were used for the installation, but I cant change it afterwards. Unfourtunately I dont know how to change the Docker Image through the terminal,
 

Rusty

Moderator
NAS Support
1,826
562
www.blackvoid.club
NAS
DS412+, DS718+, DS918+, 2x RS3614RPxs+ with expansions
Router
RT1900ac, RT2600ac, MR2200ac
Yes - the yourls admin password for entering the webgui. The value fot user/pw in the docker container were used for the installation, but I cant change it afterwards. Unfourtunately I dont know how to change the Docker Image through the terminal,
Do you have a config file for that container mapped (/var/www/html/user/config.php)? Inside it you can define user and pass (previous posts)
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Top