Manually Enabled TLER Setting Being Disabled After Hibernation

Currently reading
Manually Enabled TLER Setting Being Disabled After Hibernation

5
0
NAS
DS418
I recently set up a DS418 NAS populated with 2 WD Ultrastar 8TB drives for volume 1 (sda + sdb), and 2 WD RED 3TB drives for volume 2 (sdc + sdd).

I have somewhat followed the instructions here to enable TLER for the 2 Ultrastar drives, since TLER is NOT enabled by default for these drive, but they are capable of it

https://www.reddit.com/r/DataHoarder/comments/9gk3ic
I have used the following modified entries in the /etc/rc.local startup script:

/usr/bin/smartctl -d sat -l scterc,70,70 -i /dev/sda
/usr/bin/smartctl -d sat -l scterc,70,70 -i /dev/sdb

SCT Error Recovery control starts and shows enabled, until the drives go into hibernation mode. Once they wake up from hibernation, it's disabled.

Any ideas? Thanks in advance!
 
5
0
NAS
DS418
Last edited:
That’s what I’m doing with my rc.local script. I just hard coded the drives identified since sda and sdb are the only drives that need it turned on. My RED drives are already enabled.

My rc.local file looks like this:
#!/bin/sh
/usr/bin/smartctl -d sat -l scterc,70,70 -i /dev/sda
/usr/bin/smartctl -d sat -l scterc,70,70 -i /dev/sdb
exit 0

As I mentioned, it turns on OK, but gets disabled after the drives hibernate. This is the strange issue.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to SynoForum.com!

SynoForum.com is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!

Trending threads

Top