Mariadb10 password strength on DSM 7.01-42218

Currently reading
Mariadb10 password strength on DSM 7.01-42218

DS920+ DS416 DS418 DS218+ DS214play
Last edited:
Hello all.

NOTE: I have solved the issue by editing the users table in the MYSQL database and generating a new password in the password field (type PASSWORD) and then copying the value to the authentication_string field. Not elegant but it will solved some problems temporarily

Here's my issue. I updated today to DSM 7.01 from DSM One of my apps requires access to MariaDB. I have already migrated (a while back) my db files from MariaDB5 to 10 . My issue is the access from the app. The app is hardcoded with a password that doesn't meet the minimum requirements of MariaDB10. Before I updated to DSM 7.01, I was able to edit (by ssh) the my.cnf file by commenting out the synology_password_check = FORCE_PLUS_PERMANENT and the plugin_load_add = synology_password_check lines. These lines don't seem to exist ANY MORE in the current my.cnf files which are located at /volume1/@appstore/MariaDB10/usr/local/mariadb10/etc/mysql and /usr/loca/mariadb10/etc/mysql .

Any ideas?


Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Welcome to! is an unofficial Synology forum for NAS owners and enthusiasts.

Registration is free, easy and fast!